Showing 1-20 of 46 entries
Feb 21, 2018 @ 5:49am
In topic Valentine's Day update, Linux
I've been playing around with this a bit, and it does appear to at least be related to that bug. My Corsair M65 mouse gets detected as a joystick by udev.

There are definately some inconsistencies though.

I can unplug the mouse and starting Descenders fine, then when I reconnect the mouse after it's started both inputs work and the game runs fine. However, if I do it the other way round (unplug the controller and start it up) it crashes almost immediately.

I've also tried disabling udev's insistance on adding the mouse as a joystick, but it doesn't seem to help with this particular bug -- though it fixed another Unity game not detecting the some of t he controller buttons (with the same multiple joysticks problem).

This was also working fine prior to the valentines update and works completely fine if I don't have steam running (though I loose my profile information).

Also, my mouse and the controller both had duplicate /dev/input/js* directories, but Unity doesn't seem to mind this (and as mentioned above, seems to ingore when I actually remove all but my controller directory).

I can get around it at least, so it's not as big of a deal as it was for me, but it's still very annoying.
Feb 15, 2018 @ 10:39am
In topic Valentine's Day update, Linux
Sent, thanks.
Feb 15, 2018 @ 8:48am
In topic Valentine's Day update, Linux
Similar issue here, with a generic xbox controller clone (it does also use the xboxdrv driver though). With it plugged in the game crashes on loading after the early aceess notice / controller recommended info screen, with it unplugged it works fine.

What's strange is, running the game without steam running also works (and the controller input works fine). However, my profile information is not being used so it's not really a good workaround.

This also applies to both the .x86 and .x86_64 binaries and running either from the command line doesn't seem to provide any insights other than the regular mono verbosity:

$ ./Descenders.x86_64
Set current directory to /mnt/steamdirs/hdd2/steam/steamapps/common/Descenders
Found path: /mnt/steamdirs/hdd2/steam/steamapps/common/Descenders/Descenders.x86_64
Mono path[0] = '/mnt/steamdirs/hdd2/steam/steamapps/common/Descenders/Descenders_Data/Managed'
Mono config path = '/mnt/steamdirs/hdd2/steam/steamapps/common/Descenders/Descenders_Data/Mono/etc'
Preloaded 'ScreenSelector.so'
Preloaded 'libfmod.so'
Preloaded 'libfmodL.so'
Preloaded 'libfmodstudio.so'
Preloaded 'libfmodstudioL.so'
Preloaded 'libgvraudio.so'
Preloaded 'libresonanceaudio.so'
Player data archive not found at `/mnt/steamdirs/hdd2/steam/steamapps/common/Descenders/Descenders_Data/data.unity3d`, using local filesystem

I've tried: completely removing the game directory and revalidating local files, uninstalling and reinstalling the game, deleting the .config/unity3d/RageSquid/ directory, restarting steam, and even restarting my pc (I had a kernel update to do anyway).

Running it through gdb doesn't seem to give much relevant insight either, though it does pinpoint the exact step the game crashes (and actually segfaults):

Thread 50 "Descenders.x86" received signal SIGXCPU, CPU time limit exceeded.
[Switching to Thread 0xeac20b40 (LWP 4800)]
0xf7fd5db9 in __kernel_vsyscall ()
(gdb)
Single stepping until exit from function __kernel_vsyscall,
which has no line number information.
0xf7b651d0 in sigsuspend () from /usr/lib32/libc.so.6
(gdb)
Single stepping until exit from function sigsuspend,
which has no line number information.
0xf7fd5db7 in __kernel_vsyscall ()
(gdb)
Single stepping until exit from function __kernel_vsyscall,
which has no line number information.
0xf7f7f886 in do_futex_wait.constprop () from /usr/lib32/libpthread.so.0
(gdb)
Single stepping until exit from function do_futex_wait.constprop.2,
which has no line number information.
0xf7f7f967 in __new_sem_wait_slow.constprop.1 () from /usr/lib32/libpthread.so.0
(gdb)
Single stepping until exit from function __new_sem_wait_slow.constprop.1,
which has no line number information.

[New Thread 0xc5b3cb40 (LWP 4828)]
[New Thread 0xf7fbeb40 (LWP 4829)]
[New Thread 0xc5b2bb40 (LWP 4830)]
[New Thread 0xc5b1ab40 (LWP 4831)]
[New Thread 0xc5871b40 (LWP 4832)]




Thread 1 "Descenders.x86" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xf7b36d80 (LWP 4748)]
0xf7bbf0b6 in __strlen_sse2_bsf () from /usr/lib32/libc.so.6

Don't know what other information would be relevant to you at this point.

Also, just to say it was working perfectly yesterday.
Originally posted by IGotNothing:
He got you out of when you were locked up after all. He wants to feel usefull.

Only if you follow through with David's initial plan to meet at the house. Otherwise Kate rescues Javi.

I found that the best version of Gabe is going along with Conrad's plan and then David's plan. Kate and Clem both still seem fine (I agreed with both of them on pretty much all other decisions and dialogue) at the end.

In all other situations I've tried, Gabe really gets my back up and is barely trying at all.

I still chose to let him go after David at the end in both situations though.

The biggest gripe I have with the decisions in this episode is Eleanor; no matter what she betrays you (killing Conrad or not, essentially keeping Tripp happy or not) for no seeming reason (she potentially saw what they did to Mari). I wonder if you could not tell the doctor about her on your initial visit to the hospital? To keep her on side? I don't really want to play through it for a third time just to see what would happen if you didn't speak that one time (you have to still get caught out for the finale); her betrayal has soured my opinion of her character now anyway.
Apr 8, 2017 @ 10:01am
In topic Unity Console command ?
Yes, "unity".
Also looking to do this, but not around until 8:30 - 01:00 BST -- feel free to add me: edgleyUK
Dec 18, 2014 @ 4:31pm
In topic How to access / set "hot keys" ??
You can't. The wiki lists the keybindings: http://www.eu4wiki.com/Keyboard
Dec 15, 2014 @ 9:21am
In topic Viking Conquest Update 1.0 hotfix
Originally posted by Sanguinius:
or everyone else is doing things WRONG.

Yeah, no one else is capable of downloading a clean copy of Warband -- just you. *eye roll*

Also, cleaning your registry should *not* be required to play a game, even though I highly doubt the fact yours works has anything to do with that.

---

I'm running on Arch Linux (x86_64) with an nVidia GTX 660 and the latest proprietary drivers; if I turn all lighting / shadow effects off the game works (mostly) and I can get in to towns and villages, if I put the settings on the same as Warband (ie, max) entering any settlement immediately causes the game to hang. I still get random crashes to desktop when switching scenes (from overworld to combat and vice versa), but it is nearly playable.
Nov 24, 2014 @ 7:16am
In topic Linux / SteamOS support?
Originally posted by Teodosio:
Both Borderlands 2 and pre-sequel work on GNU so yes, this should work on GNU too out of the box. It looks like the graphical engine is the same.

It's using Telltales "Telltale Tool": https://en.wikipedia.org/wiki/Telltale_Tool -- Not the Unreal Engine 3 (like Borderlands/2/TPS).

Also, +1 for Linux.
Oct 15, 2014 @ 4:56pm
In topic a few questions (respec grinder and quest reset)
The New U station is to the left of Sunny's main door in Condoria. It's on the map...
Sep 10, 2014 @ 11:20am
In topic In game paypal link not working (linux)
Confirmed the exact same issue on Ubuntu 14.04 x86_64. PayPal link shows up instead; no URL's actually open.
Sep 9, 2014 @ 2:05pm
In topic In game paypal link not working (linux)
Originally posted by sebasjammer:
remember that in order to work the steam overlay must be on.
Moreover, as I wrote in the forum, you really shouldn't be able to use paypal. If you see the paypal option it's because you are not logged in steam or the steam client is closed.

Nope. Signed in on Steam, overlay enabled; still shows PayPal and not a Steam Wallet link:
http://oi62.tinypic.com/91b529.jpg

Also, this affects *all* in game URL's. Including the register link (I just signed up on the website).
Sep 9, 2014 @ 8:02am
In topic In game paypal link not working (linux)
Just tried it on my Ubuntu laptop, has the same issue.
Sep 9, 2014 @ 7:03am
In topic In game paypal link not working (linux)
Same issue here (Arch x86_64 as well), with all in game links. Looking at process tree, it spawns several dozen xdg-open commands with unique URL's but doesn't actually seem to complete. Also, xdg-open works fine when calling it manually.
Apr 1, 2014 @ 2:31am
In topic [Linux] Please spread the word.
+1!
Mar 12, 2014 @ 10:27am
In topic Linux?
I really hope you change your mind; this looks like a lot of fun.

Do you use any Windows specific technologies that prevent porting? Or is it just a case of time?
Mar 8, 2014 @ 7:15am
In topic Linux?
Any plans for a Linux port?
Oct 24, 2013 @ 11:33am
In topic Linux support?
Will buy for Linux :)
Oct 16, 2013 @ 1:26pm
In topic [Bug] Ridiculous CPU usage when designating
Fixed here :) However, I do get the same issue if I drag a room with left mouse and then try to pan with right mouse.
Oct 15, 2013 @ 2:47pm
In topic [Bug] Ridiculous CPU usage when designating
Yep, exactly the same issue here. x86_64 Arch with nVidia drivers (325.15).
Showing 1-20 of 46 entries