STEAM GROUP
Steam Universe Steam U
STEAM GROUP
Steam Universe Steam U
32,526
IN-GAME
297,894
ONLINE
Founded
September 23, 2013
All Discussions > Steam OS > Topic Details
jvert Jan 17, 2014 @ 4:46pm
SteamOS 1/17/2014 alchemist AND alchemist_beta update
We have just updated both the alchemist and alchemist_beta releases. Notably this should fix the audio output on the Intel Gigabyte machines that were given out at Steam Dev Days.

New for both releases:
  • Fixed Pulseaudio failing to start on machines without NVIDIA HDMI audio support
  • Tweaked Pulseaudio config to use either Intel or NVIDIA HDMI audio by default if available

Already in alchemist_beta but now available in alchemist
  • Fixed github issue 16 - Leftover "7" in PRETTY_NAME in /etc/os-release
  • Fixed github issue 34 - Not critical warning message: No such key `ubuntu-lock-on-suspend'
  • Fixed github issue 64 - Workaround for Debian bug #601670
  • Merged in Debian Wheezy bugfixes for apt, expat, gnome-settings-daemon, gnupg, gtk+3.0, nspr, pixman, tzdata, curl, libxfont, openssl
  • Made uinput a kernel builtin rather than a module and added a udev rule to allow for the steam user to access it
  • Reduced CPU and GPU usage while games are running by interrupting Big Picture and overlay rendering
  • Fixed an issue where two cursors would appear on screen when a game was starting of exiting
  • Fixed tearing issues on AMD platforms by having the SteamOS compositor now specifically requests vertical retrace synchronization rather than relying on the implementation's default
  • Improved compatibility with the Debian wheezy repositories by widening the scope of the SteamOS binary package repository
< >
Showing 1-14 of 14 comments
powerarmour Jan 17, 2014 @ 5:27pm 
Fixed Pulseaudio failing to start on machines without NVIDIA HDMI audio support

Superb news, well done :)
Studabakerhawk Jan 18, 2014 @ 6:04am 
Does this mean onboard analog audio should work now?
Terc Jan 18, 2014 @ 7:19am 
In Vmware now sound work, :D, thank you. And if you not have sound, go to desktop and here unmute your sound and set max volume.
UnkendTech Jan 18, 2014 @ 9:43am 
The last update made it really eazy to change sound :)
powerarmour Jan 18, 2014 @ 10:20am 
Actually sound still not working for me on Intel HD 4000 HDMI, it's still not detected for some reason, when launching the Gnome audio control panel it's muted and defaults to the analog port instead of HDMI, and when the correct output is selected (HDMI/Display Port 3 in my case) and the volume is raised there is nothing but silence.

Kinda weird when all other Linux distros pick up my sound perfectly w/PulseAudio straight off the bat, oh well...
Last edited by powerarmour; Jan 18, 2014 @ 1:49pm
shirgall Jan 18, 2014 @ 11:29am 
It's possible that you have a failed update of the fglrx driver stopping further updates. I was having the same issue, so I popped over to the desktop, sudo'd to root, did a apt-get -f install to get past that.

However, I may have broken my wifi driver in the process, so tread lightly.
Chompy Jan 18, 2014 @ 12:50pm 
Originally posted by jrp:

However, I may have broken my wifi driver in the process, so tread lightly.

As soon as I get the update, my WiFi stops working as well. If I restore my disk image, WiFi starts working again. But as soon as the update comes in it breaks.
Jaggy Jan 18, 2014 @ 12:56pm 
I have a brix from the conference, the update did not fix audio. my setup is vanilla, about 4 hours old.
theneworiginal Jan 18, 2014 @ 6:18pm 
This didn't fix my conference Brix 's audio but it made my wifi not work well.
Last edited by theneworiginal; Jan 18, 2014 @ 6:55pm
theneworiginal Jan 18, 2014 @ 8:27pm 
Ok I reinstalled steam with the USB key and sound now works. The wifi is still not working after the update though
_giosan Jan 19, 2014 @ 7:26am 
I'm exited about an nVidia optimus update, I hope to see it soon because right now I'm able just to web
Last edited by _giosan; Jan 19, 2014 @ 10:01am
Circlesea7 Jan 19, 2014 @ 1:40pm 
Ok i was wondering if it was the steambox or my shitty wifi....
Zero Jan 19, 2014 @ 3:18pm 
I plugged in my Brix Pro for the first time today. I got it set up and did not have any audio through the HDMI port. I updated and I got audio, but my wifi stopped working. The controller also became unresponsive on the desktop. I was able to move the cursor but no button presses were registering. Using the keyboard to try and navigate the desktop would result in the computer locking up.

Obviously something went wrong. The only fix is probably to reinstall the OS from the USB you gave us after you have an update ready; otherwise I don't see how I could fix the machine if it won't take any input. More like a Brick Pro right now, am i rite
shirgall Jan 19, 2014 @ 5:07pm 
I've played a little Left 4 Dead 2 after updating and I noticed some oddities with the controller, but I am not very familiar with it yet so I have not filed a bug... but it sounds like someone else has also had trouble. I'll try to document something later.
< >
Showing 1-14 of 14 comments
Per page: 1530 50

All Discussions > Steam OS > Topic Details
Date Posted: Jan 17, 2014 @ 4:46pm
Posts: 14