STEAM GROUP
Steam Universe Steam U
STEAM GROUP
Steam Universe Steam U
29,490
IN-GAME
286,033
ONLINE
Founded
September 23, 2013
All Discussions > Steam OS > Topic Details
smunky Jan 29, 2014 @ 9:12pm
OS update broke Steam Controller
I updated SteamOS on my Steam Dev Days brix, and on rebooting it says there was a controller firmware update. I followed the on-screen instructions (plugging, replugging with right-trigger held) and the firmware update fails. This repeats itself if I try to plug the controller in again.

I'm on OS version 1390852599.
< >
Showing 1-15 of 19 comments
gλmer007 Jan 30, 2014 @ 12:20am 
I have the same issue with it saying the firmware writing failed. Tried it both on my SDD Brix Pro and my Windows 8.1 desktop.
Rafiki Jan 30, 2014 @ 8:44am 
Same here, both on Brix and Win 8.1. On the Brix I managed to get past the screen once, and play around as usual, but I forget the steps that allowed it to happen.
gλmer007 Jan 30, 2014 @ 12:40pm 
I just tried it again on my desktop, and it updated fine this time.
Nar'Gall Jan 31, 2014 @ 8:21am 
Same here: could not make it update at all on the Brix with SteamOS. Plugged it into a desktop version of Steam running on Windows and the update worked just fine. Probably something to do with SteamOS for now. =]
razorace Jan 31, 2014 @ 9:19am 
I was also unable to update the steam controller on the Brix. However, I was able to update the firmware on my Windows machine like olifiers suggested.
Cooljerk Jan 31, 2014 @ 9:52am 
When you guys say the firmware update failed, what exactly occurred? Did you receive an error message? Was your controller still operable after the update failed? I tried updating my firmware last night and made it deep into the update process, to the point where I was instructed to unplug my controller, then plug it back in without holding any buttons (seemingly incidcating the update had succeeded). However, since doing so, my controller has been nearly completely unresponsive - it never mounts under linux nor windows, doesn't beep upon being plugged in, and generally seems bricked. The only exception is that, if I hold the right trigger when plugging the controller into a windows machine, it appears as a drive on my PC called "CRP DISABLD" with "firmware.bin" inside.

How do you force steam to reflash the firmware? Steam itself cannot detect the controller plugged in - under both SteamOS and Windows, steam claims no controller is detected. Does this match up with your experience? Any advice?
razorace Jan 31, 2014 @ 10:00am 
For my experience, I got a Hardware Update Failed error popup after attempting to follow the unplug/plug instructions. When I plugged it in with the right trigger held, the controller did not do the initial plugged in beep and had no controller. After the Hardware Update Failed popup, I was able to get the controller to work again simply by replugging it in. However, this did result in a new Firmware Update Required popup.

As for getting it to update in Windows, I simply had to plug it into my PC a couple of times for Steam to notify me about the firmware update.
Cooljerk Jan 31, 2014 @ 10:07am 
Thanks for the reply. Unfortunately, our circumstances sound pretty different. Surly there must be a way to manually reflash the firmware on these controllers... I doubt they'd send these out if they could truly be permanently bricked. Hopefully someone from valve will pop into this discussion or the one I made in the steam controller subgroup.
pdubya Jan 31, 2014 @ 12:56pm 
Even from the PC I get the failed message. Any tips? The right trigger is the bottom one on the back (not bottom) yes?
Cooljerk Jan 31, 2014 @ 1:08pm 
that's the trigger, yes.
prunk Jan 31, 2014 @ 1:52pm 
Same here. SteamOS failed to update the firmware, MacOS Steam version says it can't update controller firmwares and I only had success updating it on a Windows machine.
Cooljerk Jan 31, 2014 @ 4:05pm 
The lack of any sort of help on this issue is getting really aggravating. I had set aside this weekend to do work integrating the steam controller into a project I'm working on and this has basically killed my weekend. I'm sitting here twiddling my thumbs with a broken piece of plastic, and there's really no where to turn to for support :-\

I wish I would have never even tried to upgrade my firmware. My controller was working fine before that.
pdubya Jan 31, 2014 @ 5:17pm 
I was able to get it to work, following the regular instructions. Before I was at work so I'm wondering if it was the firewall, proxy, or maybe the front port on my PC. Now I'm at home on my laptop and it worked first time.

Once you've plugged the controller in holding the right trigger, let go of the button and windows should install a driver for USB mass storage. Thats the sign its working. Good luck!
Cooljerk Feb 1, 2014 @ 11:31am 
The above fixed my steam controller. Thank you so much for the response, I was going crazy all day yesterday looking for help.
monoid Feb 2, 2014 @ 5:15am 
For anyone looking for a way to perform the manual update without Windows:

dd conv=nocreat,notrunc oflag=direct bs=512 \ if=vcf_wired_controller_chell_1389813893.bin \ of=/media/CRP\\x20DISABLD/firmware.bin

(adjust the last argument as needed to match your mountpoint)

This is explained in http://www.nxp.com/documents/application_note/AN10986.pdf and https://github.com/bobc/bobc_hardware/tree/master/Firmware/LPC_Programming_Tools
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

All Discussions > Steam OS > Topic Details
Date Posted: Jan 29, 2014 @ 9:12pm
Posts: 19