STEAM GROUP
Steam Universe Steam U
STEAM GROUP
Steam Universe Steam U
23,443
IN-GAME
359,683
ONLINE
Founded
September 23, 2013
All Discussions > Steam OS > Topic Details
Bugs on SteamOS with Intel Skylake
I'm trying to build a small Steam Machine based on Intel Skylake (i3-6320).
I managed to install SteamOS without problem, except that I needed the kernel parameter i915.preliminary_hw_support=1 to boot.

However after the boot in Big Picture mode, the screen is flickering a lot and I have a lot of bug in the menu (once in a sub-menu, not possible to go back with ESC, back button or the mouse).

In Desktop mode, I also cannot use the mouse, as the display becomes crazy (big black square following the mouse pointer when I click).

I had a look at the logs (syslog, kern.log, Xorg.0.log), but couldn't find any relevant error.

I also tried installing the linux kernel 4.3.0 from Debian, but didn't see any improvement.
vainfo reports that the settings for VAAPI are correct.

I am connected through HDMI (I tried DisplayPort though, and it makes no difference) and I am using the very last version of SteamOS.

I am out of idea to try or to debug this. Can someone help me ?
Last edited by leatherback_turtle; Jan 27, 2016 @ 12:08pm
< >
Showing 16-23 of 23 comments
@orphum I have the same problem as in your video. You are not alone ! ;-)

@XÆЯO Not possible for me to install a Nvidia card. And I have bought a Skylake specifically to use the integrated Intel graphics.

Perhaps that kernel 4.4 will solve this problem, perhaps a new Mesa, or new Intel driver. However I would prefer to try to definitely identitfy the problem to be sure that it would be taken care of in the future.
If someone else has the courage, here are the steps to have the bleeding edge intel graphics stacks :
https://01.org/linuxgraphics/documentation/build-guide-0

We should update each component after the other, and check if the flickering disappear.
orphum Feb 13, 2016 @ 11:46am 
@leatherback_turtle - I got partway through, but ended up breaking my system :(

My steps:

Downloaded the 2015 Q4 Intel graphics stack: https://01.org/linuxgraphics/downloads/2015q4-intel-graphics-stack-release

Compiled & installed kernel 4.3 and libdrm. Rebooted. This didn't stop the flickering in SteamOS but it did fix the glitchy desktop!

Compiled & installed xf86-video-intel. Rebooted - at which point it failed to boot, and I get a screen that says "SteamOS is attempting to recover from a fatal error". It showed a progress bar, then rebooted, and I get into an infinite reboot loop on that screen.

Nothing in dmesg looks sketchy but I'm not super familiar with what I should be looking for.

My next step might be to try installing Arch or another, newer distro with a 4.4 kernel, see if that helps.
If I remember correctly, you'll have to deactivate SteamOS auto-repair in order to make some progress.
I think just emptying the file /usr/bin/steamos-autorepair.sh will be enough.
Otherwise SteamOS will try to re-install something over what you have done, which will mess your system for sure.
I'll give it a try myself somehow in the next 2 weeks.
Thanks for yout feedback !
orphum Feb 14, 2016 @ 9:54am 
I gave Manjaro a spin and things are working much better!

So far Steam works in BPM, and every game I've tried starts properly, video-wise. No screen flickering, no desktop tearing, it all functions.

I think the core issue for SteamOS is the non-updated kernel, Intel drivers, etc. Using an up-to-date stack provided by another distro fixes most issues. So long-term once Debian updates their stack to something better supported I'd expect it to work out of the box.

My Manjaro setup:

- Installed Manjaro from USB, updated all packages using pacman
- Updated kernel to `linux45`, rebooted
- Installed intel-gpu-tools (not sure if this is necessary)
- Applied Steam Controller mouse fix identified here: https://wiki.archlinux.org/index.php/Gamepad#Steam_Controller_Not_Pairing
- Booted up Steam (already installed on Manjaro)

Issues I ran into:

- Installer would not recognize display/start X server so I had to do a text install. I assume this is because it comes with a 4.1 kernel - as soon as I updated to 4.5 it started working
- Audio wasn't working initially (using HDMI from the Intel chip) - I had to toggle it specifically in Steam; still haven't gotten audio working in Manjaro proper but not too worried about that (update - just needed to select the right output in XFCE, no worries here)
- Steam Controller is glitchy in some games (Portal 2, Talos Principle). When I start some games it works for a while, but something causes the mouse to fly up to the top of the screen, and the game becomes unplayable. This happens both when running wired or wireless. Not sure what's causing this or how to debug it but I'm guessing it's not Skylake-specific. (Update - unplugging my external mouse seems to fix this)
Last edited by orphum; Feb 14, 2016 @ 9:36pm
leatherback_turtle Feb 15, 2016 @ 12:59am 
Thanks for this update ! I'll try also to see if I can that working.
Gagi Dec 21, 2016 @ 11:27am 
I think i got it working with a minimal set of changes.

First adding i915.preliminary_hw_support=1 to the kernel command line args in /etc/default/grub.cfg. As mentioned already here this atleast stopped having a black screen and having a flickering bpm.

As i wanted to test my hardware i tried to play some games never the less and as already mentioned here the flickering stops while playing, but after returning to bpm my machine froze completely and i found the following causing this:

Dec 21 11:17:01 steamos kernel: [ 122.837179] [drm] stuck on render ring

I tried to fix this using the xorg config mentioned here: https://ubuntuforums.org/showthread.php?t=2208072:

To change it back to sna, with root privileges, create the file /usr/share/X11/xorg.conf.d/20-intel.conf with the following content:
Code:

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

After a reboot i didn't had any flickering anymore and also the desktop is usable without the black rectangles on mouse cursor move

I hope this helps somebody ;-)
nkZ Feb 14, 2017 @ 2:43am 
@Gagi - You just saved my day!

I followed your solution and I just want to let other knows. IT WORKS !!!
No more flickering. Enjoy the rest of my day.

Thanks :)
< >
Showing 16-23 of 23 comments
Per page: 15 30 50

All Discussions > Steam OS > Topic Details