STEAM GROUP
Steam In-Home Streaming homestream
STEAM GROUP
Steam In-Home Streaming homestream
5,188
IN-GAME
31,392
ONLINE
Founded
November 7, 2013
All Discussions > Bug Reports > Topic Details
sfsdfd Nov 20, 2014 @ 3:12pm
"The screen is locked on the remote computer."
I have a brand-new machine - literally unboxed it yesterday, ran Windows Update, installed Kaspersky and Steam, and downloaded my library. The new machine is connected, via a switch and Ethernet cables, to a MacBook Pro. It's basically running headless for now (until I can patch in some long cables to reach a projector in another room), and I conducted most of the initial setup via RDP.

Last night and this morning, in-home streaming was working shockingly, awesomely well. Starting up a game was a little glitchy (some weird resolution changes on my MacBook Pro), but once it got running, it was beautiful.

And then everything came to a screeching halt with the message: "The screen is locked on the remote computer," following an RDP session. It's a total show-stopper: nothing runs any more. What's more - nothing really changed between this morning, when streaming was running well between RDP sessions, and now.

Things I've tried:

* Stopping and restarting Steam.

* Rebooting both machines.

* Explicitly disconnecting from RDP - i.e,. initiating a disconnect on the server - rather than just closing the window on the client.

* Reading all of the forum threads relating to this bug, and trying all posted variations (three, actually) of the "tscon.exe /dest:console" disconnection command. One was working fine to reset the terminal services state and resume streaming, but has since stopped working; one seems to work correctly (at least, it disconnects me!) but I get the same error; and the third one doesn't run at all.

Despite these steps, I'm getting the same error message - and I'm out of ideas. Any suggestions?
< >
Showing 1-3 of 3 comments
dava4444 Jan 13, 2015 @ 8:49am 
+1 here too.

what we should have is a RDP Steam. same as MS's but doesn't lock the screen after use.

WHY?? (to staff, kindly)


because many of us.. myself included will want to go headless.. FYI, I can select any resolution I want even with a AMD 280x, as long as I uncheck the EDID box in CCC.

but sometimes.. I just need in at those drives or to shut a launcher up and get to play or a setting needs changed.

I had managed to use the Steam RDP as a desktop user, via minimising Final Fantasy VIII launcher, worked great! and I could still stream games after use.

but that stopped working last night :/
for headless, u don't want password on your account then it will auto login, and use vnc or teamviewer... cause rdp requires password/logs out when u close it.... or something like that, i don't use windows anymore :)
dava4444 Jan 13, 2015 @ 1:57pm 
HAHA :D

but I do like RDP, and dont want an unsecure machine.

I think many will be the same.. maybe.

I did try out SteamOS last year, didn't like it coz the desktop was gimped.
but I might dual/tri boot again into Ubuntu this year. .. but then again, why, when it's only one problem.

my living room desktop is win7.. the streamer is win8, RDP makes sense to me.

used to be right into OS's.. VNC.. VBox.. im going to be 40 next year.. I just want *insert: things that work*. can't be bothered anymore.. just want to game without any noise haha
Last edited by dava4444; Jan 13, 2015 @ 1:58pm
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

All Discussions > Bug Reports > Topic Details
Date Posted: Nov 20, 2014 @ 3:12pm
Posts: 3