STEAM GROUP
Steam Remote Play homestream
STEAM GROUP
Steam Remote Play homestream
4,753
IN-GAME
51,503
ONLINE
Founded
November 7, 2013
Dal Feb 15, 2015 @ 12:38pm
No sound when streaming some of my games
Has something happened regarding the In-Home Streaming in the last Steam patches?
I have no sound anymore when streaming the Lara Croft - Temple of Osiris. I know for a fact that this has worked fine before.
I have also tried Evolve, no sound there either.
The Long Dark, on the other hand, works fine.
I'm guessing Lara Croft and Evolve are D3D games while TLD is not?

Any tips?

Thanks
< >
Showing 1-15 of 106 comments
shintsu Feb 15, 2015 @ 1:59pm 
check if the server system sound card settings are not set higher then 16Bit 48 000Hz for some reason anything set higher than this will result in no audio
Kenbousou_TTV Feb 15, 2015 @ 9:31pm 
I am also having this problem. Was playing Evolve with a friend when I had to close the game and now it no longer has sound when I attempt to stream; Primal Carnage: Extinction also doesn't seem to have sound. Currently testing other games.
Kenbousou_TTV Feb 15, 2015 @ 9:51pm 
Just tried runnig Bully and Killing Floor and neither worked, however when I tried running Evolve while running Bully at the same time I was able to hear Bully for a second then Evolve when it began streaming, but then Bully couldn't handle it and didn't let me see Evolve. This problem is very confusing.
Slybo Feb 16, 2015 @ 8:45am 
I have no sound while streaming as wel. It looks like the system volume mutes itself on the host machine when streaming starts but even if I unmute it there is still no sound on the client machine.
Dal Feb 16, 2015 @ 9:01am 
Originally posted by shintsu:
check if the server system sound card settings are not set higher then 16Bit 48 000Hz for some reason anything set higher than this will result in no audio
Hello, and thank you for your reply.
The audio on the server system was set to 16Bit 44 000Hz.
When I changed it to 16Bit 48 000Hz, the sound came back on the client! :)

Thank you for your tip!
sylence Feb 16, 2015 @ 4:01pm 
Had the same problem here and was able to fix it temporarily by opting out of the steam beta on the server side.
Originally posted by sylence:
Had the same problem here and was able to fix it temporarily by opting out of the steam beta on the server side.

This resolved it for me as well. Weird. I thought beta participation was necessary to stream Linux to Linux
Malbert Feb 16, 2015 @ 10:26pm 
I've had the same problem since around (or just before) the 14th Feb update. The 17th Feb update didn't help. I use a Windows 7 Host with an Nvidia card (hardware encoding) and had no sound streaming some games to Mac/SteamOS clients (both hardware decoding).

Games such as Duck Tales Remastered and Plants Vs. Zombies were working. Games including Borderlands 2, Sleeping Dogs and Civ V did not stream audio. Non-Steam games (Dragon Age:Inquisition) were also missing audio.

There was nothing of interest in the streaming_logs, it seemed to be detecting and initialising capture of the correct number of channels, sampling (2 chan, 44.1Khz) etc.

Removing the Beta Client Opt in (which then re-installed the vanilla client) on the WIndows 7 host resolved the issue.

With a beta steam client installed on the streaming host, starting the game locally and then initiating streaming from the remote end also worked. When the game started locally, Windows was un-muted. When the remote client started streaming, Steam would mute local audio (as expected and desired) but streaming audio worked.

Stuffing around with different audio output devices (digital to headphones to another digial output) didn't do anything. Changing the audio output from 44.1khz to 48khz didn't do anything and the streaming logs indicated that 44.1khz was still being sampled. Changing back to 44.1KHz did nothing. Reinstalling the beta client didn't do anything.

I guess I'm opting out of the beta for a while...
Lord Shadowfax Feb 19, 2015 @ 5:56am 
I see the same problem just recently even I am not using Beta.

When I tried to stream Grid Autosport, there was sound when just started, then after a random duration (from a few seconds to a few minutes), there was no sound again.

I checked the streaming_logs and found that when I heard sound it was 'Recording' from my primary Playback device (HDMI output from my GTX 780), but when I heard nothing I can see from the log that it switched some how to 'Recording' from my another Playback device (optical out) which I believe the game is not outputting sound to.

It seems the stream server has tried to do something funny to switch to another audio device to record sound, which wasn't an issue before.

I hope it shall be fixed soon, since I am not using Beta I cannot simply opt-out.

Last edited by Lord Shadowfax; Feb 19, 2015 @ 5:57am
yeah now it's in nonbeta too... sad.
And it looks like the problem returned. No sound on the client when streaming (HL2: Ep2 or BL2) Doesn't matter if sample rate is 44K or 48K, or whether I'm opted in or out of beta.

Crap, I was so happy with my streaming results yesterday that I went out and bought a new gfx card today. Now this. Come on Valve...
Vang Feb 19, 2015 @ 8:58pm 
Figures, I just tried switching to 48k myself and no results. What the Hell, Steam? Stop "fixing" what isn't broke!
Lord Shadowfax Feb 19, 2015 @ 9:23pm 
I was on 48k already, not working for me.
Kenbousou_TTV Feb 20, 2015 @ 10:01am 
I tried opting out of the steam beta on my host machine and it worked. Hopefully it stays that way.
NeptNutz Feb 20, 2015 @ 2:09pm 
This is totally gimped on all my Linux hosts (SteamOS, Debian 7, Mint 17.1) as far as I can tell. I tried many, many things (even installed gedit on SteamOS to uncomment and change the default-sample-rate to 48000 in /etc/pulse/daemon.conf) No luck.
Last edited by NeptNutz; Feb 20, 2015 @ 6:09pm
< >
Showing 1-15 of 106 comments
Per page: 1530 50