STEAM GROUP
Steam In-Home Streaming homestream
STEAM GROUP
Steam In-Home Streaming homestream
2,176
IN-GAME
32,256
ONLINE
Founded
November 7, 2013
How to Set-up In-Home Streaming over Hamachi
Super easy, just a couple steps that one wouldn't think to add.

1. Download the Hamachi clients on both host and client
2. Create a new network on the host machine
3. Connect the client to the network you created with the host
4. Launch Steam on both
5. On the HOST computer, go into Steam, Settings, In-Home Streaming. SUPER IMPORTANT IF IT DOESN'T CONNECT OFF THE BAT! This should refresh the list and you should get the message on both computers that they have connected.

Troubleshooting:
If the game launches, but you have a black screen with a mouse pointer, force quit the streaming client, right-click the host's name in Hamachi on the client's computer and select the basic ping. If the ping is really high (140's is when i usually see it stop working) then restart Hamachi on the client, failing that, the host and if even that doesn't work, restart Steam on both machines.

Hope this helps, I know it took me a while to think to go to the In-Home Streaming settings to refresh it.
< >
Showing 1-13 of 13 comments
puppybear1938 Apr 15, 2014 @ 11:17am 
I'm totally gonna try this.
Jonquk Park Apr 16, 2014 @ 9:58pm 
I'm really enjoy them. I have a question. If I cannot check ping because of firewall, how can I do? I'm in pc-room in school so i cannot shutdown firewall.
leanified Sep 13, 2014 @ 4:02pm 
i have black screen how to repair this i dont know where is ping options plz help
Gustakasnov Sep 24, 2014 @ 7:40pm 
I'm trying this exact thing and it's not working... Both computers recognize each other but when I launch any game I get a timed out warning every single time! Did you do anything aside from installing Hamachi to make it work? I disabled Windows Firewall and anti-virures just to see and doesn't work either :/
ares Dec 23, 2014 @ 1:17am 
Originally posted by gres147679:
I'm trying this exact thing and it's not working... Both computers recognize each other but when I launch any game I get a timed out warning every single time! Did you do anything aside from installing Hamachi to make it work? I disabled Windows Firewall and anti-virures just to see and doesn't work either :/

Hi guys,

I managed to connect to hamachi and I got the message on both computers that they have connected.

The stream option also appeared for my game but when I tried to stream, Steam said it could not connect to computer.

This is how I FIXED it (the same settings must be applied on Client and Host):

*First make sure that Hamachi network is running as 'Public' in Control Panel > Network and Sharing center

1. Go to Hamachi
2. Select the computer you are connecting to > Right Click > Details
3. Go to the Settings tab and for Traffic > Change > allow all
4. Close window

Restart Steam on both machines and now streaming should work. Have fun !

Last edited by ares; Dec 23, 2014 @ 1:20am
schmet Mar 18, 2015 @ 4:04pm 
Originally posted by ares:
Originally posted by gres147679:
I'm trying this exact thing and it's not working... Both computers recognize each other but when I launch any game I get a timed out warning every single time! Did you do anything aside from installing Hamachi to make it work? I disabled Windows Firewall and anti-virures just to see and doesn't work either :/

Hi guys,

I managed to connect to hamachi and I got the message on both computers that they have connected.

The stream option also appeared for my game but when I tried to stream, Steam said it could not connect to computer.

This is how I FIXED it (the same settings must be applied on Client and Host):

*First make sure that Hamachi network is running as 'Public' in Control Panel > Network and Sharing center

1. Go to Hamachi
2. Select the computer you are connecting to > Right Click > Details
3. Go to the Settings tab and for Traffic > Change > allow all
4. Close window

Restart Steam on both machines and now streaming should work. Have fun !


I tried that. What's strange is that it worked the first few times I attempted it. Then it stopped working altogether. Now I am getting the black screen on the client again. Any ideas why?
Tjupo May 21, 2015 @ 5:52am 
Originally posted by Jonquk Park:
I'm really enjoy them. I have a question. If I cannot check ping because of firewall, how can I do? I'm in pc-room in school so i cannot shutdown firewall.
If you cannot ping hamachi, how could you be able to connect to it in any other way? a ping is just a very simple form of communicationg with the host
Is there a way to use Hamachi without admin privliges? Or are there any alternatives to Hamachi?
brot343edfsdd Sep 22, 2015 @ 4:20am 
i found zeroteir works better and has better response time. hamachi was a little laggy for me. alternatively you can use openvpn but that takes lots of fiddling around
Nvidia Share is a good alternative. It has some caps right now but it will be the best software when it comes out of Beta.
JonJensen Mar 6, 2016 @ 3:25am 
Originally posted by Mr. Rogers Mach II:
Super easy, just a couple steps that one wouldn't think to add.

1. Download the Hamachi clients on both host and client
2. Create a new network on the host machine
3. Connect the client to the network you created with the host
4. Launch Steam on both
5. On the HOST computer, go into Steam, Settings, In-Home Streaming. SUPER IMPORTANT IF IT DOESN'T CONNECT OFF THE BAT! This should refresh the list and you should get the message on both computers that they have connected.
Great and easy. This is the client to Windows: https://secure.logmein.com/welcome/hamachi/vpn/whatsnew.aspx and this is the way you install on Ubuntu Linux: https://help.ubuntu.com/community/Hamachi
Last edited by JonJensen; Mar 6, 2016 @ 3:26am
Eravohn Jul 17, 2016 @ 3:54pm 
Me and a friend tried to set this up but ran into some problems.

I could ping him but he could not ping me.

This is what the dignosis looked like:

---
Tunnel: OK

Local results:
Adapter configuration: OK
Traffic test: Inbound traffic blocked, check firewall settings

Result for peer: [202-711-522]
Adapter configuration: IPv6 gateway setting is invalid
Traffic test: OK
---

I added hamachi to my firewall and the Traffic test under my Local results changed to OK but the result for my peer still said invalid gateway.

How do we fix this?

Last edited by Eravohn; Jul 17, 2016 @ 3:55pm
JonJensen Jul 20, 2016 @ 1:07am 
Can't use Netflix with Hamachi installed. Buu Netflix and the VPN ban.
Last edited by JonJensen; Jul 20, 2016 @ 1:10am
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Apr 9, 2014 @ 4:18pm
Posts: 13