STEAM GROUP
Steam Remote Play homestream
STEAM GROUP
Steam Remote Play homestream
2,536
IN-GAME
33,145
ONLINE
Founded
November 7, 2013
Sk@nkw0n Mar 12, 2014 @ 8:13am
Fix for lag spikes over WiFi
I've been tearing my hair out for the last few weeks, trying to sort out the regular lag spikes that were making IHS unusable for me over WiFi. Finally sorted the problem after testing out numerous conditions and possible fixes.

Host PC -
CPU - 2500K @ 3.3Ghz
GPU - Radeon HD6950
RAM - 8GB
OS - Win7 64bit

Wired to TP-Link WR1043ND router @ 1GB/s

Client Laptop - Dell Studio 1735 (with upgraded RAM & WLAN card)
CPU - Core 2 Duo @ 2.1Ghz
GPU - Mobility Radeon HD3650
RAM - 4GB
WLAN - Intel® Wireless WiFi Link 5300
OS - Dual boot - Win7 64bit & Ubuntu 13.10

Wirelessly connecting over b,g,n mixed

I've found that IHS works better for me on the Ubuntu partition, rather that the Win7 one on the client.

These lag spikes were occuring roughly once per minute, and would pretty much freeze up the screen for 2-4 seconds, making most games unplayable.

In Ubuntu - I finally cured the spikes by disabling the default NetworkManager (then removing it), and instead installed WICD. I'll admit I'm no LINUX expert and it took some fiddling with the command line, but was able to search the internet to get helpful guidance here :-

https://help.ubuntu.com/community/NetworkManager#Disabling_NetworkManager
https://help.ubuntu.com/community/WICD

I can now continue testing IHS for my optimal stream settings!

As for the Win7 partition, I'll admit I've not fixed the problem there yet, BUT .. I have read that lag spikes in Windows are likely to be caused by one of the Windows services, and that they can be cured by stopping the service or by editing the registry, or sometimes disabling IPv6.

I think the problem was being caused by the WLAN card constantly searching for new access points every minute, wether in Ubuntu or Windows.

Just thought I'd post in case anyone else is experiencing simialr issues over WiFi, I'd post in more detail but I'm rushing to get to work soon, if anyone needs any more info, I'll try and dig up all the links from my search history and post up exactly what I found... and there's a lot of search history there! ;)

Good luck and happy streaming. :)

[edit 22/4/15] - Read below, for a better solution than this, thanks all who have contributed.
Last edited by Sk@nkw0n; Apr 22, 2015 @ 3:33pm
< >
Showing 1-15 of 21 comments
Sarvatt Mar 12, 2014 @ 6:12pm 
Thanks, that actually worked. To make it easier, you can add this PPA and not need to switch away from network-manager to use that crappy wicd, I added a patch to make network-manager not scan in the background if you're connected to an AP already to give the same benefit here. https://launchpad.net/~sarvatt/+archive/taramar
Sk@nkw0n Mar 13, 2014 @ 2:25am 
Excellent, glad it's helped you out, and even better that you found an alternative solution. At work right now, but I'll look into your method later Sarvatt.
MC Mjolnir Apr 6, 2014 @ 4:29pm 
This looks interesting, I had assumed it was just a hardware problem. A bit late in the day to test this now, but subscribed.

I'm also curious as to whether these lag spikes are present in SteamOS and if this fix works in that too.
Last edited by MC Mjolnir; Apr 25, 2014 @ 8:10am
wehde Apr 23, 2014 @ 7:46pm 
I dont know if i can thank you enough!!!!!! I've spent forever looking into this problem... upgrading ubuntu to 14.04... upgrading firmware for my 802.11ac wifi card... installing bumblebee on my laptop for nvidia optimus... different routers and different cards... but this is the stupid simple fix i overlooked. Thanks!!!
MC Mjolnir Apr 24, 2014 @ 9:19am 
Yep, can confirm that it works a treat for me as well =) (just tested it last night as I was previously running 12.04 which isn't supported by your PPA).
Sk@nkw0n Apr 25, 2014 @ 5:38am 
Cool, glad it's helped you both. Since first post and a few Steam updates, the problem disapearred in Windows, I've also since upgraded to Ubuntu 14.04, but as it was an upgrade my settings where all still in place, so I had no idea if this problem was still relevant. It seems it is!
Originally posted by Sarvatt:
Thanks, that actually worked. To make it easier, you can add this PPA and not need to switch away from network-manager to use that crappy wicd, I added a patch to make network-manager not scan in the background if you're connected to an AP already to give the same benefit here. https://launchpad.net/~sarvatt/+archive/taramar

Can I get some help trying to install this PPA? I have no idea which one to install on the software center. (that is where I get it, right? I'm kind of new to Ubuntu)
Last edited by The Man Who Sucked Too Much; Feb 7, 2015 @ 6:02pm
Sk@nkw0n Feb 8, 2015 @ 5:17am 
I never got around to trying Sarvatts method, and I suspect Sarvatts Ubuntu expertise to be far greater than mine! Therefore I can only offer help using my original method.

The Man Who Sucked Too Much - Are you currently experiencing these spikes? If so, try searching the Software Centre for WICD, and try connecting to IHS using that as a Network Manager (after first disabling default Network Manager).

I'll boot up Ubuntu laptop later hopefully, and I'll have a crack at IHS Win7 --> Ubuntu again tonight, because TBH Win7 --> Win7 has been working well enough for me since IHS came out of beta.

Post back and let us know how you get on.
Last edited by Sk@nkw0n; Feb 8, 2015 @ 5:17am
1200baud Feb 12, 2015 @ 6:41pm 
Thanks for this! Solved my problem. On Ubuntu 14.04 LTS I replaced network-manager with WICD using instructions here https://help.ubuntu.com/community/WICD
Jayme Apr 20, 2015 @ 10:37am 
Just stumbled upon this thread but was not willing to switch to a different network manage and I did not want to completely disable the "scanning in background" because that would prevent roaming to different APs to work correctly... long story short:

To work around this with Network Manager you can enter (or select) the BSSID (e.g. hardware address) of your AP in your network settings. With that set the network manager will no longer try to find a better (e.g. stroger) AP for your network and that will stop the spikes.

Find the BSSID (Address) of your ESSID in iwlist output:
$ sudo iwlist wlan0 scan wlan0 Scan completed : Cell 01 - Address: 00:11:22:33:44:55 Channel:5 Frequency:2.432 GHz (Channel 5) Quality=70/70 Signal level=-33 dBm Encryption key:on ESSID:"the_known_ssid" Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s 24 Mb/s; 36 Mb/s; 54 Mb/s Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s Mode:Master ...
walmartshopper Apr 22, 2015 @ 3:08pm 
Thanks, static BSSID worked.
Sk@nkw0n Apr 22, 2015 @ 3:31pm 
Thanks Jayme, a much better solution.
jptagman May 5, 2015 @ 6:48am 
so basically if you get lag spikes REAL BAD ONES, please restart your laptop(the client that receives the video steaming feed) and it should work perfectly. Thats how my mac laptop behaves. just thought i would share
MC Mjolnir May 5, 2015 @ 8:49am 
That's not really a fix.
Blacksilver65 Aug 25, 2015 @ 8:03pm 
Static BSSID worked for me too. Go no Network under your System Settings. Click the little arrow next to the network you are connected to and where it says BSSID, hit the drop down menu and select your APs hardware address. You can find it using the command listed above from Jayme. Just wanted to add some more clarification.
< >
Showing 1-15 of 21 comments
Per page: 15 30 50

Date Posted: Mar 12, 2014 @ 8:13am
Posts: 21