STEAM GROUP
Steam Remote Play homestream
STEAM GROUP
Steam Remote Play homestream
2,461
IN-GAME
28,538
ONLINE
Founded
November 7, 2013
 This topic has been pinned, so it's probably important
slouken Aug 23, 2019 @ 1:59pm
Steam Remote Play FAQ & Support
Last edited by slouken; Aug 23, 2019 @ 2:00pm
< >
Showing 1-15 of 86 comments
wataf Nov 1, 2019 @ 1:49pm 
omg
Phil Nov 6, 2019 @ 1:09pm 
So how would I play :p2aperture: Portal 2 Coop with someone who doesn't own it?
InfernoFufila Nov 12, 2019 @ 2:16am 
How The Hell Do You Disable Remote Play Together Notifications?
Mastnosis Nov 14, 2019 @ 6:13pm 
I am so freaking steaming mad at valve. After a recent play session with a friend having to reload company of heroes 2 the 10th time, I've had it. In-home streaming used to work like a charm. switching away and then back almost never had an issue and was near instantaneous. Now in home streaming is a pile of crap. switching away and then back is almost guaranteed not to work. and on the occasion where it does work it takes a long time to recover. If that wasn't bad enough, you used to be able to kill the stream and restart it to fix any issues. Now stopping the stream kills the game on the host machine forcing a restart. This basically all started back when Steam was updated for remote play.
In home streaming was the killer function for me. Not only because I use Linux as my daily driver, but also because key games I play don't like being switched away even when run on Windows, but streaming allowed me to seamlessly switch back and forth.
The downward spiral has been slow and steady. At first it occasionally didn't like to be switched away and then back. would sometimes crash, but restarting the stream got things back up and running. Now I virtually never can switch away and then back without the stream crashing or not responding at all.
The main issue seems to be full screen. Warlock, doesn't allow me to switch away full screen anymore even though it used to work flawlessly for YEARS. But what does work now is if I hit Alt+Enter to window the stream and then switch away. I can then switch back with ease and Alt+Enter back to full screen.
For the love of god
1) Fix streaming so you can Alt + Tab away and back
2) Allow to restart the stream like it used to be 2 months ago. Pressing the streaming button would open and close the stream quickly fixing any issues you might have. Now it's kill and restart the game.
If you can't do the above then revert to the old way of in-home streaming. I give 2 $hiz about remote play.
Theos Nov 24, 2019 @ 10:41pm 
im trying to play cuphead with a friend online. we both enabled the beta participation and enabled remote play, yet there is no button that allows me to invite them to remote play the game. any suggestions for what could be wrong?
Phil Nov 26, 2019 @ 7:54am 
Should be out of Beta now, apparently you need to start a Local Coop, maybe it is also a problem with input (Portal 2 needs 1 keyboard and 1 controller for ex. .....)
Is it possible to remote play from another pc in local network? I have gaming pc in my "server room" and nuc pc on my desk, and I want to utilize gaming pc to play games. But, when I start game from my nuc pc, games starts on host, but I get this screen on my nuc pc http://forum.pcekspert.com/attachment.php?attachmentid=21674&d=1573298782 thank you
KeyboardWarrior Nov 26, 2019 @ 7:26pm 
On your friends list, if you right click your friend, there should be a invite to remote play option

Originally posted by Theos:
im trying to play cuphead with a friend online. we both enabled the beta participation and enabled remote play, yet there is no button that allows me to invite them to remote play the game. any suggestions for what could be wrong?
KeyboardWarrior Nov 26, 2019 @ 7:30pm 
Has anyone here experienced that after remote play hosting, all your audio on your PC is being treated as input for your mic? What i mean is if I play a video on Youtube, everyone in discord will hear that video (not noise bleed from mic, my friends say sound quality is as if they were watching the video themselves). Thanks!
dawaste Nov 30, 2019 @ 5:14am 
my friend have trouble on the display of steam remote play.In all the games we tried,his screen was glitched and cutted into small pieces and arranged in the left and right of the screen(like this: http://imgur.com/a/neXbXT3)

Are there any ways to fix it?i tried opening vsync on both connector and host,and i tried capping frame rate to 60 but still didn't work
TMT Dec 2, 2019 @ 10:38am 
404 Not Found. Class act, that. Don't you have a bugzilla or something that works?
RedSToneJerry Dec 4, 2019 @ 4:24am 
Earlier today we play 2 game with Remote play,Unrailed! and Tool up!
They can invite 3 player
but now they can only invite 1 player to play
if you want to invite second player
it will show "End Remote player Stream"
then the first player will lost connection
How could this be?
zeroSkill Dec 15, 2019 @ 9:23pm 
omg
West0821 Dec 21, 2019 @ 1:48am 
nah
mcelikten_ Dec 29, 2019 @ 6:47am 
NJ
< >
Showing 1-15 of 86 comments
Per page: 1530 50