STEAM GROUP
Steam Client Beta SteamBeta
STEAM GROUP
Steam Client Beta SteamBeta
5,203
IN-GAME
42,664
ONLINE
Founded
January 8, 2013
All Discussions > Bug Reports > Topic Details
FFXIV: Wired Xbox 360 Controller Detected by Game but Does Not Work or Calibrate
BUG:
Using a Wired Xbox 360 Controller on FFXIV causes the game to register the controller as usable, when in actuality you are unable to use/calibrate the controller in the game at all.

OS:
Windows 10

STEPS:
1. Open and run FFXIV like normal with the wired controller plugged into the computer.
2. Switch to Gamepad Mode with the Enable Gamepads setting turned on in the game's Character Config settings. (You will see that the game reads that the controller is plugged into the system.)
3. Try to use the controller to find it wont work.
4. Enter the Character Config settings to try and calibrate the controller.
5. Start calibration.

RESULT:
At step 3, you realize the controller isn't working. After step 5, the end result becomes that the controller will not even calibrate, let alone work. Even though the game registers that the controller is plugged into the system.

EXPECTED RESULT:
The game should read the controller and it should work. If it does not work initially, you should be able to successfully calibrate the controller so that it works.

(NOTE: I have tested the controller elsewhere to make sure that the controller was actually working anywhere other than FFXIV. My OS is able to use the controller as are other games. This leads me to say that this is a bug issue rather than a faulty controller issue.)
Last edited by ChirolingFury; Sep 8, 2017 @ 12:42pm
< >
Showing 1-11 of 11 comments
SprayRate Sep 8, 2017 @ 10:25pm 
Is the Steam overlay working? Is there any similar posts in the game's forum? Did it work fine previously? Did you install anything from the list of apps that can interefere with Steam?
ChirolingFury Sep 9, 2017 @ 6:56am 
The Steam overlay works fine as it shows that I can access it when game is running. Previously, before I had joined the beta program, I was flawlessly able to use a controller with FFXIV without many issues. If I ran into an issue with my controller, I was able to fix it on my own.

In the case of apps that would interfere with Steam, any security software I have is built into my OS. It's not anything like McAfee or Norton security software where I would've installed it. The only thing that seems to be an "interference" is Glyph (known to be used for games like Trove), but that's only when I update random games, as I get the "Missing File Privileges" error (but it is never associated with FFXIV as the game has a launcher that updates it).
GodestLove Sep 9, 2017 @ 7:10pm 
I have the same problem. My wired 360 controller works in big picture mode but in none of my steam games such as Trine 2 and Transformers. I have never had this issue before.
ChirolingFury Sep 10, 2017 @ 2:52pm 
Originally posted by GodestLove:
I have the same problem. My wired 360 controller works in big picture mode but in none of my steam games such as Trine 2 and Transformers. I have never had this issue before.

I remember looking up the issue on Google a few days ago to try and figure it out. According to a forum board post for FFXIV on their website, the issue is related to the beta build client for Steam, as this issue has happened for others in the past.

This is a link to the forum board post. [forum.square-enix.com]

This problem has been happening for a year or so in terms of FFXIV running with the beta build version of Steam's client. I'm not sure if there is a permenant solution as of yet, so I brought the issue here hoping it might be able to finally be resolved for everyone who plays games using a controller.
SprayRate Sep 10, 2017 @ 10:43pm 
The beta is done in individual rounds where at the end it gets merged into the public client. These happen a bunch of times during the year so that means it has been broken then fixed a bunch of times rather than it being broken for a whole year.

When did this start happening for you most recently?
ChirolingFury Sep 11, 2017 @ 12:32pm 
Originally posted by SprayRate.WorldStar:
The beta is done in individual rounds where at the end it gets merged into the public client. These happen a bunch of times during the year so that means it has been broken then fixed a bunch of times rather than it being broken for a whole year.

When did this start happening for you most recently?

This started happening for me a few days ago, when I last played the game in question (FFXIV).

I had my controller plugged into my laptop, logged into the game as normal, and switched to gamepad mode to go to use the controller.

When I went to use the controller, the controller wouldn't do anything in the game. I checked my configuration settings in FFXIV, thinking it wasn't reading the controller, but I noticed that the controller was being recognized by the game.

At that point, I went to calibrate the controller, thinking if I recalibrated it that it might start working. But when I went to calibrate the controller, I couldn't calibrate any part of the controller at all (the sticks wouldn't calibrate, nor would the buttons, bumpers, or triggers). Instead, the game stopped the calibration process and I found myself unable to use my controller at all with FFXIV.

Hopefully these details help. If not, feel free to ask more needed questions.
StealthOpossum Oct 26, 2017 @ 4:54am 
I have the same issue. I received my steam link yesterday and the very first time I started the game the controller worked. I stopped playing for a bit and when I started the game again, the controller acts almost like a mouse. This is happening both through the link and when using just my computer, regardless of where I connect the mouse(Steam link USB or computer USB). I can move the cursor with the right joystick, and RT acts like a left mouse click. No other buttons work. I have tested with Icey and the controller works as expected. I switched to the beta version of steam as I read it had fixed this problem for others, but I have the same issue. I just don't quite understand why it worked the first time I connected the steam link. I did not update software between the time it worked and the time it stopped.
Alright, so I had this same issue with my Xbox one Elite controller. I used a regular wired xbox one controller beforehand and it worked fine. Swapped to an elite controller. Got it wired in and everything. For the life of me I couldnt get it working. Tried everything from swapping out drivers to moving ports, swapping between fullscreen and borderless window (because its always the stupid ♥♥♥♥ that works), etc.

You know what finally fixed it? I have FFXIV through Steam. I've always had the overlay turned off. Just for ♥♥♥♥♥ and giggles I turned the overlay back on in game. It ♥♥♥♥♥♥♥ works. Just to double check things I went and turned Steam Overlay off for FFXIV and sure enough the controller stopped working again.

Why the ♥♥♥♥ does the Xbox One Elite controller require Steam Overlay to be on in game for it to work? Thats pretty stupid if you ask me.

Looking in my configuration settings it does say that FFXIV recognizes my controller as an xbox 360 controller, which it most certainly is not:
https://i.imgur.com/fC0T2b8.jpg

Under my Device Manager it shows up properly as the Elite controller:
https://i.imgur.com/6E3ttKy.png

To me this looks like a problem on Squeenix's end in controller recognition. A fix for this so I dont have to have my overlay on would be nice, because with how Steam's new overlay works I dont want FFXIV to have focus stolen from it because someone decides to message me on Steam. :\
The Dabbling Dibbler Jul 3, 2021 @ 7:02am 
2
Properties > Controllers > Disable Steam Input.
This fixed my issue
ColdRamune Jul 21, 2021 @ 5:04am 
Originally posted by The Dabbling Dibbler:
Properties > Controllers > Disable Steam Input.
This fixed my issue
OH MY GOD, you are an absolute savior. i have been looking for a solution for 2 hours now. TY SO MUCH <3
Player Jun 5 @ 11:06am 
Originally posted by The Dabbling Dibbler:
Properties > Controllers > Disable Steam Input.
This fixed my issue

Jesus christ thank you
< >
Showing 1-11 of 11 comments
Per page: 1530 50

All Discussions > Bug Reports > Topic Details
Date Posted: Sep 8, 2017 @ 12:38pm
Posts: 11