STEAM GROUP
Steam Client Beta SteamBeta
STEAM GROUP
Steam Client Beta SteamBeta
6,151
IN-GAME
54,881
ONLINE
Founded
January 8, 2013
All Announcements > Announcement Details

Steam Client Beta Update - Sep 13

389 Rate up
< >
47 Comments
nintendude794 Sep 22, 2017 @ 1:26pm 
Hope hi-res DPI scaling comes to the rest of Steam's interface soon.
VinAbqrq Sep 15, 2017 @ 8:40am 
Overlay not working properly anymore. Before this update you could enter and exit the overlay using the steam button, now you can only enter, and you have to use B to exit the overlay. This sucks because if it doesn't save where I was. If I am in the overlay but one to give a quick look at the game, I loose the page I was visiting.
Demitri Sep 15, 2017 @ 8:31am 
Big Picture doesnt fill the entire screen, using 4k resolution it trips the sides off than allow all the screen to be used
Mushe Sep 14, 2017 @ 3:36pm 
2 things:
BIg Picture: Terrible performance, unusable.
Achievements: No sound when unlocking + if you click the pop-up it opens the friends list instead of the achievements page of that game.
《❤テᏊι ჯ ჯり❤》 Sep 14, 2017 @ 1:36pm 
Its still all ♥♥♥♥ed up, doesnt matter what:BITRAY_Angry:
|G|AleyKsi.Cxl-a Sep 14, 2017 @ 11:50am 
Can't launch MINION MASTER with the beta : invalid launch option.
It's the only game so far for me
Mobeeuz Sep 14, 2017 @ 11:13am 
Can no longer get out of steam overlay with the piston button on the steam controller.
ZX Sep 14, 2017 @ 9:32am 
Hey Valve! Did you know that your Linux client can't create desktop and application menu shortcuts since june?

It seems a bug, which can be fixed in less than an hour by FOSS community, takes 4+ months in Valve time. Congratulations.
Darkitow Sep 14, 2017 @ 8:57am 
I'm not sure I've understood the action set layer thing properly, or if I'm experiencing some bug.

I've understood the Photoshop layer reference, so I get that whatever action that is overwritten on a higher layer will "mask" the lower. This behavior seems to be working properly.

However, the actions related to action set layers don't seem to be working at all for me. Whatever layer I create last, that will be the one that will be applied, even if I didn't set an action to enable it. And using the action to disable it, doesn't change anything, it's still applied.
Lethal Flavor Sep 14, 2017 @ 7:32am 
nice :gearthumbsup: