STEAM GROUP
Double Action: Boogaloo 2x_action
STEAM GROUP
Double Action: Boogaloo 2x_action
17
IN-GAME
259
ONLINE
Founded
July 19, 2012
Xylemon Jul 1, 2014 @ 11:40am
[BUG] (Linux - Fedora 20) Cannot connect to VAC servers
I've been trying to get this working on Linux for a while, and today decided to finally see if anyone can help me. Basically the terminal spits out this:

Game update: AppID 243750 "Source SDK Base 2013 Multiplayer", ProcID 32143, IP 0.0.0.0:0 ERROR: ld.so: object '/home/<username>/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored. /bin/sh: -g: invalid option Usage: /bin/sh [GNU long option] [option] ... /bin/sh [GNU long option] [option] script-file ... GNU long options: --debug --debugger --dump-po-strings --dump-strings --help --init-file --login --noediting --noprofile --norc --posix --protected --rcfile --rpm-requires --restricted --verbose --version Shell options: -irsD or -c command or -O shopt_option (invocation only) -abefhkmnptuvxBCHP or -o option Game removed: AppID 243750 "Source SDK Base 2013 Multiplayer", ProcID 32143

Any help? I do have Source SDK Base 2013 Multiplayer installed, and I don't understand why it keeps whining about the Steam overlay library because I can use the overlay just fine in other games.
Last edited by Scout; Aug 6, 2014 @ 1:43pm
< >
Showing 1-11 of 11 comments
Jakovski Jul 1, 2014 @ 11:54am 
Try disabling the overlay? Best i can contribute with :/
Xylemon Jul 1, 2014 @ 12:44pm 
Didn't work.
Jakovski Jul 1, 2014 @ 4:12pm 
Alright, sorry i couldn't help any further. Good luck though :)
[BS] Vino Jul 9, 2014 @ 7:32pm 
Sorry I haven't been over to the Linux side of things in a while so I haven't been able to look into this for you, but it looks like there's something wrong with your Source SDK installation. Do any other Source games work, eg TF2 or CS:GO? Do other games on your Steam list work? Can you run the "Source SDK Base 2013 Multiplayer" benchmark on its own?
Xylemon Jul 10, 2014 @ 4:36pm 
Well TF2 and the SDK Base 2013 Multiplayer work fine. Pretty much everything Source related works fine except for Double Action: Boogaloo
Xylemon Jul 29, 2014 @ 12:11am 
Using the latest release "Kappa Plus" it works now.
[BS] Vino Jul 29, 2014 @ 9:50am 
Horay I fixed it and I have no idea how! I'm glad it works for you, hopefully it won't break again :)
Xylemon Aug 3, 2014 @ 7:11pm 
Well now I have another problem which is I can't play on Linux because I'm in "not secure" mode (I guess its not reading the libraries for Steamworks?) So I can't play on any of the VAC secured servers, which is sad because I would love to play online.
Scout Aug 3, 2014 @ 11:25pm 
Potentially a fix: https://github.com/ValveSoftware/steam-for-linux/issues/3296

Also, Steam is officially only supported for the latest stable version or two of Ubuntu - if you're running another distro, this might be even tougher to chase down.

Valve says a potential fix for this in Windows is to run the Steam Service executable with the -repair flag (https://support.steampowered.com/kb_article.php?ref=2117-ILZV-2837&l=english). Is there an equivalent in Steam for Linux?
Xylemon Aug 4, 2014 @ 6:04pm 
Hmm, I'm not sure, almost every Steam game and mod has worked fine on a different distrobution. Even my friend on Slackware has little to no issues with native ports on Steam. On top of this VAC issue, DAB crashes half the time when I die, I'm just going play via Wine until another udpate or Steam release :(
Last edited by Xylemon; Aug 4, 2014 @ 6:05pm
Scout Aug 4, 2014 @ 6:45pm 
I'm sorry you're having so much trouble. It works fine on our Ubuntu test box and with a small player base running Linux, we don't get testing done on the same breadth of setups as we do for Windows, so bugs are hard to spot and even harder to track down.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50