Hellblade: Senua's Sacrifice

Hellblade: Senua's Sacrifice

Hellblade: Senua’s Sacrifice Hotfix 1.01.1 Released!

535 Rate up
Share
< >
80 Comments
brightonsblueeyedboy Aug 28, 2017 @ 12:22am 
I can't play this at all now, 60 fps from the start until the beach level, and from then on it fluctuates between 1 fps and 60 fps. It gets so bad running through the maze with a fire thing chasing me I'm literally playing at 1 fps which makes it impossible! I've uninstalled, and reinstalled, started a new game, and still the same problem - I've even noticed the earlier levels I had played wuth no issues no longer run at 60 fps as they did before, they too fluctuate between 15 fps and 60 fps.
Have tried all the tricks in the book such as the 2 launch options to use all cores, updating to the latest driver on AMD, changing game settings on AMD, reduced all graphic settings on the game to low, turned v-sync off, reduced resolution - nothing fixes it!
I don't understand why this patch has fixed the fps issues for everyone but me, do I have to go somewhere to get the patch? How do I know if I already have it?
Vinicius Preu Aug 26, 2017 @ 6:51am 
I still got the black screen when she dies in combat... FX8350 / RX480 8Gb / 16Gb DDR3
alenjenny Aug 24, 2017 @ 7:09pm 
DEAR DEVELOPER NINJA THEORY,

when will we be getting Nvidia SLI or AMD Crossfire support for your game? it's practically a horrible experience to play at 4k resolution max detail with any existing single GPU on the planet, even Nvidia GTX 1080ti. please look into this. thank you
diegito86 Aug 24, 2017 @ 1:55pm 
nach 5 minuten geht mein Monitor in Standby . spiel läuft weiter.
nicht spielbar
Sek Aug 23, 2017 @ 2:18pm 
I start the game and then that
LowLevelFatalError [File:E:\P4Workspaces\HellbladeRelease\UE4\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 796]
Rendering thread exception:
LowLevelFatalError [File:E:\P4Workspaces\HellbladeRelease\UE4\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0020 - 'INTERNAL_ERROR')
KERNELBASE.dll!0x00000000D8879E08

Please help
Eggchin Aug 22, 2017 @ 4:00pm 
Fixed some issues but there's still bugs. I died fromt he illusion boss (crow boss thing) and froze on black screen. I restarted the game and no longer hear voices and the illusion portals don't work either. Also I can't cross bridges after bringing them out of their illusion. I haven't been able to play since the game was released because of this issue.
thelastraver Aug 22, 2017 @ 2:36pm 
you just killed the game, i want a refund.
Chronos999 Aug 22, 2017 @ 1:52pm 
why send an e-mail to support@hellblade.com if you don't respond......:steamsalty:
zibi Aug 22, 2017 @ 1:25pm 
:)
Cecily Nocturnal Aug 22, 2017 @ 12:59pm 
that sucks