Endless Space 2

Endless Space 2

[1.0.52] Hotfix

292 Rate up
Share
< >
77 Comments
petercarr Jun 11, 2017 @ 3:55am 
Game still producing endless pending and hanging during the start of ship combat - stuck at turn 254 - apparently a few turns from victory - have tried restarting earlier saves, but still happens.
Buddha D Jun 7, 2017 @ 9:29am 
Is anyone else still encountering the "hardship ready" ecologist law bug where standard colonisable planets terran, ocean, jungle atoll etc are getting a 50% FIDS penalty as the game doesn't recognise you have the tech unlocking those planets?

I'd be very grateful if someone could try and replicate this starting up as an ecologist custom nation with a planet type that doesn't need colonization tech. Confirm or refute please?
BajMic Jun 5, 2017 @ 12:01pm 
I still got the 'pending' issue. Can't get past turn 139 even with this hotfix.
peciu1983 Jun 5, 2017 @ 6:45am 
Hi there;],
fights not pending now - one problem - last and best Riftborn hull - all is working exept when I want to watch battle - there is a problem with it - first of all you cannot see it then black screen apears and I you cannot do anything(some kind of hanging). Please look into it....
yu_fong_siu Jun 5, 2017 @ 6:14am 
still got turn pending issue ...
FB Jun 5, 2017 @ 12:44am 
So I don't know where to post those issues and if I am the only one but some stuffs in the technology tree mid-late game just don't work properly for me, while it seemed they were already reported during development. Here they are:
- Quadrinix and orichalcix mining not working while having proper techs and lots of systems with these resources discovered
- Additional law slot(s) at empire development V not working while working at empire development III
- No additional government at xeno Anthropology?

Thanks for the great game, but please take care of those annoying things!
SaOk Jun 4, 2017 @ 7:31am 
I got the game yesterday. My first game worked good as the united empire. On second try and 3rd try (with the same faction) got stucked in end of turn event around on 25th turn. I had a craft exploring automatically. Both those times I had picked random faction and both time it was the united empire.

But else liking very much the game. Been now playing as The Lumeris as custom selected without issues.
Shirner Jun 3, 2017 @ 1:43am 
I cant run the game after this fix was implemented! :(
STARSLINE Scream♠ Jun 2, 2017 @ 10:32pm 
Il y a des bugs encore, surtout en jouant l'empire !!
Impossible de terminer la partie car le tour ne se fais meme pas..
Niveau Optimisation c'est juste mal optimisé. c'est horrible à partir du 100 e tour .
Franchement faite quelque chose pour que sa soit vraiment jouable.
J'ai la Titan X Pascal I7 16gb ram, Meme niveau battaille quand la flotte est trop grande la video de gameplay de combat Ram , c'est Moche à regarder.
:steamfacepalm:
Omega3 Jun 2, 2017 @ 2:36pm 
Still bugy for me , not happy !