Empyrion - Galactic Survival

Empyrion - Galactic Survival

Alpha 9.2 Bug Fixes and Improvements - Part II

184 Rate up
Share
< >
66 Comments
Strykerx88 Jan 28 @ 3:01pm 
In-crease flight-speed

*clap* *clap* *clapclapclap*

In-crease flight-speed

*clap* *clap* *clapclapclap*
TheSkyArmyFox Jan 28 @ 12:03pm 
Mule; it's not really a bias. my brother googles a lot of stuff and believes that the best Radeon graphics cards are not the best graphics cards, and never were. and holy crap as if the optimization hadn't gotten any worse, i'm in a GAMING computer, and get lag loading planetary playfields now, since the latest update. optimize your game, Eleon. i shouldn't be lagging playing Empyrion on a computer that runs Skyrim at max graphics with 60 FPS. i get a full 10 second freeze frame on transition from playfield to playfield, and then a slideshow for the next 30 seconds the planet loads. and the flight controls are off again; i go down a little bit, i drop like a damn rock.
Thats what you get Jan 27 @ 1:55pm 
also, why are there ALWAYS talon hanging around zirax armories? ive accidently gone hostile with talon several times now because their troops are ALWAYS mixed in with the zirax troops... it would be really nice if instead of colluding with the enemy they helped the dude who has honored reputation with them...
Thats what you get Jan 27 @ 1:53pm 
hello, was just wondering if there were any plans to make npc factions fight each other? ive been honored with polaris and building a nice base in their territory, but the damn zirax scum come thru 10 times a day and attack me... flying right over polaris defense IIs to get to me... i recently build my base next door to a defense ll and the zirax drones just fly around it. turrets dont shoot at it or anything....

but if i loot just one container... or accidently miss with a missile... all of my work gets wiped off the planet by that damn defense ll....
Strykerx88 Jan 25 @ 12:53pm 
FLIGHT.






SPEED.







INCREASE.
FluffyMule Jan 25 @ 4:29am 
As I have said, my system is more than capable of running everything else I throw at it and the game only became unplayable with one of the most recent updates. As for your comment about Radeon cards, is this really the place to bring up you bias?

Finally, my post was for the devs to see and hopefully address and to let others who are having similar issue know they are not alone.

I really do hope they can fix the issues I'm having as I love to play this great game!
TheSkyArmyFox Jan 25 @ 2:57am 
Radeon? haha! there's your problem, Mule! Radeon has never had the best graphics cards. not only that, you might also just have a common computer. now; i agree, games shouldn't require a gaming computer to run, but i have a gaming computer, by Cyberpower PC, and it ran this game, before the most recent update, at 60-45 FPS at maximum graphics.
FluffyMule Jan 25 @ 1:56am 
I love this game but last time I played was before .9 update. Of all the games I have this one performs the worst but with the last update it is now unplayable. I barely get 30 fps and the movement is jerky and laggy even on a new unpopulated creative planet without any buildings/ships spawned in. Frame rates have never been particularly good compared to other games, but not bad enough to stop me playing, hence my 1800+ hours played.

I play game like Skyrim, Warframe, Destiny 2 and Battfield 4, 1 and 5 on highest settings without issue. Windows 10 completely up to date as are my Radeon Graphics drivers and all other drivers (using Driver Booster). System is very stable.

Anyway, wanted to post here as I don't want to post a negative review and hope the devs will read this.
Parabellum168 (Bunseth) Jan 24 @ 3:37am 
gREAT ;D
TheSkyArmyFox Jan 24 @ 2:11am 
for some reason, something happened with the game that made it to where i can't play it. it becomes non responsive every time i load it, and it never even loads the main menu. i have a few blueprints from the workshop on me. i tried reinstalling the game (backing up my saves, of course), restarting my computer, verifying the game file integrity, nothing worked or even made any progress. i'm pretty sure this is a game cripling bug because of the ineffectiveness of everything i tried. has anyone else had this problem yet?