SteamVR Beta Updated

49 Rate up
< >
mattdilllon May 13, 2016 @ 1:12pm 
so,,,this is saying that the DK1 will function again with Steam? My DK1 cease to work when the newer programming came out for the later DK products.:steamsad:
phuzz Aug 18, 2014 @ 8:31am 
Forgot to add, the positional tracking works much better if you change vr_translation_limit from 10 to 100. (use the dev console to change it, or create an autoexec.cfg)
phuzz Aug 18, 2014 @ 8:29am 
I wasn't getting any visuals at all, until I installed the latest beta version of the AMD drivers for my R9 290, so that might be worth checking.
Also, you don't need to _run_ the SteamVR tool, just do the following:

Open Steam and go to Library > Tools.
Right-click Steam VR, choose Properties, click the Beta tab and opt-in.
Restart Steam.
Right click on Half Life 2 in your Library and select Properties
Click Set Launch Options…
Enter -freq 75
Run Half Life 2 in extended mode, with the Rift as the primary monitor
Open the game, go to Options > Graphics and enable VR mode
Go back to the main menu and click Activate Virtual Reality.

I found it worked really well, but something about the run speed made me feel a bit ill after half an hour, in a way I've not had from any of the OR demos.
clipkilla Aug 15, 2014 @ 8:57am 
Just got HL2 working with DK2 but it's not perfect and it's not been straight forward (Beta - yay!) Here's my 2 cents, might help:

Using Windows 7 64 bit, extended desktop with Rift as Primary monitor, latest 2.11 firmware:
- I had to copy the Oculus Config Utility.exe from the Rift install over top of the HL2 & steam common utils version. Out of date OCU.exe that ships with current HL2 and SteamVR beta releases? Full outline by Le_marton in comments of the article Joe just linked to (
- Needed several attempts to turn on VR mode in settings in HL2 + restart to then 'activate virtual reality mode'
- When I do activate VR mode I get the UI but the 3d scene behind the menu is black.
- Loading up a level I can play it (woot!) but no positional tracking even though my camera light is on and the OCU can see it.
- I get positional flicker every few seconds - seems to be driver polling the camera or freaking out that the camera is on but something's wrong
python Aug 15, 2014 @ 7:46am 
To all the people having trouble: Are you opted into the Steam VR Beta ? Also, I don't think you need to launch the SteamVR application (DK1 config utility), just install it and Steam should detect the DK2.
NakedNinja Aug 15, 2014 @ 5:47am 
Happy :D
DzyDzyDino Aug 15, 2014 @ 4:16am 
I'm having the same problem as everyone else. Steam is not detecting my Oculus DK2. It launches a DK1 config. I've tried it with and without the service running.
madyvision Aug 15, 2014 @ 3:18am 
@Isaksen @willz99ta Same problem for me. Windows 8.1 and DK1 configuration utility but shows no device attached
Isaksen Aug 15, 2014 @ 3:01am 
Doesn't seem to work on Windows 8.1, like others, Steam VR launches Oculus Configuration Utility but shows no device attached.
Theanine Aug 15, 2014 @ 12:54am 
Does this mean TF2 now supports the Rift too? or just HL2?