Mfashnick May 25, 2013 @ 8:40pm
They Don't Read Your Trouble Tickets - part a million
Here's my total interactions with Steam since May 7th:

Ticket number
Category Steam Client > Steam Client Crashes
Product *STEAM*
Steam Account Login Name
Operating System Mac OSX
[NOTE THE "MacOSX" listed obviously on this ticket]
I scoured the Internet to find out that this issue is all over the place, existing for years.

I deleted all files in the Library/Application Support/Steam folder except the SteamApps. After a computer re-start and a relaunching of the program, I get the age-old "Could not connect to the Steam network" error message B.S.
I tried various fixes from deleting the ClientRegistry.blob to changing my router settings, all to no avail.

It concerns me when I look on the Internet and find people with the same problems from years ago, unresolved and often with no response from administrators here. I hope you will prove them wrong and respond in a timely manner to resolve these issues.
3 Message by you on Sat, 11th May 2013 8:28 am
I just upgrade to 10.8.3 and it did nothing to solve this problem. But now I can't play some older games that used to run on PowerPC. The sheer amount of time it's taking to get a response is absurd. I paid for these games, so not allowing me to use a product I paid for is stealing. When will there be a fix for this problem?
This certainly doesn't make me want to continue to do business with Steam. I've heard Oracle is good. Or maybe I'll just use Steam to browse games and then I'll buy the games separately from their individual web sites. That sounds like a better idea than not being able to play my games at all.

4 Message by you on Wed, 15th May 2013 3:29 pm
iTunes Store response time: a few hours. They couldn't solve my problem, but they responded with information quickly and told me where I could go to get more help. Almost Human Games response time: a day. They couldn't help me, but I understood why and appreciated the speed of their response.
Steam response time: 8 days and counting.

5 Message by Support Tech Roger on Thu, 16th May 2013 9:47 am

Thank you for contacting Steam Support.

We apologize for the long delay in getting a response to you.

Steam Support has recently had a higher volume of tickets and we are working to respond to everyone.

We have found that many users have resolved their issues since submitting their ticket.

You may be able to find solutions to common problems in our Support Knowledge Base or in the Steam Discussions.

Support Knowledgebase:
Steam Discussions:

We would like to help you resolve your issue. If you have not found a solution since submitting your ticket, please respond to this ticket and we will continue to assist you.

If we don’t receive a response, this ticket will automatically close in 24 hours.

If you are still encountering the issue please follow the instructions linked below to run an msinfo32 report and attach it to this ticket so we may further diagnose the issue:

Title: How to run and submit MSINFO32 Reports

NOTE: Please make sure your Operating System is fully updated before running this report.

We appreciate your patience as we want to make sure all our customers are assisted.
6 Message by you on Thu, 16th May 2013 3:01 pm
Dear "staff,"

I am still encountering the problem, and I cannot submit a "msinfo32" because the instructions you gave are for a PC and I, clearly as you can see in the header information, have a Mac running OSX 10.8.3 (though I was running 10.7.8 nine days ago when the problem started). The Steam program still does not completely start, only giving me an "Updating Steam" and "Checking for Available Updates" box, and freezing on that box. I've tried tons of solutions in the Discussions, from dropping my Firewall, including Steam in my Firewall, reinstalling Steam several times including deleting the Library files (I had to learn how to make the Library folder visible and keep the Steam Apps folder elsewhere so it's safe), and probably more that I've forgotten.
Something clearly is wrong with this Steam build. I'd like to relax and play those games I bought.
If you want me to generate some sort of report, you need to send me instructions that are usable on my computer.

7 Message by you on Mon, 20th May 2013 1:58 pm
using the following commands in the Terminal:
cd /Applications/

I can report the following error message:
Assertion Failed: Unable to set default socket options, error 55
8 Message by Support Tech Roger on Tue, 21st May 2013 12:38 pm
Hello Ian,

Please exit Steam and go to the folder Users/[username]/Library/Application Support/Steam

Delete all of the files in this folder except for SteamApps and Userdata.

Restart your computer.

Launch Steam and re-test the issue.

Note: This process will not affect your currently installed games.

Note: If you are using Lion please do the following to access your Steam folder:

1. Click "Go" in the menu bar
2. Click "Go to Folder..."
3. Type "~/Library/Application Support/Steam"
4. Click "Go"

This will take you directly to the folder.

If the issue persists, make sure your network is optimized for Steam:

Title: Troubleshooting Network Connectivity

If you have any further questions, please let us know.
9 Message by you on Tue, 21st May 2013 5:13 pm
I've done this a dozen times. I did it again just now. It has no effect. I've gone over the router settings and connected directly. This has no effect.

Please just admit your client drop on May 6th was terrible and re-engineer the entire thing. Steam was working before this update.

Not that my typing this text matters. No human is reading my responses.
10 Message by Support Tech Roger on Sat, 25th May 2013 12:05 pm
Hello Ian,

Please exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation - if you set a different installation directory, you will need to browse to it).

Delete all of the files in this folder except:

- \Steamapps\ and \Userdata\ folders

- Steam.exe (this file is listed as an application and features the black and white Steam logo)

Restart your computer.

Then, launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.

With Steam running, re-test the original issue.

Note: This process will not affect your currently installed games.

If the issue persists, make sure your network is optimized for Steam:

Title: Troubleshooting Network Connectivity

If you have any further questions, please let us know.
11 Message by you on Sat, 25th May 2013 7:33 pm
I HAVE A MAC! WE DON'T HAVE A "Program Files" FOLDER OR A "Steam.exe" FILE!

Last edited by Mfashnick; May 29, 2013 @ 7:43pm
< >
Showing 1-11 of 11 comments
ErniePC12 May 26, 2013 @ 4:34pm 
You know, I was able to have them acknowledge that I was using a Mac, but I noticed 2 days ago that my ticket was closed.

I didn't close it, so I can only assume that they did it.

I'm less than impressed with this...
Mfashnick May 26, 2013 @ 4:47pm 
They're clearly overwhelmed, yet unwilling to hire more people. If you had time follow the huge amount of crazy text I posted up there, they did acknowledge that I had a mac in the second message, but then forgot again in the third. And all of those suggestions were ineffective. *sigh*
С.Jl.l0.H.b.K.U May 27, 2013 @ 5:05am 
НЕстоит того просто вы никчёмные ребята
F² BiZZaRD May 27, 2013 @ 6:00am 
They're clearly overwhelmed, yet unwilling to hire more people...
Mfashnick May 27, 2013 @ 5:44pm 
I notice on the May 6th client update notes:
"Fix client update-loops caused by inconsistent server and proxy-cache states"

No, Steam, you didn't fix them. You caused more.
neyyy<3 May 28, 2013 @ 7:13am 
Mfashnick May 29, 2013 @ 4:14pm 
I just thought, "Hey, maybe if I opt into the Beta, that will solve the problem." So I looked at the beta opt-in instructions. One has to OPEN Steam first and opt-in through the program... but I can't open Steam. In fact, that's the whole reason why I want to TRY Beta.
chaz May 29, 2013 @ 5:12pm 
Jesus H Christ, OP. Remove your account name and email from your post.

Mfashnick May 29, 2013 @ 7:43pm 
Wow, good call. Thanks.
Mfashnick May 31, 2013 @ 5:57am 
I got a response again that apologized for not recognizing my OS last week. That's right - it's been almost 4 weeks and 4 responses, none of the successful.
This one suggested I use my system preferences to cut out any programs that open on startup, restart the computer, and then try Steam. It didn't work. So now I tell them that it didn't work and wait another week for a response. Oh, and hope that in their response they recognize my operating system and give me a suggestion that at least relates to it.
Braveheart- May 31, 2013 @ 8:45am 
eto huinya
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: May 25, 2013 @ 8:40pm
Posts: 11