Mfashnick May 19, 2013 @ 5:36am
Steam Client doesn't work Roll Call
Who hasn't been able to play since the May 6th Build?
I've tried making my Library folder visible and deleting all files except the Steam Apps folder, then reinstalling (several times).
I've tried upgrading from 10.7.8 to 10.8.3 and then re-setting all of my certificates and running Keylogger.
I've tried turning off my Firewall, making sure Steam is accepted on my Firewall.
I've tried changing my router settings.

All I get when I start the program is "Updating Steam..." and "Looking for available updates..." then it just sits there forever.

Any other ideas? Putting in a trouble ticket has been useless and, after all, according to Steam/Valve, you're my tech support.
< >
Showing 1-6 of 6 comments
neogeo May 19, 2013 @ 8:54am 
Same here! I just opened a post and also contacted support. Do you mean support told you to get your help from the community of this forum???
Mfashnick May 19, 2013 @ 1:11pm 
That's one of the things it suggested. They also told me to generate a report: a Microsoft report. In other words, the lame form letter didn't even take note that I was running OSX and, therefore, had a Mac. I don't think anyone actually read it.
It took 9 days to get that response. I'm still waiting for a response to my response.
ErniePC12 May 19, 2013 @ 6:02pm 
I also am having this issue. I tried all the above steps, and it didn't work. And that was all before I opened a support ticket. And so far, my response was to create an MS report, and take the steps that I have above.

I have found this to be the error that I think it preventing me from continuing...

Assertion Failed: Unable to set default socket options, error 55

I've written that line 3 times in my ticket. They have had yet to acknowledge it...
GloriousMassacre Jun 13, 2013 @ 11:59pm 
Same here. Steam just doesn't start.
ErniePC12 Jun 14, 2013 @ 6:47am 
Since I have posted my last message, Valve came out with a fix for the client.

I moved the Steam Client on my computer to the trash, and then downloaded a new client from their website. I installed the app, opened it, and it grabbed the update.

It has been working since then.
Mfashnick Jun 14, 2013 @ 8:57pm 
Mine has been working since then, too. I've had to download the games again, but all of my save information appears to be there.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: May 19, 2013 @ 5:36am
Posts: 6