This topic has been pinned, so it's probably important
henryg Jan 1, 2016 @ 11:13pm
Error: Failed to load steamui.dylib (NOW FIXED)
Update Dec 22, 2017: We've fixed a recent compatibility issue with Mac OS X 10.7 that caused this error message. We have released a patch that will download and apply automatically for all Mac users. Just restart Steam, and it will update and launch normally.

Original post below:


Due to an unexpected compatibility issue between new OS X security features and our recent update, some users may see an error message saying "Failed to load steamui.dylib" which prevents Steam from starting up properly.

If this happens to you after Steam restarts itself for an update, there are two options. First, please try the directions at to refresh your local files (including a system restart).

If the problem still continues after a restart, you may need to perform a full re-installation of the Steam application (but not your games). To do this, drag the Steam application to the Trash. You will be prompted to Keep or Discard related files - you should choose KEEP in order to retain your saved games and local downloads. (If you do not see a prompt, then your saved files will not be deleted, as the default behavior is Keep.)

Empty the trash, verify that Steam is no longer an application on your system, and then fully restart your Mac. The restart step is very important, do not skip it!

You can then download and reinstall Steam from this website (Install Steam link at top of page) after the reboot, and the issue should be gone.
Last edited by henryg; Dec 23, 2017 @ 5:21am
< >
Showing 1-15 of 763 comments
leviDFW May 27, 2013 @ 9:27am 
Failed to load libsteam.dylib
After reinstalling Mac OSX, I can't get steam to start up.

It says 'Failed to load libsteam.dylib'. I have redownloaded it, restarted, etc.

I notice that this question has been asked before, and the only response is 'Try posting here' with a link to this forum.

Its now been posted here.

Now - has anyone who ran into this issue found a solution for it?
Stique May 28, 2013 @ 1:51am 
i have the same problem....
BMan May 30, 2013 @ 9:08am 
Me too!
Enkidu May 30, 2013 @ 9:49am 
Mazoyk May 30, 2013 @ 10:12am 
I have the same problem too!!! We need help, please!
alono89 May 30, 2013 @ 3:00pm 
i have the same problem
Xenon Jun 1, 2013 @ 12:06am 
Me, too.
finboygeraghty Jun 1, 2013 @ 4:09am 
This Worked for me. It's pretty straight forward.
Xenon Jun 1, 2013 @ 11:13pm 
thanks - it worked!
Stique Jun 13, 2013 @ 8:05am 
its not working for me i have the same problem........
d.smash45 Jun 13, 2013 @ 10:43am 
steam says that i need to check my internet connection and this video didn't wok for me, so when this problem will be solved ?
Dentifrico Jun 16, 2013 @ 9:08am 
same problem here. that solution didnt work
Gari_Rockman Jun 17, 2013 @ 6:16pm 
I've saw the same problem at 2011 Sep, so it's comes again…

I think it's a broken update, before me update, my game list all ruins and fail to load it.
i had this issue, all i had to do was opt out of all the steam client beta and it worked
oh and i checked the tf2 properties via my library and when i checked the betas tab it was showing one in the pull down menu, i also clicked the menu and picked 'opt out of all betas'. Either way i had the error appear 3 times, then i did this solution and all is good now.
< >
Showing 1-15 of 763 comments
Per page: 15 30 50