Problem with running a dedicated server
Recently, I've been trying to make a dedicated server for CS 1.6 using the steamcmd tool. By using "app_update 90 validate", the files were downloaded (the command was used more than once because of a bug, that is mentioned on valves developer wiki). For a quick test, i ran "./hlds_run -game cstrike" and the server launched fine. But then the weird things started. After I restarted my virtual machine (the server ir kept on a virtual machine that runs Ubuntu Server 12.04) and tried to start the server using the same exact command, it did not - after "couldn't exex banned.cfg" there was no continuation. Writing "status" in the console returned "Can't "status", not connected" and the main problem - whenever someone connects to the server, it crashes. Server console then proceeds to send a crash report (at least I think that it is a crash report). Sometimes I get an error code, sometimes the upload fails. The last message is "Segmentation fault (core dumped)". I have tried with redownloading the server files, reinstalling steamcmd and even reinstalled Ubuntu Server, which did not solve the problem.
I also tried to launch the server by using hlds_linux instead of hlds_run. The process failed and returned a error (no such file or directory. Unable to load engine, image is corrupt). But that's not all. By running the hlds_linux, whole ubuntu console gets messed up (see below the second link for screenshot).

Scrsht #1 :
Scrsht #2 :
Machine specs:
Windows 8.1 64-bit /Ubuntu Server 12.04 on Virtualbox 4.3.6
Intel i3-2310m 2,1 Ghz
DDR3 3Gb Ram
Intel HD 3000

ได้รับการแก้ไขครั้งสุดท้ายโดย SHLNSKI; 2 ก.พ. 2014 @ 12:59pm
< >
กำลังแสดง 1-3 จาก 3 ความเห็น
Ouch that looks pretty broken. Give my script a try and see if that works better for you :).
Worked like a charm. Even after I restart my virtual machine, the server starts without any problems. Thank you :)
< >
กำลังแสดง 1-3 จาก 3 ความเห็น
ต่อหน้า: 15 30 50