cinna Jul 11, 2014 @ 2:10pm
can't update cs:s dedicated server
I've restarted my server, I've typed app_update 232330 validate in steamcmd, it says it's already updated, restart server, it still says "your server needs to be restarted in order to receive the latest update". what do i do??
< >
Showing 1-4 of 4 comments
Knappy Jul 11, 2014 @ 2:17pm 
If you have mods and whatnot on the server, delete just the the bin folder and run the validate.

If it's just a stock server with a server.cfg host.txt and motd.txt, copy them over and nuke the server, reinstall.
cinna Jul 11, 2014 @ 2:37pm 
how do I "nuke" the server? i delete everything and it still says its updated
Knappy Jul 11, 2014 @ 2:40pm 
Nuke as is delete everything and re-install. Copy your cfg, addons etc back to the server and launch.

Also, check the steam.ini and see what version it reads. I don't run CSS but in L4D2:
Steam\steamapps\common\Left 4 Dead 2 Dedicated Server\left4dead2 :

Originally posted by xtro:
i delete everything and it still says its updated
When you try to connect with the client, does it give a version error or are you able to connect to the server?
Last edited by Knappy; Jul 11, 2014 @ 2:49pm
Blaquicat Jul 12, 2014 @ 3:05pm 
Try taking the validate out..
Solved the problem for me..

Every time i want to update the server i run with and without the -validate.
Some times the -validate acts just like "Verify the game cache", without updating the server.
Last edited by Blaquicat; Jul 12, 2014 @ 3:06pm
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Jul 11, 2014 @ 2:10pm
Posts: 4