This topic has been locked
Access Violation at nvwgf2um.dll
Hey guys,
Since I got this pc I'm having some problems with it I can't solve. Many games work without any problems, but some, especially newer ones, simply won't start or crash after a few minutes of playtime. Those are: Metro Last Light, Crysis 3, AC 4, BF4 and Stalker Clear Sky. Most of them appcrash and report that the nvwgf2um.dll is the faulting module. Now I've found some clear sky errorlogs on my hard drive. They report an access violation at nvwgf2um.dll, so there has to be something wrong with it but I don't know what it is. Has it something to to with the program not being allowed to write on C drive? I'm always using the latest drivers for my gpu (currently 332.21). Is there anyone who knows what could be the problem? I'd appreciate any suggestions! Thanks in advance :)


Xeon W3570 @ 3.20ghz
GTX 680 4gb from Zotac
650W PSU
WIN 7 64bit

I know that workstations are not perfect for gaming, but I had chose this one (much faster than E8200) until my new pc build is finished. And it performs really nice except these few crashes :)


Application: XRay Engine
Computer: XXXX
User: XXXX
Date: XXXX

Error Reason:
xrengine.exe caused ACCESS_VIOLATION in module "C:\Windows\system32\nvwgf2um.dll" at 0023:6822FB9E, OpenAdapter10()+944510 byte(s)

System Error:
0x00000012 - Es sind keine weiteren Dateien vorhanden.

EAX=0000002A EBX=0076E308 ECX=00000000 EDX=005DFBC0
ESI=00000001 EDI=0D863D18 FLG=00010202
EBP=0018F13C ESP=0018EF04 EIP=6822FB9E
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

Number of Processors: 4
Processors Descriptions:
1. Intel(R) Xeon(R) CPU W3570 @ 3.20GHz
2. Intel(R) Xeon(R) CPU W3570 @ 3.20GHz
3. Intel(R) Xeon(R) CPU W3570 @ 3.20GHz
4. Intel(R) Xeon(R) CPU W3570 @ 3.20GHz

Operating System:
OS Version: Unknown Service Pack 1
Build Number: 7601

Memory Usage:
Current Memory Load: 18%
Total Physical Memory: 4095 MB
Available Physical Memory: 4095 MB
Total Page File Memory: 4095 MB
Available Page File Memory: 4095 MB
Stack Trace: Interrupted Thread, TID: 3860
"C:\Windows\system32\nvwgf2um.dll" at 0023:6822FB9E, OpenAdapter10()+944510 byte(s)
"C:\Windows\system32\nvwgf2um.dll" at 0023:681AEA59, OpenAdapter10()+415801 byte(s)
"C:\Windows\system32\nvwgf2um.dll" at 0023:681AE5CB, OpenAdapter10()+414635 byte(s)
"C:\Windows\system32\sgfxu32.dll" at 0023:715C5358
"C:\Windows\system32\d3d11.dll" at 0023:7166DEAD
"C:\Windows\system32\dxgi.dll" at 0023:739E3B21, DXGID3D10RegisterLayers()+25657 byte(s)
"C:\Windows\system32\dxgi.dll" at 0023:739E1C2E, DXGID3D10RegisterLayers()+17734 byte(s)
"C:\Program Files (x86)\Steam\steamapps\common\STALKER Clear Sky\bin\xrRender_R3.dll" at 0023:05656667

Sorry for this long post...

< >
Showing 1-15 of 19 comments
UberFiend Feb 16, 2014 @ 3:26am 
nvwgf2um.dll is a problem with nVidia display driver

uninstall, reboot, clean registry with ccleaner, reinstall latest (or last good one), reboot
VDV Homer707070 Feb 16, 2014 @ 3:45am 
I already tried those steps, it didn't help. But thanks for your reply!
Pyrrhic Victory Feb 16, 2014 @ 3:53am 
Did you make sure to do a 'Clean Install' when you were reinstalling the GPU driver?
VDV Homer707070 Feb 16, 2014 @ 3:56am 
Yes, of course. Before that I already used ddu to remove all Nvidia related files.
Pyrrhic Victory Feb 16, 2014 @ 3:59am 
If it still does not work re-register your DLL files
Last edited by Pyrrhic Victory; Feb 16, 2014 @ 4:00am
Pyrrhic Victory Feb 16, 2014 @ 4:02am 
Originally posted by Homer707070:
As I said above, I already did that :)
So you have already tried reregistering the DLL files? If so then you could try checking your PC for file system errors.
VDV Homer707070 Feb 16, 2014 @ 4:03am 
Sry, I was wrong. I read the first post again and thought that was your answer... I will try re-registering. Thanks for your suggestion!
Pyrrhic Victory Feb 16, 2014 @ 4:17am 
Hope it works, remember to run it as an Admin.
Pyrrhic Victory Feb 16, 2014 @ 12:47pm 
Has it worked? Kinda curious, that re-reg method is like a 50/50 shot.
VDV Homer707070 Feb 17, 2014 @ 8:57am 
Not done yet, I had some other complications... But I'll post as soon as I've tried it!
VDV Homer707070 Feb 19, 2014 @ 11:15am 
Done now, unfortunately didn't solve it :(
Pyrrhic Victory Feb 19, 2014 @ 3:21pm 
Try installing the latest NVIDIA driver (a new one came out today) perform a clean install. If that doesn't work then a reinstal is most likely the best option. What are your full system specs? I know the CPU, GPU, RAM and PSU but what Motherboard? and do you have a Soundcard? A full system spec would help and may be able to allow me to offer a alternate solution.
Last edited by Pyrrhic Victory; Feb 19, 2014 @ 3:21pm
Silicon Vampire Feb 19, 2014 @ 3:28pm 
Are you using some kind of third party patch to allow programs to use more memory?
Last edited by Silicon Vampire; Feb 19, 2014 @ 3:29pm
VDV Homer707070 Feb 20, 2014 @ 6:39am 
Describing my mobo is some kind of difficult. It's an E-ATX Intel Serverboard, but it should be Socket 1366. I think I'll wait until I've finished my new build, this thing lacks options.

To Silicon Vampire:
No, not as far as I know.
UberFiend Feb 20, 2014 @ 7:12am 
Originally posted by Homer707070:
Error Reason:
xrengine.exe caused ACCESS_VIOLATION in module "C:\Windows\system32\nvwgf2um.dll"

Maybe Xray Engine is the problem.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Feb 16, 2014 @ 2:15am
Posts: 19