Donye Aug 12, 2015 @ 8:29am
FIXED: Help! Black screen of death when playing certain games
FIX: If you are experiecing similar issued with GW2, log into GW2, go to graphics and choose "auto detect" do not use any GPU software to "optimise" games. GW2 does not like this



Hi guys. I'm using a gaming rig I had put together since September last year. It's a pretty decent set up but lately I've been having some issues. I get a Blue screen of death when I load up Minecraft (lol) and when I play GW2 it crashes, there is no signal for my monitors and a robotic sound comes out the speakers and I have to hit the power button.

Here's some important things to know:

I have not added any new hardware
Recently formatted SSD
GW2 and Minecraft both installed on HD2, Witcher 3 on HD1 (dunno if this would affect it)
I can play high end games such as Witcher 3 and a modded Skyrim on ultra/high specs with no crashes
I have tried to reproduce the GW2 crash but it seems sporadic (eg I ran for 2hours in world v wolrd so lots of players on screen and had 0 crashes, but I run today in different areas of the game and it crashes)
Desktop, twitch, youtube, general day to day use never crash PC
PC shut down safely everyday
No overclocking

Here are some things I've done to try and resolve it:

Googled the *beep* out of it all day
Checked my CPU and GPU temps. CPU around 60C max, GPU around 80C max
Run Furmark benchmarking tool several times with consistent results
Checked my voltage on PSU and this seems consistent around the 12.0V
Taken my PC apart, checked for dust etc
Moved my RAM from the different slots and reinserted fine
Used CC Cleaner to remove registery errors
Uninstalled and reinstalled my GPU drivers

Here are my specs:

HD1: 120gb Samsung 840 EVO SSD
HD2: 1TB WD1OEZRX SATA3 HDD 64MB
GPU: 3GB XFX RADEON R9-280X 1000M
CPU: INTEL CORE I5-4690 CPU @ 3.50GHZ
RAM: 2X CORSAIR VENGENCE PRO DDR3 8GB
MOTHERBOARD: GBYTE Z97-HD3 MOBO
FAN: NZXT KRAKEN X31 RL-KRX31-01
CASE: CORSAIR 230T BLACK + WINDOW
POWER: CORSAIR RM 550
OS: WINDOWS 7 HOME PREMIUM 64 BIT

Would any of you kind souls be able to help me out? I will happily provide more information/clarity if needed

Last edited by Donye; Aug 17, 2015 @ 12:07pm
< >
Showing 1-14 of 14 comments
_I_ Aug 12, 2015 @ 8:54am 
could be a bad ram dimm
run memtest86+ overnight
http://www.memtest.org/#downiso
Donye Aug 13, 2015 @ 10:13am 
Originally posted by _I_:
could be a bad ram dimm
run memtest86+ overnight
http://www.memtest.org/#downiso

Hi thanks for advising this. I tried this overnight and there were no errors. Still at a loss here :(
_I_ Aug 13, 2015 @ 12:29pm 
is anything overclocked?

post a cpuz validation link
http://www.cpuid.com/softwares/cpu-z.html
cpuz -> validate button -> submit button
it will open a browser, copy the url (address) and paste it here
Donye Aug 13, 2015 @ 12:44pm 
Nothing is overclocked. I'm not keen on signing up to websites like that for spam :/
_I_ Aug 13, 2015 @ 1:49pm 
no need to sign up
just download and run it to show us system specs and cpu/ram/fsb speeds and timings
_I_ Aug 14, 2015 @ 1:54am 
what power suply do you have? (brand/model)

7970 is a 250w gpu
the i5 build will be around 250w

if its a poor quality psu or under 500w it may have troubles running the system

and your ram is running at 1066 cl11
use cpuz to see what xmp profiles it supports
it has a profile for 1333 cl9 1.5v, go to bios and selct the ram profile for that
Last edited by _I_; Aug 14, 2015 @ 1:56am
Donye Aug 14, 2015 @ 10:47am 
_I_ Aug 14, 2015 @ 8:51pm 
rm 550 is good enough for the build

run windows ram test or use memtest86+ overnight
http://www.memtest.org/#downiso
Donye Aug 15, 2015 @ 1:05am 
Hi I already did and there we no errors
Donye Aug 16, 2015 @ 1:45pm 
Changed the PSU and still noping
Help! Black screen of death when playing certain games
what games show blackscreen?

1. gpu driver version?
2. have you tried downgrading gpu driver to previous version?
3. have you tried upgradng gpu driver to latest version?
4. have you tried using another psu like seasonic or silverstone 500w+ ?
Donye Aug 17, 2015 @ 10:48am 
Guild Wars 2 is only game with Black screen.

1. AMD Catalyst driver 15.7.1 up to date
2. Yes
3. It is latest version
4. New PSU installed see above

Thanks
Donye Aug 17, 2015 @ 12:06pm 
FIXED: Was a compatability issue with GW2. GW2 doesn't like AMD optimising it's games. I logged into GW2 and auto detected GPU settings from there and no black screen after hour of playing, before every 5mins. Thanks to all above who helped
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Date Posted: Aug 12, 2015 @ 8:29am
Posts: 14