Makronic Nov 19, 2012 @ 5:55am
Games won't work
NONE of my games work anymore. Each of them pop up with a specific error message. Dota 2 comes up with 'failed to load the launcher DLL: invalid access to memory'. MTG says 'MTG failed to start (error code: 66)'

Those are just the ones I've reinstalled, can't be bothered reinstalling all the other ones since they'll just give me the same message. I've tried verifying cache, I've tried reinstalling steam as well as the individual games. I've tried contacting steam helpdesk over a week ago and still no reply.

If i load the games from their location, MTG works, but dota 2 stops at the load screen and gets stuck with 'connecting to dota 2 network...'.

This is quite ridiculous, I've paid for lots of games, and now i can't play them. The least that Steam can do is get back to me on the tech support. Getting quite fed up. Anyone got any ideas on how to fix this?
< >
Showing 1-3 of 3 comments
Kiya Nov 19, 2012 @ 6:26am 
You may have the wrong permissions set for your user account in windows. Try running Steam as an Administrator and Disabling UAC as described in this Steam support article -> Windows 7 and Vista Troubleshooting
jardail Nov 19, 2012 @ 6:29am 
Been having the very same problem and I'm on windows XP pro. About 2 weeks ago started having issues with crashes to desktop, some kind of windows runtime error with the c++ libraries. Now the games won't start at all and I've had a tech support issue in since the 13th of November.
Makronic Nov 20, 2012 @ 11:13pm 
same, its been over a week, no word from tech support.. WTF?
thx kiya, i'll try it.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Nov 19, 2012 @ 5:55am
Posts: 3