This topic has been locked
Steam Isn't Running. Client Refuses to Open. Steam Games Will Not Run.
Today I began having issues with Steam and games downloaded from Steam refusing to launch. Not sure what to do, since I can't access my Steam settings without the client running.

I've already checked the Task Manager and the Steam.exe Process is not running. Nor is the Application. I tried to force start it in Services, but it started then stopped. Restarting my PC didn't work. A "repair" action on Steam in the Control Panel didn't have an affect either.

I should mention this began happening after my PC crashed while I was playing War Thunder. Not sure why. But when my PC tried to reboot its self it went into a loop of restarting and bringing me back to the screen that asked me to restart repair or start Windows normally. Both options yielded the same result. So I forced the PC to shut down and let it sit off for 10 minutes. When I turned it back on I did a repair install and did a system restore in the process to the last successful start-up (this morning). Steam was running in the background at the time. This kind of crash doesn't usually happen, though. I'm not sure if the crash affected Steam in some way or to the point where it won't work.

Is there a solution to get Steam running properly again or am I going to have to go through the trouble of backing up files and re-installing?
< >
Showing 1-15 of 56 comments
Marble Jun 6, 2013 @ 10:50pm 
I would say the underlying issue here is that the service won't start.

I think the easiest way around this would be to follow this guide and start again:
https://support.steampowered.com/kb_article.php?ref=9609-OBMP-2526
]BIG[ Superbacon Jun 7, 2013 @ 8:28pm 
Guess I had to re-install. But Steam is working normally again. Thanks.
Zyous Jan 6, 2014 @ 7:27pm 
another thing somebody could try if they have this problem...enable the services to automatic for steam, try to open steam, then open task manager and end both the services task and the steam.exe task, abd relaunch steam
Lolaskye Jan 10, 2015 @ 11:40am 
I have that issue and I've done both things and nothing. It still keeps popping up.
ƒishßait Feb 20, 2015 @ 3:42am 
still wont work -_- i re-installed it many times ithink (16 times) as for today but still nothing happens' WTH is happening with the steam?
LuminosXI Feb 20, 2015 @ 3:55am 
its a little laborious buuuuuuuuuut, you could uninstall steam and sift through the registry to see if there are any entries relating to steam and remove them. do you only have one library for steam or multiples?
blackhawk252 Apr 24, 2015 @ 7:51pm 
so I've done everything here but will not open im not sure how to do registry is there any steps i need to take ive tried other forums but nothing is working :(
im having the same issue here now :S but it Does sound like the harddrive does a jump when i try starting steam.. looks like its gona start everytime, but kinda never does :S
Squirtle Jun 25, 2015 @ 12:14pm 
Originally posted by The_Darkness86:
im having the same issue here now :S but it Does sound like the harddrive does a jump when i try starting steam.. looks like its gona start everytime, but kinda never does :S


Originally posted by blackhawk252:
so I've done everything here but will not open im not sure how to do registry is there any steps i need to take ive tried other forums but nothing is working :(

If you have Rolled Back you Driver lately, this is the reason. All you have to do is update you Display Adapter.

Windows 7: Control Panel/Hardware And Sound/Device Manager/Display Adapters. Right click on your Display Adapters and select "Properties". Afterwards go into "Driver" and select "Update Driver".

Windows 8: Search "Control Panel" in the search and everything else afterwards is the same.

Hope this helped :)
Last edited by Squirtle; Jun 25, 2015 @ 12:15pm
christopher.cuche Jun 25, 2015 @ 12:36pm 
For me it's impossible to launch any games, the screen comes black and I have to restart my mac. Tried to re-install but not working still, any clue on what's going on?
zester Jun 25, 2015 @ 12:49pm 
I am having the same problem - very annoying
zester Jun 26, 2015 @ 10:28am 
Has this been solved yet?
Squirtle Jun 26, 2015 @ 11:26am 
Originally posted by mhildrethbell:
Has this been solved yet?

Did you try Updating your Visual Adapter?
Bad 💀 Motha Jun 26, 2015 @ 11:29am 
GPU Drivers; Steam requires that.
ga5m5k Jul 22, 2015 @ 3:08am 
currently having the problem reinstalled, updated drivers, did a virus scan, and checked registry. still it looks for updates, then tells me its logging in, then poof. nothing. need to know a sure fire fix for this. its very irritating.
< >
Showing 1-15 of 56 comments
Per page: 15 30 50

Date Posted: Jun 6, 2013 @ 10:41pm
Posts: 56