Nettacki Dec 25, 2012 @ 1:37am
"Error reading data segment" error upon trying to launch Steam
I've been getting this error lately after it downloaded a client update of sorts. I've reinstalled this several times and it still hasn't been solved.

Is there any solution to this problem? So far, I've deleted ClientRegistry.blob, reinstalled Steam, and ran CheckDisk for any HDD errors (which I managed to fix somewhat).
< >
Showing 1-2 of 2 comments
pcnuttie Dec 25, 2012 @ 1:44am 
Reformat? It sucks i know but i never heard of this error before. Might have to dig in forums. Try www.overclock.net Maybe someone knows there. I am a free proud member refer me if you sign up 78@pwnt4lif3 AND i think maybe you should try this.. CCleaner? Maybe you have left over files in the registry that needs to be clean and if your steam works then it's that. If it's NOT that then if i were you i'd reformat. For the sake of it. but that's just my 2 cent
Nettacki Dec 25, 2012 @ 1:46am 
I did the CCleaner thing. Still didn't work. However, I managed to solve this thing by myself by "refreshing" my steam files as mentioned in "Help: Steam Doesn't start no matter what I try" thread. It finally worked.
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Date Posted: Dec 25, 2012 @ 1:37am
Posts: 2