Ying☻Kit Dec 4, 2012 @ 3:55pm
Cannot connect to steam server?
Hey guys, I've been unable to connect to steam since yesterday. Most of the time this will sort it self out, after numerous failed attempts i lost my patience and deleted steam from my computer. Now when i try to start steam i get the 'steam is updating' box but then i get this error.

Steam.exe(main exception): To run Steam, you must first connect to the internet.

So i tried to do numerous things, such as restarting my computer, restarting steam, restarting my router, set a static ip for my computer, disable and re -enable my network.
None of these seem to work. I thought it could be a router problem, however my laptop seems to connect fine to steam network.

So i tried another to look for possible programs that interfere with steam, i went through this and pretty much deleted everything listed on there https://support.steampowered.com/kb_article.php?ref=9828-SFLZ-9289

I completely deleted my anti virus disabled my firewall, it still gives me the same problem. Anyone got a solution to this strange problem?
< >
Showing 1-15 of 36 comments
Ying☻Kit Dec 5, 2012 @ 3:15am 
Nah, i pretty much uninstalled every software that functions as a firewall.
Felix Dec 5, 2012 @ 3:17am 
Try launching Steam using the
launch parameter. If you don't know how to do that, this Support article should help: https://support.steampowered.com/kb_article.php?ref=5623-QOSV-5250

If that doesn't work, have a go with the
launch parameter.
Ying☻Kit Dec 5, 2012 @ 3:56am 
Blah! Still doesn't work, thanks for the help thought, much appreciated. I've had server issues before about unable to connect to steam server, but never one that states i don't have the internet.
Ying☻Kit Dec 5, 2012 @ 6:51am 
Tried this method quite a few times, doesn't seem to work. This and removing steam completely doesn't seem to have any impact. The thing is it tries to update, but doesn't make any progress before claiming i don't have any internet. So it seems to be struggling to connect to the server for some reason.
Ying☻Kit Dec 5, 2012 @ 7:07am 
I believe my ISP is plusnet (division of BT), most likely on about 10 mbps line. I have considered my ISP being the root of it, however, steam works and updated completely fine on my laptop and also ive been using steam in this house for about a year now without any problems.
Fen1x(0_0) Dec 5, 2012 @ 7:34am 
fred this is the third post about this problem you've given this same junk advice to bro. To many ppl are having this issue for it to be anything simple like a driver issue. It has to be a file or something that steam Installed with there last update. SO unless you have roll back program that we can all use to go back one update or something dont waste your breath with stupid ♥♥♥♥ing driver update advice.
Ying☻Kit Dec 5, 2012 @ 8:26am 
Ive updated my driver but still no go, I ran through windows update yesterday thinking that there might be possible conflict with steam, but still not able to get it working. Oh speaking of rolling back versions i did try installing a real old version of steam (about 2006 i think) however it also stumbled on the 'update' box section.In my case its def something thats preventing me from connecting to the steam server. No idea what though, as most of these solutions are revolving around this issue. Thanks for the help though, it really sucks that it still won't work :/
Ying☻Kit Dec 5, 2012 @ 10:46am 
Nah, tried that multiple times still no results. . This is getting pretty frustrating :/
FlamingDeath (Banned) Dec 5, 2012 @ 11:20am 
Have you tried using system restore in windows to bring it back to an earlier date?
Ying☻Kit Dec 5, 2012 @ 11:36am 
Nah, i uninstalled all anti virus and spyware software. So its pretty much naked atm.
Miha22 Dec 5, 2012 @ 12:31pm 
as i had the same problem and it seems to be resolved now, i wanted to share what i did.
actually all i did was run windows update and there was an update for win 7 professional 64bit version that had some compatibility fix.
Last edited by Miha22; Dec 5, 2012 @ 12:33pm
Ying☻Kit Dec 5, 2012 @ 12:46pm 
Testing TCP Port: done
TCP Passed:
TCP Failed: 27014-27050
Testing UDP Port: done
UDP Passed: 1500,3005,3101,3478,4379-4380
UDP Failed: 27000-27030,28960
Detailed Results

UDP Passed: 1500,3005,3101,3478,4379-4380
TCP Handshake Connection Timeout: 27014-27050
UDP Payload Receive Timeout: 27000-27030,28960

Well the results do look kinda bad :P.

I do understand that i haven't port forwarded (due to me being unable to access the router) however, I've been using steam for about a year without any problems also my laptop can still connect to steam on the same router.

Miha22 Dec 5, 2012 @ 12:47pm 
oh sorry must have missed that in the comments i read

have you tried copying your steam folder from your laptop to you desktop pc? (dont copy steamapps folder, just the rest)
Last edited by Miha22; Dec 5, 2012 @ 12:49pm
Ying☻Kit Dec 5, 2012 @ 12:53pm 
Yeah i tried that, it game me another error, cant remember the details but i think it had something to do with a DLL file. Maybe its due to system incompatibility.
Ying☻Kit Dec 5, 2012 @ 1:48pm 
Hmm you have a good point there, i do def know that its something on 'this pc' that is preventing steam from hooking up. If it is due to high bandwidth then it could be tracking my IP address.

My ISP is Plusnet (a division of BT) the router im using is a voyager 2110
< >
Showing 1-15 of 36 comments
Per page: 15 30 50

Date Posted: Dec 4, 2012 @ 3:55pm
Posts: 36