This topic has been locked
TheRealGrinch May 11, 2013 @ 9:36am
Failed to Start Game (Unknown Error)
I have played over 300 hours of Team Fortress 2 on the same computer but this weekend i could not get in game. It simply said "Failed to Start Game (Unknown Error)". Unfortunately i play on a Mac so many tips and tricks dont work. Any suggestions?
Last edited by TheRealGrinch; May 27, 2013 @ 7:44pm
< >
Showing 1-15 of 455 comments
computer May 11, 2013 @ 10:34am 
Same thing here. This is a brand new, fresh install of OSX 10.5.8, literally nothing else has been installed before Steam and TF2.
Dat Kitty May 11, 2013 @ 2:52pm 
Same here, OSX 10.5.8, This isn't the first time this happened, dumb update was carless and caused this again, you're going to be unable to play tf2 for like another 3 or 10 more days, Just like the last holloween event, and valve is going to focus on us last and more on the next update -_-
TheRealGrinch May 11, 2013 @ 3:59pm 
oh great
AgentOracle May 12, 2013 @ 8:36am 
Aww crap. And here i just finished deleting my entire appcache folder after reading that "missing file" error.

So, no TF2 this weekend? I think I'm gonna be ill.
sta_0027 May 12, 2013 @ 9:42am 
Same ♥♥♥♥ here. 10.5.8. CSS is not starting.
Steam sure sucks like hell.
TheRealGrinch May 12, 2013 @ 11:08am 
i fugured out how to stop it
computer May 12, 2013 @ 3:58pm 
Thanks for the helpful comment. Care to enlighten us, please?
TheRealGrinch May 12, 2013 @ 5:26pm 
so what you do is that you click play game, and then when the notice comes up click 'ok' and do it again, and again, and if it does not work in the first say 20 tries, quit steam, log back in, and do it over. It has worked for me...
Sofa King May 16, 2013 @ 10:52pm 
Bump, same problem.
Guy On Fire May 17, 2013 @ 11:01am 
10.5.8. No need to say that I have the same problem and I reinstalled the game 2 times during this week. It's incredible how I always find some new reasons to hate steam.
Mr. Skeltal May 17, 2013 @ 11:47am 
Same specs and same crash. Last night it worked if you clicked OK after the 'unknown error' message and just tried to play anyway...however with the update that I just installed it just says 'syncing' for a second and crashes completely. Hopefully someone finds a way to fix this...
Last edited by Mr. Skeltal; May 17, 2013 @ 11:51am
yancypants May 17, 2013 @ 2:11pm 
Same thing right now for TF2 and new CS-Global Offensive I just downloaded. "Failed to start game (unknown error). Tried doing it over and over, restarted, everything, no change.
Pollo May 17, 2013 @ 5:15pm 
Same thing happening to me, 10.8.5. Installed TF2 twice along with Steam and it is still happening. This is getting so freaking annoying, and it needs a fix, fast.
Logrey May 18, 2013 @ 6:35am 
Same Here im on 10.5.8! And this is happening to me I want robokeys!
Logrey May 18, 2013 @ 6:42am 
Don't even bother with Steam Support, Ive contacted them and they've provided me with nothing but mere useless information. Just a waist of time. *Also while your done with validating the cache files and click "play game" it will say that you currently have a game in the process of launching, and wait until it is complete (it wont be complete). And you could start your game by having someone invite you to one, but "thankfully" the new TF2 update patched that XD.
< >
Showing 1-15 of 455 comments
Per page: 15 30 50

Date Posted: May 11, 2013 @ 9:36am
Posts: 455