Fatal Error: VGUI_Setup failed
I've seen a lot of people having the exact same issue as me on this, perhaps it's something to do with a new Steam up-date? Anyway; can anyone give me some tips on how to fix this. From what I've seen, Re-Installing does NOT work.

< >
Showing 1-11 of 11 comments
Batman Apr 4, 2013 @ 1:06pm 
i have the same problem, any solution?
I fixed it, but only via another error.
So I dowloaded the Steam installer, and clicked repair, half way through repair an error occured, LEAVE THAT UP. Then click to start Steam, it updates Steam and replaces the file, fixed it for me.
SprayTactics Apr 5, 2013 @ 11:48am 
Just go to the "bin" folder. just move the "vgui2_s.dll" out of the bin folder. that is how i fixed this error. It worked for me.
Batman Apr 6, 2013 @ 2:30am 
thanks man, the restless solution work for me, thanks a lot both.
barrett1522 Apr 6, 2013 @ 6:16pm 
I tried the first one and it seemed to have worked so far, thanks to both for the helpful suggestion, I have been worried about this problem for a couple days now.
Techy Apr 8, 2013 @ 9:31am 
The suggestion ModernEzio gave works as well. This relies on the commonly known steam self repair feature. When a file is missing it is re-downloaded automatically. Delete vgui2_s.dll from c:\program files\steam\bin or c:\program files (x86)\steam\bin and start steam again. The file is downloaded automatically and fixes steam.
Gojira Apr 8, 2013 @ 11:41am 
I did what the guy above did, I went to the "bin" folder and deleted the "vgui2_s.dll" thing and badaboom it works now
SaudiBear Apr 9, 2013 @ 6:05pm 
Go to your bin folder in steam and move out vgui2_s.dll thats what i did and it worked!! :DD
Eueh Apr 18, 2013 @ 10:41pm 
The above suggestions work. Fixed.
Zâbina Apr 22, 2013 @ 4:29pm 
Originally posted by ModernEzio:
Just go to the "bin" folder. just move the "vgui2_s.dll" out of the bin folder. that is how i fixed this error. It worked for me.

This fixed it for me too. Thanks a lot for awnser mate!
Last edited by Zâbina; Apr 22, 2013 @ 4:30pm
yesto Apr 28, 2013 @ 9:31am 
i tried both ways but my steam now sits at Connecting steam account forever and the minized icon says Steam (Not Responding)
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: Apr 4, 2013 @ 7:31am
Posts: 11