This topic has been locked
Marko Aug 1, 2015 @ 12:50pm
Slow ALT-TAB on some games after Windows 10 Upgrade.
I recently 'upgraded' my PC from Windows 7 Ultimate (64bit) to Windows 10 Pro.
I have noticed some problems when trying to alt-tab out of some full-screen games.

Certain games that would always alt-tab instanttly, smoothly with no black screen in the process while on Windows 7 are showing completely opposite results now i'm running Windows 10.

Basically this game is taking 1-3 seconds to tab out on windows 10, feeling very slow/buggy and with a temporary black screen in the process. This NEVER happened while on Windows 7, and is very frustrating. I am talking about the game Arma 2 and Arma 2 Operation Arrowhead for the ones interested.

I have done some experimenting/testing with NVIDIA drivers/settings, and am almost totally able to rule them out as a cause. All i ask for is this game to alt-tab the same quick, snappy way it did on Windows 7 now that my PC is running windows 10. Guess it's windowed mode for the time being then...

Anyone else noticed any similar issues after 'upgrade' to Windows 10?
< >
Showing 1-15 of 34 comments
Mark WALLBANG Aug 6, 2015 @ 12:18am 
I have the same issue, it gets really annoying at times
Terminus Aug 6, 2015 @ 3:30am 
Hey

Regarding "Windowed Mode" - there are applications to run the game in a "Borderless Window" / Fake Fullscreen Mode":
Last edited by Terminus; Aug 6, 2015 @ 3:30am
Dick Justice Aug 6, 2015 @ 6:59pm 
Encountering this myself. I initially thought it was an issue with refresh rate, but my desktop and in-game (GTA V) refresh rate are both 60, yet there's still a very noticeable delay when alt-tabbing, which isn't the case with 7.
Notebene Aug 7, 2015 @ 6:43am 
For what it's worth, I have NOT upgraded to Windows 10, still using Windows 8.1, and this started happening to me after the last update around the time of the Windows 10 launch. I'm actually surprised I haven't seen 'more' complaining across the board about this issue.

This definitely makes me feel it's an nVidia issue.

I play all my games in some sort of Borderless Windowed Fullscreen mode. As of now, none of them require any sort of 3rd party help to achieve it, they have it baked in. If I've had focus on the game for a few minutes, the new alt-tab over to, say, a browser (Chrome) will be slow. After that initial slowness, I can alt tab around and it's nice and loose. If I settle back on a game and play for a few minutes then alt-tab back out to something else, that initial delay will return.

It's very annoying.
Dick Justice Aug 7, 2015 @ 8:43am 
On this topic, does anyone else have issues getting loudness equalization to work? I'm using Nvidia's audio drivers to output sound via HDMI to my monitor, and the effect doesn't work, resulting in games and videos going really quiet, then really loud, which isn't an issue on 7 where the effect works properly.
Dusk of Oolacile Aug 7, 2015 @ 8:50am 
W10 needs some resources for its spyware activity, otherwise it would break the law of conservation of energy. You just have to accept that it will always be slower than a clean OS.
Marko Aug 7, 2015 @ 5:17pm 
Originally posted by Notebene:
For what it's worth, I have NOT upgraded to Windows 10, still using Windows 8.1, and this started happening to me after the last update around the time of the Windows 10 launch. I'm actually surprised I haven't seen 'more' complaining across the board about this issue.

This definitely makes me feel it's an nVidia issue.

I play all my games in some sort of Borderless Windowed Fullscreen mode. As of now, none of them require any sort of 3rd party help to achieve it, they have it baked in. If I've had focus on the game for a few minutes, the new alt-tab over to, say, a browser (Chrome) will be slow. After that initial slowness, I can alt tab around and it's nice and loose. If I settle back on a game and play for a few minutes then alt-tab back out to something else, that initial delay will return.

It's very annoying.

Just to clarify, you are running win8.1 and are also experiencing the issue that after an update some fullscreen games/applications that used to alt-tab instantly are now slow/delayed/with black screen in the process?

As for NVIDIA i tested both older and latest drivers on windows 7 and 10.
In every test, Arma 2/OA would alt-tab instantly when PC was running win7 and would be slow/delayed on win10. (no matter what drivers) I talked to NVIDIA through live chat, and both times they were hinting it was an issue on microsofts side...? (though it felt like the chat agent wasn't too knowledgeable lol)
Last edited by Marko; Aug 7, 2015 @ 5:24pm
Bakawun Aug 7, 2015 @ 8:40pm 
It's a Microsoft issue. I'm on an AMD card seeing the EXACT same issue. Also kills audio during alt-tab process... What's up Microsoft?
Marko Aug 8, 2015 @ 10:18am 
I have just talked to a friend that also recently switched from Win7 to 10 and he confirms some games experiencing slow/delayed alt-tab after he switched to Win10.

:steamfacepalm:
Last edited by Marko; Aug 8, 2015 @ 10:19am
Notebene Aug 11, 2015 @ 9:51am 
Originally posted by Marko:
Originally posted by Notebene:
For what it's worth, I have NOT upgraded to Windows 10, still using Windows 8.1, and this started happening to me after the last update around the time of the Windows 10 launch. I'm actually surprised I haven't seen 'more' complaining across the board about this issue.

This definitely makes me feel it's an nVidia issue.

I play all my games in some sort of Borderless Windowed Fullscreen mode. As of now, none of them require any sort of 3rd party help to achieve it, they have it baked in. If I've had focus on the game for a few minutes, the new alt-tab over to, say, a browser (Chrome) will be slow. After that initial slowness, I can alt tab around and it's nice and loose. If I settle back on a game and play for a few minutes then alt-tab back out to something else, that initial delay will return.

It's very annoying.

Just to clarify, you are running win8.1 and are also experiencing the issue that after an update some fullscreen games/applications that used to alt-tab instantly are now slow/delayed/with black screen in the process?

As for NVIDIA i tested both older and latest drivers on windows 7 and 10.
In every test, Arma 2/OA would alt-tab instantly when PC was running win7 and would be slow/delayed on win10. (no matter what drivers) I talked to NVIDIA through live chat, and both times they were hinting it was an issue on microsofts side...? (though it felt like the chat agent wasn't too knowledgeable lol)

Yes, running 8.1, and right around the time nVidia released new drivers a day or so after W10 hit is when my problem started.

Doesn't surprise me that nVidia's answer was to blame it on Microsoft. It's the cheapest solution.
Notebene Aug 11, 2015 @ 9:52am 
Originally posted by Bakawun:
It's a Microsoft issue. I'm on an AMD card seeing the EXACT same issue. Also kills audio during alt-tab process... What's up Microsoft?

If it's a Microsoft issue, then it's an update they 'also' gave Win 8.1 OS, and it's not isolated to W10.
Erodoeth Aug 12, 2015 @ 5:19pm 
I'm having the same prob: Win 7, no lag; Win 10, lag. So I guess is a microsoft prob and they will fix it as soon as there is an update... ♥♥♥♥♥ annoying tho....
Valkyrian Aug 13, 2015 @ 12:52pm 
Happening to me only with Windows 10. No issues with Windows 7. Some problem with refresh rate on fullscreen games, regardless the settings are right.

GPU: XFX R9 270X 2GB
DRIVERS: CCC 15.7.1
Last edited by Valkyrian; Aug 13, 2015 @ 1:01pm
Stevefox Aug 28, 2015 @ 2:57pm 
i had the same exact problem few days ago and it started in about 5 days after upgrading to windows 10. Now i am back to windows 7, and guess what ? i don't have that problem anymore. Sadly DX12 is coming out soon, and the only way to have it is through windows 10.

GPU: MSI GTX 970 4GB
CPU: i7 4790k Devil's canyon
Start_Running Aug 28, 2015 @ 3:38pm 
That problem is a problem in the Windows OS. Write to Microsoft about it.
< >
Showing 1-15 of 34 comments
Per page: 15 30 50

Date Posted: Aug 1, 2015 @ 12:50pm
Posts: 34