EvilBro Nov 5, 2017 @ 11:02am
<Solved> Unity games won't run on Windows 10 1709
Short story:
Games that use Unity do not work and give an error:
"IndexOutOfRangeException: Array index is out of range.
at UnityEngine.Display.RecreateDisplayList (System.IntPtr[] nativeDisplay) [0x00000] in <filename unknown>:0"
What is wrong? And how do I fix this?

Long story:
A few days ago Windows 10 updated to version 1709. All seemed well until I wanted to play a game of Twilight Struggle. When I started it, there was an icon on the task bar and the title screen music, but no title screen. I "quickly" discovered that this happens with all games in my library that use Unity.

I thought the graphics driver might perhaps be at fault, so I upgraded to the newest version (Nvidia geforce 388.13 for a GTX 650). This changed nothing. I tried several driver versions (376.19, 382.05), but all had the same result.
If I disable the driver, games start normally (albeit really slow). If I look at the outout_log.txt from a Unity based game, I see that the driver it reports is Microsoft Basic Render Driver.
If I enable the driver, I see that it mentions NVIDIA Geforce GTX 650 in the output_log.txt. It also has the following exception in output_log.txt:
"IndexOutOfRangeException: Array index is out of range.
at UnityEngine.Display.RecreateDisplayList (System.IntPtr[] nativeDisplay) [0x00000] in <filename unknown>:0"

I've tried all types of launch settings (dx 9, dx 11, etc.), I've tried with game bar and without, I've tried with overlays (steam's and geforce's) and without and none of it had any impact.
Some games like Teslagrad give the same error in the output_log.txt, but also give a popup that says "Couldn't switch monitor resolution".

Does anyone know what might cause the IndexOutOfRangeException? And how to avoid it? Or what else I can try to troubleshoot this problem further?
Last edited by EvilBro; Nov 11, 2017 @ 12:26pm
< >
Showing 1-15 of 66 comments
EvilBro Nov 7, 2017 @ 2:55pm 
Some additional info: If I start a game while holding shift, I get a config-window. This window has a pull-down field "Select monitor". This field has no options in it.
Could this be related to the problem?
EvilBro Nov 11, 2017 @ 12:25pm 
This post is just to document how I fixed this (Maybe it is of some use to someone):

After some more experimenting, I discovered that Dark Souls 3 didn't work properly either. It opened in a 800x450 windowless box in the top left corner of the desktop. Given that this had nothing to do with Unity, I was a bit perplexed. When I went to the options to change the resolution (within Dark Souls), I couldn't go windowed and the only resolution was 800x450.
I went into GeForce Experience and from there I was able to launch DS3 windowed. In windowed mode, it had all kinds of resolutions it could switch to. As soon as you switched to full screen, only the 800x450 would be available.
I went into Nvidia Control Panel. This is where I changed "Aspect ratio" to "No scaling" on the Adjust desktop size and position page (with "perform scaling on Display"). Suddenly everything was okay again. In DS3 I had options for resolutions. If I started up a Unity game with shift, the Select Monitor was no longer empty, but said "Display 1".
I tried switching back to "Aspect ratio" to see if this would break things again. It did for some games (e.g. Hearthstone), but others kept working. I also tried "Override the scaling mode set by games and programs" and that seem to work as well.

Now I have no idea why this works, but it did (for me).



Akayen Nov 16, 2017 @ 2:42am 
You sir are a hero!
This is probably the only place on the whole Internet with a solution for this problem.
Niskala Nov 23, 2017 @ 8:49pm 
Yes! I had the same issue and this solved it!

It's a good thing my friend thought to google the line from my Superhot VR log:

IndexOutOfRangeException: Array index is out of range.
at UnityEngine.Display.RecreateDisplayList (System.IntPtr[] nativeDisplay) [0x00000] in <filename unknown>:0

I just wish I had found this sooner :)
johnnyyen Nov 28, 2017 @ 8:29am 
Thank you! This solved my issues with most of my games! (only Life is Strange Before the Storm is still stubborn. As their customer service.):salvador:
hanrai Dec 1, 2017 @ 3:34am 
It's working for me!
Forgetful Dec 10, 2017 @ 11:43pm 
Thank you very much for documenting the solution EvilBro! Worked like a charm.
Bratan Dec 12, 2017 @ 10:24am 
EvilBro, thx bro! Now spellforce 3 is working. In City skyline a black screen apears now and after some seconds I became an error. Exe doesnt working...
EasyCompany Dec 13, 2017 @ 8:17pm 
Will the fix above work on my AMD card? I can't find any option that matches what EvilBro wrote.
zeotherm Dec 17, 2017 @ 11:54am 
For the record, I had the same issue and came upon this thread. My laptop has a Nvidia GTX 860M and an Intel Integrated Graphics adapter. What I found that fixed this issue was to go into the Intel Control panel and switch the 'Scaling' option from "Maintain Display Scaling" to "Maintain Aspect Ratio"

Now all my Unity based games seem to be running fine, where as before I got that exception in them after the Windows Fall Update. So, seems to NOT be an NVidia thing, but a Intel thing. Hope this can help someone out.
|FOS|. Awperator Dec 18, 2017 @ 10:29am 
I have AMD cards will this still work?
Hammersmith Dec 18, 2017 @ 8:32pm 
Originally posted by zeotherm:
For the record, I had the same issue and came upon this thread. My laptop has a Nvidia GTX 860M and an Intel Integrated Graphics adapter. What I found that fixed this issue was to go into the Intel Control panel and switch the 'Scaling' option from "Maintain Display Scaling" to "Maintain Aspect Ratio"

Now all my Unity based games seem to be running fine, where as before I got that exception in them after the Windows Fall Update. So, seems to NOT be an NVidia thing, but a Intel thing. Hope this can help someone out.

Thanks! ^^ I can now play Cuphead and Battle Chasers: Nightwar again! (And any other Unity games I have, I suppose.)
debbie6754 Dec 19, 2017 @ 1:07pm 
Thanks so much. I clicked on "Override the scaling mode set by games and programs" and it worked. The game takes longer to load but it plays.
zeotherm Dec 19, 2017 @ 1:42pm 
Originally posted by |FOS|. Awperator:
I have AMD cards will this still work?
I would imagine so, since this is an issue not with the NVidia/AMD card, but with the Intel Integreated card. Let us know if it works!
capedcrafter Dec 20, 2017 @ 6:48am 
Originally posted by |FOS|. Awperator:
I have AMD cards will this still work?

I went to AMD Radeon settings and under 'display' changed scaling mode from 'preserve aspect ratio' to 'full panel'. Worked perfectly for me. Games are running again. Thx for the tip EvilBro!
< >
Showing 1-15 of 66 comments
Per page: 15 30 50

Date Posted: Nov 5, 2017 @ 11:02am
Posts: 66