Star Trek Online

Star Trek Online

View Stats:
who is Oct 4, 2013 @ 7:45pm
Game not launching
I've lost track of how many times I've tried uninstalling and instaling again. The game simply crashes when it reaches the loading screen with legacy of romulus. I'm trying to play it with a laptop, could this be the problem? Configuration wise I don't think so: I7 2.5ghz, 8gb RAM DDR3, Geforce GT630M 2gb

I'm installing it at my HDD partition wich I use for games only.
< >
Showing 1-5 of 5 comments
Warwolf Oct 5, 2013 @ 3:03am 
Yep, same here, but playing on a pc. I definitly meet the requirements since I already had the game running a bit earlier this year. Then I wiped my hdd and now had to download it again of course. And now the game crashes at the LoR loading screen. I'm already running the game's exe as administrator and stuff. Anyone got a solution?
Kill Me Oct 5, 2013 @ 12:51pm 
does the screen go black, or just plain shut down?
who is Oct 5, 2013 @ 4:56pm 
I've downloaded it from the official website and that version works.

Originally posted by Cam-Ikazi:
does the screen go black, or just plain shut down?
It reachs the loading screen and stays there for a while, if you click, it show the program isn't responding.
Warwolf Oct 6, 2013 @ 8:26am 

BTW: Tried the version from the official homepage, still same error for me though
who is Oct 7, 2013 @ 12:21pm 
What I noticed that I did with the official website version was that when the Windows Firewall warning pops up, instead of clicking to allow it trhough the firewall I've waited the game to load. If you are using the windows default firewall, this could be the problem
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Oct 4, 2013 @ 7:45pm
Posts: 5