Star Trek Online

Star Trek Online

View Stats:
Shadowspown Jun 11, 2013 @ 1:49pm
Any one having probs getting in game or even staying in game?
i have ben trying all day and i cant stay one for more then 30 sec, that is if i make it on at all.
any one having this prob?
< >
Showing 1-15 of 15 comments
Kingrarr Jun 11, 2013 @ 3:36pm 
Started yesterday for me, same in Neverwinter. What is your ISP? See if it is something common.
Edeon Jun 11, 2013 @ 4:03pm 
It's nothing to do with ISPs or even the users. It's something on Cryptic's end, but Cryptic, in all their infallible "wisdom" states that it's the users, not them, like it's -fact-, when it isn't.

Basically, their train of thought on this matter is "Oh what's that? The servers are acting up? Must be your internet lol" despite the fact that there's hundreds of people, maybe even more, suffering from the SAME. EXACT. PROBLEM.

GG Cryptic. -Slam- that nail into the coffin.
Last edited by Edeon; Jun 11, 2013 @ 4:08pm
Loina Jun 11, 2013 @ 9:41pm 
I've been having the same server lag issues really irratating.
Fuzzy466 Jun 11, 2013 @ 10:26pm 
Well game not even loading for me not just hangs in windows, trying reinstall atm.
Shadowspown Jun 11, 2013 @ 11:27pm 
well then at least its not just me lol
Bourbonator General Jun 12, 2013 @ 12:57pm 
I've had problems since yesterday as well. rather frustrating.
gallyefc123456789 Jun 13, 2013 @ 10:50am 
ye it cannot connect to cryptic patch servers
Dred Nox Jun 13, 2013 @ 10:53am 
same issues for me. they supposedly maintenanced the shard, gg screwing that pooch
ダニエル Jun 13, 2013 @ 11:00am 
I was a bit confused when I finished downloading the patch and found that, after it had crashed and I verified the cache integrity, I was missing 3.9 GB. Not sure what happened there. =S
Hugolin Jun 13, 2013 @ 11:02am 
yeah i like the game...when im able to play it
ShotsofJack Jun 13, 2013 @ 11:15am 
when i go to play the game it opens a window with i think its japanese and its just one sentence and i cant do anything but close the window, i even tried downloading the game from the website and still the same, i used to play it but now it wont let me in
madamn3470 Jun 21, 2013 @ 1:56pm 
same problem and i like the game from what ive played
OCC Jun 21, 2013 @ 2:51pm 
Got to play yesterday afternoon after the new patch at 5 Pm.. crashed at 6 Pm and launcher will not work . Downloaderd another launcher from a site I got from STO forums and that wont work .
So I don't know why criptic would think its us and not them
Last edited by OCC; Jun 21, 2013 @ 2:53pm
ダニエル Jun 21, 2013 @ 3:48pm 
It seems to have a habit of doing things like this. What's particularly nasty is that the game also sometimes crashes when loading an area and you see the patching notification at the top, the whole thing just freezes. I know Cryptic do this with their other games too, but I don't see why they have to do it in the middle of the game.

Aren't patchers called that for a reason after all??
OCC Jun 21, 2013 @ 5:25pm 
Ok found this and it worked for me :)
fix your launcher by going to properties, and setting the game launch into maximized
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Date Posted: Jun 11, 2013 @ 1:49pm
Posts: 15