Demolition, Inc.
Demolition, Inc. > 일반 토론 > 제목 정보
NukeJockey 2013년 4월 9일 오후 10시 20분
Integer Divide-By-Zero - Game Startup Crash [SOLVED]
^ The thread title is the message the log gives, not sure if its relevant or not.

Bought this game way back at release, played through it, all was good.

Re-downloaded last night, after Steam alerted me to its update with Steam Workshop integration.

Went to launch it, goes to a black screen then an error box.

Log started on Wed Apr 10 15:14:22 2013 *** Exception: Integer Divide-by-Zero at 0x6953dba8 *** --- Registers --- EAX = 0003c000 EBX = 0c318180 ECX = 00000280 EDX = 00000000 EBP = 0018f07c CS:EIP = 0023:6953dba8 SS:ESP = 002b:0018ef30 DS:ESI = 002b:0be74b08 ES:EDI = 002b:00000180 FS = 0053 GS = 002b Eflags = 00010246 --- FP/MMX Registers --- ST0 = 0.000000e+000 ST1 = 7.500000e+000 ST2 = 1.000000e+000 ST3 = 0.000000e+000 ST4 = 2.300000e+001 ST5 = 1.000000e+000 ST6 = 2.500000e-001 ST7 = 3.307100e+004 MM0 = 0000000000000000 MM1 = f000000000000000 MM2 = 8000000000000000 MM3 = 0000000000000000 MM4 = b800000000000000 MM5 = 8000000000000000 MM6 = 8000000000000000 MM7 = 812f000000000000 --- Disassembly --- 6953db20: mov esi, [ebp+10] 6953db23: mov eax, [eax] 6953db25: mov esi, [esi+6c] 6953db28: push edi 6953db29: push dword ptr [esi+34] 6953db2c: mov [esp+10], eax 6953db30: push dword ptr [esi+30] 6953db33: mov dword ptr [esp+20], 00000000 6953db3b: push 00 6953db3d: push dword ptr [esi+38] 6953db40: call 695c32b0 6953db45: or eax, edx 6953db47: jnz 6953db6e 6953db49: mov eax, [ebp+24] 6953db4c: mov dword ptr [eax], 00000000 6953db52: mov eax, [ebp+28] 6953db55: mov dword ptr [eax], 00000000 6953db5b: mov eax, [ebp+20] 6953db5e: mov dword ptr [eax], 00000000 6953db64: xor eax, eax 6953db66: pop edi 6953db67: pop esi 6953db68: mov esp, ebp 6953db6a: pop ebp 6953db6b: ret 002c 6953db6e: mov eax, [esi+24] 6953db71: mov ecx, [esi] 6953db73: mov edi, [esi+08] 6953db76: mov [esp+28], eax 6953db7a: mov eax, [esi+28] 6953db7d: mov esi, [ebp+0c] 6953db80: mov [esp+1c], ecx 6953db84: mov [esp+20], eax 6953db88: cmp esi, 03 6953db8b: ja 6953e17c 6953db91: jmp dword ptr [esi*4+6953e270] 6953db98: mov esi, [ebp+08] 6953db9b: mov eax, edi 6953db9d: imul eax, ecx 6953dba0: add esi, 000004f0 6953dba6: xor edx, edx 6953dba8: div eax, dword ptr [esi] <--- 6953dbaa: mov [esp+10], esi 6953dbae: mov [esp+2c], eax 6953dbb2: cmp eax, 00080000 6953dbb7: ja 6953dbc0 6953dbb9: mov esi, 00000008 6953dbbe: jmp 6953dbe4 6953dbc0: cmp ecx, 00000200 6953dbc6: ja 6953dbcf 6953dbc8: mov esi, 00001108 6953dbcd: jmp 6953dbe4 6953dbcf: mov edx, 00000400 6953dbd4: cmp edx, ecx 6953dbd6: sbb esi, esi 6953dbd8: and esi, fffff800 6953dbde: add esi, 00000908 6953dbe4: cmp eax, 00040000 6953dbe9: ja 6953dbf3 6953dbeb: and esi, fd 6953dbee: or esi, 01 6953dbf1: jmp 6953dc05 6953dbf3: cmp eax, 00080000 6953dbf8: ja 6953dbff 6953dbfa: or esi, 03 6953dbfd: jmp 6953dc05 6953dbff: and esi, fe 6953dc02: or esi, 02 6953dc05: cmp dword ptr [ebp+0c], 03 6953dc09: jnz 6953dc0e 6953dc0b: and esi, fe 6953dc0e: push 30 6953dc10: xorps xmm0, xmm0 6953dc13: lea eax, [esp+bc] 6953dc1a: push 00 6953dc1c: push eax 6953dc1d: db 0f 6953dc1f: jg 6953dc21

Theres my crash dump.

Things I have tried so far:

Downloading and installing OpenAL

Installing OpenAL from the extras folder in steamapps/common/demolition inc

Reinstalling Physx

Running as admin

Running in XP compatibility

Disabling my 2nd monitor

Disabling Crossfire and my 2nd monitor

Copying over my old Config File from a backup I had (I don't think the game even starts to read the config file, as it wont create its own)

All of the other "fixes" I've seen listed around have been of no use.

MY system specs:

i5 2500k @ 4.6ghz
P67 Sabretooth
8gb DDR3
2x 7950 in Crossfire @ 1000mhz

Running Windows 7 x64, with all available updates installed.

I'm out of ideas and the few hours I spent searching the net today have given me nothing.

Need help ASAP.


*EDIT* Forgot to mention, I've also verified the cache and have removed and re-downloaded the game from scratch, no change.
NukeJockey님이 마지막으로 수정; 2013년 4월 20일 오후 4시 02분
< >
1-88개 댓글 표시
Eyes 2013년 4월 11일 오전 3시 01분 

Sorry to hear you're having trouble with the game. Thanks for the very detailed report though!

One thing I could suggest is deleting your local profile (save data):
Go to MyDocuments and rename the DemolitionInc folder something like DemolitionInc_backup.
Then go to your steam folder (normally c:\program files\steam\) then go to userdata. You'll probably see a list of folders with numbers, one for each steam profile. Look in each one until you find another folder called '98600'. This is your steam cloud stored version of your savegame. So for example:

C:\Program Files (x86)\Steam\userdata\[userID]\98600\remote

Look for the file called profiles.xml, and rename it to profiles_backup.xml.

Then try and run the game. It won't be able to find your profiles, so will prompt you to create a new one.

If this fixes the problem, please zip up the DemolitionInc_backup folder that is in your MyDocuments, and email it to

NukeJockey 2013년 4월 11일 오후 5시 11분 
Hi Eyes,

Thanks for the response.

Unfortunately your suggestion did not work, still crashes with the same error.

Have my crash logs helped at all?

NukeJockey 2013년 4월 20일 오후 4시 01분 
Seems my issue was stemming from use of the AMD Cat 13.3 Beta 3 drivers. All working now.
Eyes 2013년 4월 21일 오전 1시 31분 
That's great news, h.IV. We'll take a look at these drivers ourselves and see what we can do anyhow.
Eyes 2013년 4월 23일 오전 9시 51분 
So...I tested those beta drivers myself, and everything runs fine my end. Very strange. Let me know if you have any other problems.
NukeJockey 2013년 4월 23일 오후 8시 11분 
I may have just needed to reinstall them, just out of curiosity, are you running a 7xxx series card?
Eyes 2013년 4월 24일 오전 1시 46분 
I'm afraid not. Being a small company we don't have access to all the hardware, so rely on you guys a bit to help out :) Let us know if you run into any other problems!
NukeJockey 2013년 4월 24일 오전 5시 17분 
Running the Catalyst 13.4 WHQL drivers which were leaked today, but not officially up on AMD yet and no issues. My guess is it was either a bug with a 7xxx card and the 13.3 beta 3s, or just a weird driver bug that uninstalling and reinstalling fixed, regardless of version.
< >
1-88개 댓글 표시
페이지당 표시 개수: 15 30 50

Demolition, Inc. > 일반 토론 > 제목 정보