Solar 2
Solar 2 > Общие обсуждения > Подробности темы
[Linux] Says I need to be running Steam, but I AM running Steam...
Topic says it all. I installed Solar 2 on Kubuntu 12.10 x64, ran it and itgives me a message that says Steam has to be running. Problem is, Steam IS running, just fine.
< >
Сообщения 115 из 17
I had the same error, restarting Steam as the message says fixed it for me.
I spoke too soon. The error is back and restarting does nothing.
Murudai  [Разработчик] 9 янв. 2013 в 21:15 
Just a weirdness of the Steam Linux Beta. Make sure it is updated to the latest version. You may need to restart your computer. Are any other Linux games having the same issue? (maybe not this exact issue, but being unable to use any Steam features or the Steam overlay). If you are still having issues, email me at and I can give you more detailed help.
Thanks, Jay. The next time I am on my laptop I will see if it decides to work, and, if not, if any other games are working.
Последний раз отредактировано Sir_Brizz; 9 янв. 2013 в 21:17
Isn't Steam for Linux really only supported on Ubuntu 12.04 LTS? ( Not surprised you're having issues...
No. They only (currently) guarantee the package dependencies are available in 12.04.
I have the same problem on Ubuntu 12.04
Последний раз отредактировано dwd; 10 янв. 2013 в 9:23
weird i dont have this issue at all on my ubuntu 12.04
After system reboot the problem is gone :)
Murudai  [Разработчик] 10 янв. 2013 в 17:38 
Okay, I just uploaded a patch to the Linux build that should help this. The issue is the Steam client being a bit slow, so I've made the game a bit more tolerant of that and giving the Steam client more time to respond. If you are still having the issue, then a restart should fix it. If it doesn't, email me at and we'll do some debugging.
I got the update, it is still not working. I will email you directly.
Murudai  [Разработчик] 10 янв. 2013 в 19:22 
The patch would have helped if the issue was the game, but it's certainly seeming more and more like the issue is with the Steam API unable to communicate to the Steam Client. So yeah, as I mentioned before this is because the client is still in Beta and the bugs are being worked out. I'll talk to Valve about this issue, see what they say about it.
It looks like it was indeed steam, here is a bug report

To fix just download and install steam_latest.deb then it should update properly.
That fix did indeed work for the time being. Thanks for your help all.
I had this problem as well, but when I quit steam it performed an update and upon login it and the game were cooperating.
< >
Сообщения 115 из 17
Показывать на странице: 15 30 50

Solar 2 > Общие обсуждения > Подробности темы