Volcanoids

Volcanoids

View Stats:
Volcanoids > Bugs > Topic Details
Venator Feb 8, 2020 @ 1:16am
Linux crashes
I am running Linux Mint 14.3 with kernel 5.3.0-28. I am using the oibaf mesa ppa drivers, which include Vulkan on a Radeon RX 580.

This provides me with OpenGL 4.6:
OpenGL vendor string: X.Org OpenGL renderer string: Radeon RX 580 Series (POLARIS10, DRM 3.33.0, 5.3.0-28-generic, LLVM 9.0.1) OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.1.0-devel (git-26ab38f 2020-02-07 bionic-oibaf-ppa) OpenGL core profile shading language version string: 4.60 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.1.0-devel (git-26ab38f 2020-02-07 bionic-oibaf-ppa) OpenGL shading language version string: 4.60 OpenGL context flags: (none) OpenGL profile mask: compatibility profile OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.1.0-devel (git-26ab38f 2020-02-07 bionic-oibaf-ppa) OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20 OpenGL ES profile extensions:

If I run the game without Vulkan, it states at the starting screen that I do not have OpenGL 4.5 support at least, which is not correct. The game itself renders okay, other than all the menu and HUD boxes, which are empty. No crash whatsoever.

If I run the game via -force-vulkan, it does crash whenever I try to climb up the ladder in the submarine, moving around in the submarine works, the menu and HUD boxes are correctly displayed. I played around with different resolutions, all types of shadow and render settings, from OFF to high.
Same result. Works in the submarine, but crashes immediately after climbing the ladder up.
Here is the logfile when using -force-vulkan:
https://pastebin.com/31UgrxDL

Edit:
I can play this game with Proton 5, but it would be great if it would be supported natively under Linux
Last edited by Venator; Feb 9, 2020 @ 2:45am
< >
Showing 16-27 of 27 comments
ripper81 May 12, 2020 @ 11:35am 
Great to see such a commitment to linux gaming.
Ondrej Petrzilka  [developer] May 19, 2020 @ 3:39am 
OpenGL issues were fixed, the support is now detected correctly and texts work.
This is part of tomorrows Co-op update.

Vulkan is still crashing and we're working on that with Unity3d. It seems there's issues with some shaders. Vulkan is great API, but it's implementation in Unity is less than optimal. On Windows it runs considerably slower than D3D11, which shouldn't happen.

Sorry for not answering earlier, we have the fix for about a month.
Last edited by Ondrej Petrzilka; May 19, 2020 @ 3:39am
zebh May 23, 2020 @ 11:29am 
Just tested the OpenGL version and it worked great! I will do some more extensive testing later and report back if I find more oddities.

Cheers!
ripper81 May 25, 2020 @ 3:20am 
I can confirm that the OpenGL detection is now working for AMDGPU+MESA on Kubuntu 20.04 and i found no graphical glitches. The OpenGL Version is 4.5. So it should be compareable to the DirectX 11 renderer that is used for the Windowsversion of the game. I found two bugs so far.

1. The display cannot be set to exclusive fullscreen mode. While the game works in borderless fullscreen it would be good to have real fullscreensupport to make Freesync/G-Sync available on Linux.

2. Sending a bugreport via the option in game triggers a systemreset of my rig.
zebh May 27, 2020 @ 8:11am 
Done a couple of hours of co-op so far (great fun!), and it seems solid. I've had some performance issues here and there, especially when running in 1440p, but nothing that seems like it needs to be fixed ahead of general optimisation. All in all, looking good!
Ondrej Petrzilka  [developer] May 28, 2020 @ 2:59am 
Vulkan might work soon, unity has fixed one of the main issues:
https://issuetracker.unity3d.com/issues/vulkan-crash-when-camera-sees-a-shader-with-more-than-64-descriptors

We're waiting for Unity 2019.3.15f1 to be released to confirm it works.
Last edited by Ondrej Petrzilka; May 28, 2020 @ 3:00am
Ondrej Petrzilka  [developer] May 28, 2020 @ 5:39pm 
Tested Unity 2019.3.15f1, unfortunately it still crashes.
But there's solution, which I think might be okay for you.

Use launch options:
-force-vulkan -gfx-enable-gfx-jobs 0

This will use Vulkan's native multicore rendering and disable Unity's custom multicore rendering. When both are enabled, it crashes.

If you'd like to disable also Vulkan's native multicore rendering for some reason, you can add -gfx-enable-native-gfx-jobs 0, but I wouldn't recommend it unless it's necessary or you're running on system with 2 cores or less.

Please let me know whether it work for you
Last edited by Ondrej Petrzilka; May 28, 2020 @ 6:04pm
zebh May 29, 2020 @ 8:01am 
Originally posted by Ondrej Petrzilka:
Tested Unity 2019.3.15f1, unfortunately it still crashes.
But there's solution, which I think might be okay for you.

Use launch options:
-force-vulkan -gfx-enable-gfx-jobs 0

This will use Vulkan's native multicore rendering and disable Unity's custom multicore rendering. When both are enabled, it crashes.

If you'd like to disable also Vulkan's native multicore rendering for some reason, you can add -gfx-enable-native-gfx-jobs 0, but I wouldn't recommend it unless it's necessary or you're running on system with 2 cores or less.

Please let me know whether it work for you

I did a quick test and could enter/exit my drill ship and walk around without issues. Game felt smooth and responsive. I'll give it a longer test during my next game session and report back.

Player.log: https://gist.github.com/zebh/384eedd0e03b3dc821de71bea63f9227
zebh Jun 2, 2020 @ 2:54am 
I have had a full co-op session since last post, and it worked very well. The Vulkan renderer certainly seems smoother and has my graphics card run about 5-7° cooler on average which is nice too see.

$ egrep "WARNING|ERROR" Player.log
WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities-flip' - All passes removed WARNING: Shader Did you use #pragma only_renderers and omit this platform? ERROR: Shader Hidden/Nature/Terrain/Utilities-flip shader is not supported on this GPU (none of subshaders/fallbacks are suitable) WARNING: Shader Unsupported: 'Hidden/Nature/Terrain/Utilities' - All passes removed WARNING: Shader Did you use #pragma only_renderers and omit this platform? ERROR: Shader Hidden/Nature/Terrain/Utilities shader is not supported on this GPU (none of subshaders/fallbacks are suitable) WARNING: Shader Unsupported: 'Particles/CaveBlast' - All passes removed WARNING: Shader Did you use #pragma only_renderers and omit this platform?
Ondrej Petrzilka  [developer] Jun 3, 2020 @ 5:21am 
Glad to hear that!

We know about the issue with shaders, it's some editor utilities for terrain, which are not used at runtime. However we're unable to remove them from the builds. Unity improved shader preprocessor recently, I'll take a look how we can remove these.

The CaveBlast is weird, when you're in caves and eruption occurs, do you see yellow "bubble" which grows?
ripper81 Jun 3, 2020 @ 8:31am 
I tested the game with vulkan. Sadly the performance was very weak for me. With all graphicsettings maxed out in 1080p i got between 50 and 70 FPS. With OpenGL i get 60-90 FPS. Both results are pretty poor considering the hardware my system is running on:

CPU: AMD Ryzen 5 3600
GPU: AMD Radeon RX 5700
Drivers: AMDGPU (Kernel 5.7) +MESA 20.1.0 LLVM/ACO
Last edited by ripper81; Jun 3, 2020 @ 7:43pm
zebh Jun 3, 2020 @ 10:49pm 
Originally posted by Ondrej Petrzilka:
Glad to hear that!

We know about the issue with shaders, it's some editor utilities for terrain, which are not used at runtime. However we're unable to remove them from the builds. Unity improved shader preprocessor recently, I'll take a look how we can remove these.

The CaveBlast is weird, when you're in caves and eruption occurs, do you see yellow "bubble" which grows?

Just did a test and yep, there is indeed a bubble.
< >
Showing 16-27 of 27 comments
Per page: 15 30 50

Volcanoids > Bugs > Topic Details