Saints Row 2

Saints Row 2

Saints Row 2 > General Discussions > Topic Details
Terc Aug 8, 2013 @ 4:05am
Saint Row 2 Multiplayer and Co-op gamespy login error FIX
Hi. All who have problem with coop and multiplayer, exist simple fix. Create new rule in your Firewall for SR2_pc.exe (C:\Program Files (x86)\Steam\steamapps\common\Saints Row 2\SR2_pc.exe) and your login and multi(coop) now working.

OR

1. Temporarily disable firewall
2. Run game
3. Log in with your gamespyarcade account
4. After logging switch on again the network firewall and try find coop or multiplayer
-now game want internet connection and you can allow new rule for game in firewall
5. Now your gamespy login and coop(multi) working.

And for end: If you have error "Invalid Nickname" try other "NAME". Do not use same Nick like in your GAMESPY account.
< >
Showing 1-6 of 6 comments
Slaya Aug 8, 2013 @ 1:47pm 
Open the correct port or ports in your router. Disable the Hamachi network adapter (if Hamachi is installed. You'll have to do this after every reboot.) Info in the guide that's pinned: http://steamcommunity.com/app/9480/discussions/0/846958724811426425/

Also in the additional tips section (and the next post after): http://steamcommunity.com/app/9480/discussions/0/846958724811426425/#c846959998065937810
Last edited by Slaya; Aug 8, 2013 @ 1:47pm
Eek-A-Mouse Mar 26, 2014 @ 11:10am 
and which port may that be?
Slaya Mar 26, 2014 @ 8:39pm 
4200 UDP and TCP.
Slaya Mar 26, 2014 @ 10:18pm 
However this may be it for GameSpy.... Still not working....
piotrkandziora Mar 28, 2014 @ 7:09am 
kurwa
xWangan Mar 29, 2014 @ 3:38am 
Thank You
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Saints Row 2 > General Discussions > Topic Details
Date Posted: Aug 8, 2013 @ 4:05am
Posts: 6