Supreme Commander: Forged Alliance

Supreme Commander: Forged Alliance

Cryos Feb 8, 2014 @ 8:43pm
Forged Alliance won't start (solved)
I can't get Forged Alliance to start. Every time I click PLAY or start it from any part of my computer, shortcuts or applications, my Steam avart changes to green for a minute, then goes back to blue.

This game worked a week ago, now nothing.

I don't get an error message or even a "loading game" message.

I've been through these forums and all over the internet looking for a solutionm and tried every one I came across

I've tried setting the compatibility to windows XP service pack 3

I've tried running it as an administrator

I've tried reinstalling the game.

I've tried looking for the game.pref file to delete (it wasn't there).

None of these worked. Can someone help me?
Last edited by Cryos; Aug 30, 2014 @ 10:21pm
< >
Showing 1-15 of 48 comments
Sheppy Feb 9, 2014 @ 2:07am 
nothing new, if you scroll down this forums you will see that there is a problem with the steam exe
you can use FAF (www.faforever.com) , try to uninstall google desktop if you have it etc.. all that was stated before too
Cryos Feb 10, 2014 @ 5:05pm 
My friend's copy is working and he uses steam as well. I don't have google desktop so that's out.
DRKSEEKERS Feb 10, 2014 @ 6:06pm 
I have the same issue and i have tried all the soltutions ive senn on these forums, the only clear answer is to revolt and sacrfice the first borns to the sun god.
TheElectricFred Feb 10, 2014 @ 8:50pm 
Forged Alliance Forever doesn't fix my EXE, i still cant launch the game. I have the same problem, no error messages just a false startup
KingKobra46 Feb 10, 2014 @ 9:33pm 
i removed a a bunch of adware and malware that i had somehow picked up from the internet and now my game works just as quick as it stopped working previously.
TheElectricFred Feb 10, 2014 @ 10:09pm 
What program?
Cryos Feb 11, 2014 @ 9:37pm 
I'll get rid of malware I might have then and hope that works
Cryos Feb 12, 2014 @ 3:07pm 
Yes, it was the adware and malware. Once I got rid of it the game works just fine
Araknon Feb 13, 2014 @ 8:17am 
My SC:FA wont start either, Ive now removed/deactivated a couple of adware/addons/plugins to my 2 browers IE and Firefox. We'll see if its enough, redownloading it now since i had given up and unistalled.
But I'd like to hear if anyone found out if its any specific adware/malwareaddon/plugin thats causing the conflict or problem of the game.
TheElectricFred Feb 13, 2014 @ 1:40pm 
Im still not sure what exactly it was, Im also willing to bet that the ad/malware wasnt the only problem preventing it from starting, Youll probably stillhave to redo direct X and Remove those other programs that impede it from starting (Logitech Drivers, Google Desktop Etc)

I wouldn't reccomend getting FAF until youve tried everything else, as it doesn't really solve the problem (It didnt work for me, i installed FAF and i still ended up having to remove my adware and spyware to solve my problems, And My current installation works without FAF...)
Big Al Feb 13, 2014 @ 1:48pm 
Currently having the issue of SC FA saying it is starting when I look at the friends list status. Then it clicks off of Playing Game into Online with out acually going through any of the loading on the hard drive. I've tried uninstalling SC FA and testing it, same thing happens. I've tried redownloading Steam and testing I get the same problem with the game not loading from steam, I know the game will work independant from steam it seems to have a hangup from the loadtime between steam to SC FA on the hard drive.
Sheppy Feb 13, 2014 @ 2:16pm 
Originally posted by TheElectricFred:
I wouldn't reccomend getting FAF until youve tried everything else
i would recommend to check it out even if you dont have problems :)
Glorious Feb 13, 2014 @ 9:51pm 
The game will not start for me either. Very briefly appears to load, then nothing happens. No process appears or anything. Tried every solution to no avail.
XP sp3,
2gb ram,
2.93GHz dual core,
Nvidia 650GTX.

Funniest thing is, for me the disc version actually WORKS, unlike the steam version.
LordAvaric Feb 13, 2014 @ 10:19pm 
Same problem as every one, click to start game, looks like its going to start then get a message saying its not responding any more. tryed as a admin and all that. wtf. I want a refund.
TheElectricFred Feb 13, 2014 @ 11:08pm 
Originally posted by Sheppard:
Originally posted by TheElectricFred:
I wouldn't reccomend getting FAF until youve tried everything else
i would recommend to check it out even if you dont have problems :)

Need a bit more practice before i could manage any PvP, I dont reccomend using FAF as a bugfix because it doesnt really fix the original problem (if it does fix it at all). However yes, i reccomend checking out FAF after you get your EXE working because PvP FA looks awesome

EDIT: To the people above who are having problems, have you tried Everything?

in order to get mine to work i had to update My direct X 9 Drivers (you still need Direct X 9 even if you have Direct X 10 or above, Reinstall its Distributable And see if that fixes your problem), I also Changed my permissions to run in compatability mode for XP3 AND always run it as an administrator. FInally i Had to run an adware/malware remover (I used Malwarebytes Free, Google it, worked like a charm). Im not sure which particular bugfix my problem arose from, but it didnt work until after i cleared my adware/malware. If none of that works try installing FAF.

Also on another Note, for Sheppard. Does FAF patch the steam files so i could still play the single player steam version? Or does it only enable FAF Matchmaking through its own client. Just curious for everyone else here, who probably wants to play the singleplayer before jumping right into PvP.

EDIT2: Also Validate your game cache, could help with alot of potential problems and error messages, All of these fixes may need to be applied to your system, as almost everyone has a different bug or error message, Also make sure you dont have any Logitech Hardware installed (I know, thats a really ♥♥♥♥♥♥ concept for those of us with logitech mouses or headphones, but FA wont run properly with many Logitech Drivers installed.... DOnt ask me why someone over at GPGnet mustve been smoking something while coding)
Last edited by TheElectricFred; Feb 13, 2014 @ 11:16pm
< >
Showing 1-15 of 48 comments
Per page: 15 30 50

Date Posted: Feb 8, 2014 @ 8:43pm
Posts: 48