Supreme Commander: Forged Alliance

Supreme Commander: Forged Alliance

Hoon Sep 9, 2017 @ 4:49pm
Random crashes. please help
this is the error im getting in win event viewer

Faulting application name: SupremeCommander.exe, version: 1.5.0.1, time stamp: 0x4e5c092e
Faulting module name: xactengine2_9.dll, version: 9.20.1057.0, time stamp: 0x46a06729
Exception code: 0xc0000005
Fault offset: 0x0001de58
Faulting process ID: 0x3078
Faulting application start time: 0x01d329baa147e855
Faulting application path: F:\SteamLibrary\steamapps\common\Supreme Commander Forged Alliance\bin\SupremeCommander.exe
Faulting module path: C:\WINDOWS\System32\xactengine2_9.dll
Report ID: fd82c776-4e74-4925-9cc6-f7064251f1b7
Faulting package full name:
Faulting package-relative application ID:

Specs,

crosshair vi hero , 1700x
Evga 1080ti ftw3

16gb ram 3200mhz

win 10.

Any help appreciated,

I have done the verify files and that was fine,

i have tried in compatibility mode for win 7 , made no differance

litrally mine and my group of friends favorite RTS at the moment and i cant play as i cant finish a game.
< >
Showing 1-6 of 6 comments
ZaidusRecon Sep 14, 2017 @ 10:04am 
The single most helpful guide to Supreme Command bugs I can possibly recommend, and my personal go-to for any and all technical issues throughout SupCom. It's long, but there's a 98% chance of a fix waiting for you in there somewhere.
http://steamcommunity.com/sharedfiles/filedetails/?id=175274474
Hoon Sep 14, 2017 @ 12:36pm 
Thanks for the reply, i think i may have fixed it, i moved the game to my OS SSD, which so far, appears to have worked, fingers crossed anyway and thankyou for the link i have saved it incase i run into more issues, or i start to have the same crash again.

Cheers man.
KBlomquist Jan 5, 2018 @ 1:46pm 
Hello, I have exactly the same error message: Faulting module path: C:\WINDOWS\System32\xactengine2_9.dll
Did your solution (moving the game) solve this for you permanently ? I am getting mad in trying so many things and just came to the Windows Error Log. Thanks for your feedback !
Hoon Jan 5, 2018 @ 8:13pm 
Hi KBlomquist , i cant recall having the problem since moving it to my C: drive, try it see how it goes :)
Paraniomia May 3, 2020 @ 3:07pm 
Thank you this worked, finally able to play again!!
Hoon May 3, 2020 @ 3:32pm 
Originally posted by Paraniomia:
Thank you this worked, finally able to play again!!

Glad you got your game sorted, have fun ! :)
< >
Showing 1-6 of 6 comments
Per page: 15 30 50