Revenge of the Titans

Revenge of the Titans

Statistiken ansehen:
Cavii 16. Feb. 2013 um 0:15 Uhr
[SOLVED] Linux - locks pulse sink?
I don't get sound! The game is selecting the _not_ default pulse audio sink (sound card). Can't change the game to use the correct one on the fly because things are locked... never seen this before... DONT_MOVE is new to me

$ pacmd list-sink-inputs
>>> 1 sink input(s) available.
index: 38
driver: <protocol-native.c>
flags: DONT_MOVE START_CORKED FIX_RATE
[snip]

$ pacmd move-sink-input 38 2
>>> Moved failed.

advice? -- Developers can you not lock the source to the sink or provide some configuration? -- Is thiere anything I can do with openAL configurations?
Zuletzt bearbeitet von Cavii; 17. Feb. 2013 um 7:46 Uhr
< >
Beiträge 13 von 3
cprince  [Entwickler] 16. Feb. 2013 um 1:14 Uhr 
I have no idea; normally it all "just works" unless you've twiddled something or have some sort of exotic configuration. We use OpenALSoft for sound and there might be configuration settings you can specify for OpenALSoft... I'm probably more lost than you are though!
Cavii 17. Feb. 2013 um 7:45 Uhr 
Thank you! That was more than enough for me to sort things out, thank you for the port!

# Create a config file for openalsoft that allows the source to move # but still uses the wrong default # ~/.alsoftrc [pulse] allow-moves=yes

# Finding the config file and options like a "mannly man" git clone git://repo.or.cz/openal-soft.git grep -R DONT_MOVE * vim Alc/backends/pulseaudio.c grep -R GetConfigValueBool * vim openal-soft/Alc/alcConf.c
cprince  [Entwickler] 17. Feb. 2013 um 9:21 Uhr 
Nice one, well done :)
< >
Beiträge 13 von 3
Pro Seite: 15 30 50

Geschrieben am: 16. Feb. 2013 um 0:15 Uhr
Beiträge: 3