Revenge of the Titans

Revenge of the Titans

View Stats:
Michadl Feb 17, 2017 @ 10:36pm
game won't start (Windows 10 64-bit, Java errors in err.log)
Recently I attempted to play Revenge of the Titans after a very long time (the last time I played was 2011). It has refused all attempts to start it; Steam shows "Revenge of the Titans - Running" briefly, then back to simply "Revenge of the Titans"; there is otherwise no response from the game.

I see two errors (with Java backtrace) appear in err.log:
java.lang.InternalError: DMH.invokeStatic_L_L=Lambda(a0:L,a1:L)=>{ Fri Feb 17 20:41:28 AKST 2017 t2:L=DirectMethodHandle.internalMemberName(a0:L); Fri Feb 17 20:41:28 AKST 2017 t3:L=MethodHandle.linkToStatic(a1:L,t2:L);t3:L} ... backtrace information ... Caused by: java.lang.NoClassDefFoundError: jdk/internal/org/objectweb/asm/ClassWriter ... backtrace information ...

I have attempted various steps to fix the issue, and I always get the same results.

  • upgraded Nvidia GeForce drivers to the latest (378.66)
  • reinstalled the game
  • verified file integrity
  • disabled Steam cloud syncing
  • renamed .revenge_of_the_titans_1.80 in my user directory, so that a new one was created
  • moved the installation from my E drive to C drive, and back again
  • resolved a different error by creating registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432NODE\JavaSoft\Prefs (err.log was showing an error that it could not create Software\JavaSoft\Prefs)
  • set compatibility mode on RevengeOfTheTitans.exe to Windows 8
  • disabled display scaling on high DPI settings on RevengeOfTheTitans.exe

Unfortunately I am now at a loss. I would appreciate any assistance, and I'm more than happy to repeat any of the steps in whatever order is recommended.
Last edited by Michadl; Feb 17, 2017 @ 10:41pm
< >
Showing 1-8 of 8 comments
cprince  [developer] Feb 18, 2017 @ 2:52am 
Hi there, can I have the full log output?

It looks suspiciously like you've got something installed in your system path that is interfering.
Michadl Feb 18, 2017 @ 12:42pm 
The full err.log was a little large to paste directly here, so I have pasted it to; I hope that's ok. The link is here:

The output is somewhat short on details. I was looking for some way of getting more information; for example, Java's CLASSPATH, or perhaps what jars are being loaded. I have so far found no way of doing that.
cprince  [developer] Feb 18, 2017 @ 4:25pm 
That's the most peculiar stacktrace I've ever seen... basically, you're not running "Revenge of the Titans" as deployed, but some sort of curious hybrid with some other code.

There is likely to be something on your system path (that shouldn't be) - Minecraft hacks and the like - which is interfering with the launch. What do you get if you do java -version from a command prompt?
Michadl Feb 18, 2017 @ 6:16pm 
I don't have java in my path; "java -version" returns "'java' is not recognized as an internal or external command". I don't have a Java installed, based on Control Panel -> Programs and Features (I searched for *java*, *sun*, and *oracle*, with no results).

A search across the filesystem results in no java.exe; I only see directories named java as part of software that's not installed (, and Sun). I removed those directories, as it was part of a backup from a system a long time back, but there's no change in behaviour from Revenge of the Titans.

I did have Minecraft installed and tweaked on a previous system, and I did migrate the data from that system to this one. I have not installed or played Minecraft on this system, and as far as I can recall I haven't installed or played any other Java-based games.
cprince  [developer] Feb 19, 2017 @ 10:04am 
How about strange jar files, and environment variables? (Let's see your environment variables - just type 'set' at a command prompt and list that lot out)
Michadl Feb 19, 2017 @ 3:28pm 
So, I appear to have resolved the issue.

I ran Steam -> Uninstall ... (again) on Revenge of the Titans, then went into the library directory (in this case E:\Games\SteamLibrary\SteamApps\common) and manually renamed "Revenge of the Titans" to "Revenge of the Titans -- old", in order to get a completely fresh install. I then re-ran Steam -> Install on the game, and the game now starts up.

The files left-over after the Steam -> Uninstall.. are all dated 2014-01-10, and include meta-index files, a few .dlls, zoneinfo files (lib/zi), and some font-related files.

The meta-index files are of particular interest; based on the content of the files (they list Java class paths), and some brief searching on Google, it appears they're used by Java to reduce load times on JARs. If there was a bad class (outdated, obsolete, etc.) listed in one of those files it's possible that was causing the conflict.

Unfortunately I have no idea what created them. It is entirely possible the system that had Minecraft installed, with Java tweaking to get it working, caused the issue, and I've simply been transferring this data along until it finally broke something else.

I can provide more information (file listing and/or checksums of the leftover files, content of the meta-index files, or possibly something else) if it would be of help.

Thank you very much for your assistance, especially over the weekend. I greatly appreciate it.
cprince  [developer] Feb 19, 2017 @ 3:32pm 
No worries... interesting issue to find though. Good sleuthing!
Lnchb0xMarathon Mar 20, 2017 @ 5:41pm 
same thing is happening to me. screen stays black. i actually left for an event after i tried starting it and a few hours later when i got back it was still a black screen. if i move my mouse around the screen, i can hear the options being highliughted but it just wont come off the black screen. :/
< >
Showing 1-8 of 8 comments
Per page: 15 30 50