SpaceChem

SpaceChem

View Stats:
SpaceChem > General Discussions > Topic Details
Epsilon Jul 1, 2017 @ 2:14pm
Help with changing window size?
I'm attempting to use the config.ini file to change the window size for SpaceChem. I can bump it up to 2840x1600 (I've got a 4k monitor,) but the images in the game don't scale up to fit the window.

How do I get it to correctly stretch to fit the window size I specify?
< >
Showing 1-9 of 9 comments
Epsilon Jul 5, 2017 @ 5:37pm 
Sad that I'll have to return this game. I can't handle the eyestrain. :(
Leylite Jul 6, 2017 @ 10:17am 
Sorry nobody's replied sooner. You might need to use an external program to force the game into full-screen, keeping its aspect ratio - it might look stretched, but at least it would be large enough to fill the screen. There's probably different programs to do the job depending on which operating system you're running.
roguetracer Aug 25, 2017 @ 12:36pm 
I don't think there's a great deal that can be done. There are an absolute shed load of older games that don't have UI scaling. So now we are in the 4K era and after that the 8K era, these games will be unplayable because you won't simply be able to read the user interface. (You'll have to stick to 1080p in most cases.)
Last edited by roguetracer; Aug 25, 2017 @ 12:37pm
monnef Dec 16, 2017 @ 7:00am 
Then it should be stated in game requirements like "maximum resolution: 1280×720". Even in 1080 the game window doesn't occupy whole screen in any direction. I am trying to play it on Kubuntu LTS (which is according to GOG supported) and yet it can't run properly in ANY combination of checkboxes in options (window too small, when forced resized the game doesn't render on the whole window; half game on both monitors; game on one monitor, but mouse locked in such way that right 1/3 of the game cannot be interacted with).
eldorel Feb 13 @ 7:50pm 
I'm having the same issue with my system. I have a 4k display, and even with DPI scaling off and manually setting the resolution in the config, I only have a tiny copy of the game in the upper leftcorner of the screen.

Even if I set the resolution to 1080x720 and enable full screen, it still doesn't allow for the display's scaling to kick in. (instead detecting the desktop resolution and ignoring the config settings.)

I've loved every zachitronic's game i've been able to play, but I like to come back to replay games I enjoyed after I've had enough time to forget the solutions.

If these games aren't going to be supported in the future, then I'm not going to keep setting myself up for hours of frustration.
I have a perfectly normal screen, and it still won't work for me. I can't see anything at the top of the screen. That, combined with the dead YouTube video link that's supposed to be the introduction to the game, hasn't left a positive impression on me so far. :/
Similar challenge here, suggestions where to start would be great.... Works on 1080p monitor, displays offscreen on 1080p TV.
Kzon Apr 21 @ 7:38am 
Game is great, but it's config for normal screens is♥♥♥♥♥♥ Best option is to edit the config file which is found by default in C:\Users\<YourUserName>\Appdata\Local\Zachtronics Industries\ . Tinkering with these numbers here should fix most problems. Try for lower resolutions, not full screen as well. Good luck.
Originally posted by Kzon:
Game is great, but it's config for normal screens is♥♥♥♥♥♥ Best option is to edit the config file which is found by default in C:\Users\<YourUserName>\Appdata\Local\Zachtronics Industries\ . Tinkering with these numbers here should fix most problems. Try for lower resolutions, not full screen as well. Good luck.

Thanks, think it's sorted out now. Took some wonky (and needing to be fixed from time to time) editing of game config files, startup launch, and will have to switch between config files depending on which monitor I'm using (though both are 1920x1080)... Cheers!
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

SpaceChem > General Discussions > Topic Details