DOOM 3: Resurrection of Evil

DOOM 3: Resurrection of Evil

Strangerhand May 15, 2014 @ 7:58pm
New Video Glitches--Please Fix!

There's an even worse one when one uses the Artifact that makes the game unplayable, though I didn't get any screenshots of that one.

I'm using an nVidia GeForce GTX 750 Ti w/ 2GB VRAM. And yes, I'm using the latest drivers. :P

Please help! Please fix!
< >
Showing 1-8 of 8 comments
Tricky Lou Sep 8, 2014 @ 8:23am 
Same problem.
Tenshihan_Quinn Feb 20, 2015 @ 12:46pm 
I can't believe how broken this game is - STILL NO FIX AFTER ALL THIS TIME?

The Grabbers visuals are UPSIDE DOWN, the Artifacts visuals are UPSIDE DOWN, the stuttering/micro-lag is CONSTANT.

My Specs: (All drivers are up to date)

OS: Windows-7 Home Premium (64-bit)

CPU: AMD Phenom II x4 955 B.E. @ 3.2 GHz

GPU: Radeon HD 7850 2GB


RAM: G.SKILL Sniper 8GB (4GBx2) DDR3/1600MHz Dual Channel.

PSU: 600 Watts - Sigma SP-600AB ESP 80 Plus.

HDD: 500GB SATA-II 3.0Gb/s 16MB Cache 7200RPM.
Strangerhand Feb 21, 2015 @ 12:43am 
Actually the original problem went away on my end. Everything seems to work fine now here hehehehe

But if I notice something, I'll report back here hehehehe

Hey, you report here too! hehehehe
Last edited by Strangerhand; Jul 29, 2015 @ 5:04pm
greenhillmaniac Apr 19, 2015 @ 8:44am 
The fix is to disable Anti Aliasing. It worked with me :)
Råtastokk Jun 22, 2015 @ 11:23am 
hmm.. didnt work for me, not sure if there's something you can do in doomconfig.cfg either
Råtastokk Jun 22, 2015 @ 11:25am 
my problem is with both the "gravity-ripoff" weapion and the artifact, my screen turns upside-down, lol :P
Heldengeist Jul 29, 2015 @ 8:37am 
I just tried to play this game and had the same problem with the grabber and the artifact. Luckily I have an old CD version of the game so I thought I check if it has the same problem. That version works perfectly. Maybe a f'd up update is the source of this problem.

btw I'm using W8.1 and turned off AA fixes the steam version too for me. With the boxed version, I can use AA without the bug.
seswrt Mar 27, 2016 @ 3:18pm 
Well i found that turning off anti aliasing fix's this problem :steamhappy:
< >
Showing 1-8 of 8 comments
Per page: 15 30 50