DOOM 3 > General Discussions > Topic Details
lafragle Aug 3, 2013 @ 1:15pm
Unplayable glitch doom 3 reg with silkmod
i just tried to setup some mods and did it properly, i load up a new game and i get what is shown in this screenshot, any help?
< >
Showing 1-3 of 3 comments
KobraKira Jan 10, 2014 @ 9:42am 
Do you run on Nvidia or AMD?
Doomsdayman Jan 13, 2014 @ 2:41pm 
I have the same glitch. I got AMD, I already turned off CCC.
Lymanity Feb 3, 2014 @ 8:30am 
This happened to me too. I actually got a response the other day to a pic I posted that gave some advice that I haven't tried yet. Though, please let us know if it works for you.
"I realize this is old, but I had so many problems with Catalyst Control Center running Sikkmod it's unreal. If you're interested in trying it again: Get RadeonPro. Add DOOM 3 executable. Boost settings as needed, though there may be slowdown with overriding Antialiasing settings. The biggest thing to having it run correctly is to disable Catalyst AI through RP. Ugh, next graphics card will definitely be nvidia."
Last edited by Lymanity; Feb 3, 2014 @ 8:31am
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

DOOM 3 > General Discussions > Topic Details
Date Posted: Aug 3, 2013 @ 1:15pm
Posts: 3