Last Epoch

Last Epoch

Last Epoch's Website filled with Phishing Malware?
Both my phone and my laptop are flagging the Last Epoch forum website as being malware. According to my anti-virus software, there's some sort of phishing in the website?

I've received this problem on 7/21/21. Would someone look into the website and see what's going on with it?
< >
Showing 1-8 of 8 comments
yeah, same here...
no more info on this??? What kind of malware is it?
like the one that can take your account? or just something else like popup malware?
yimimoto Jul 21 @ 3:42pm 
It most likely is just a problem retrieving the certificate for the site, because I have no problems in chrome on my pc. It will automatically get flagged if it can't get it.
Logoth Jul 21 @ 9:23pm 
What specifically is flagging it?
xanaki Jul 21 @ 10:43pm 
Originally posted by thepowerofmediocrity:
Both my phone and my laptop are flagging the Last Epoch forum website as being malware. According to my anti-virus software, there's some sort of phishing in the website?

I've received this problem on 7/21/21. Would someone look into the website and see what's going on with it?
Same here, my virus scanner would not let me enter their official forums due to phishing content.

Don't know what is going on here.
My antivirus just say it is "URL:Phishing", and I use Avast FYI
As of 7/23, the issue appears to be solved. I can now access the forums again without having the website flagged as phishing.
xanaki Jul 23 @ 5:52am 
Great! I uninstalled Avast and replaced it Bitdefender which is much less intrusive than Avast or AVG. But good to hear the site is ok again.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Jul 21 @ 11:25am
Posts: 8