Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
Nowaker Jun 11, 2014 @ 9:02am
Linux: blank/black screen after start - windowed mode maybe?
I've been trying to run Civilization 5 on my Arch Linux x64. The game starts. Although the music is playing, the screen is blank.

This is probably a problem with full screen mode. Is there a way to run a game in a window? Some option for a config file? Where is the game's config file? Can anyone set the windowed mode and then provide me with a full config file?

Arch Linux x64, Radeon 7870 @ radeonsi Gallium3D driver, 4 monitors.
Last edited by Nowaker; Jun 11, 2014 @ 9:38am
< >
Showing 1-12 of 12 comments
Ariatiki Jun 12, 2014 @ 5:55am 
I'v egot a similar situation, although I can see a small strip of the video/loading screen, it is centered on my screeen (two monitor set up), and the rest of the screen is black.
Nowaker Jun 12, 2014 @ 10:45am 
~/.local/share/Aspyr/com.aspyr.civ5xp.json

{
"ASLAllowGLSoftwareFallback" : false,
"ASLCacheGLSLUniforms" : false,
"ASLDebugDasmInGLSL" : false,
"ASLDeferFBOClear" : false,
"ASLForcePSOff" : false,
"ASLForceVSOff" : false,
"ASLForceVSync" : false,
"ASLGLSLAvoidFacing" : false,
"ASLGLSLAvoidFogFragCoord" : false,
"ASLGLSLBindableUniforms" : false,
"ASLGLSLFacingFix" : false,
"ASLGLSLPreventDBZ" : false,
"ASLGLSLPreventRSqrtDBZ" : false,
"ASLGLSLZeroLengthVecFix" : false,
"ASLGenerateGLSL" : true,
"ASLIntelDeleteRBWorkaroundEnabled" : false,
"ASLPSMajor" : 3,
"ASLPSMinor" : 0,
"ASLPackedDepthStencilClearFix" : false,
"ASLRestrictNPOT" : false,
"ASLSupportClipPlanes" : true,
"ASLSupportMRT" : true,
"ASLUseARBFragmentProgShadow" : false,
"ASLUseARBFragmentPrograms" : true,
"ASLUseARBVertexPrograms" : true,
"ASLUseAnisotropic" : true,
"ASLUseBindableUniform" : true,
"ASLUseConditionalRender" : true,
"ASLUseCoreProfile" : true,
"ASLUseFBO" : true,
"ASLUseFloatTextures" : true,
"ASLUseFlushVBO" : true,
"ASLUseFramebufferBlit" : true,
"ASLUseFramebufferMultisample" : true,
"ASLUseGLSL" : true,
"ASLUseGPUProgParams" : true,
"ASLUseGPUShader4" : true,
"ASLUseGeometryShader4" : true,
"ASLUseHardwareShadowMapping" : true,
"ASLUseLODBias" : true,
"ASLUseNPOTTextures" : true,
"ASLUseNVFragmentProgram2" : true,
"ASLUseNVFragmentProgramOption" : true,
"ASLUseNVVertexProgram2Opt" : true,
"ASLUseNVVertexProgram3" : true,
"ASLUsePBO" : false,
"ASLUseTextureArray" : true,
"ASLUseTextureInteger" : true,
"ASLUseTransformFeedback" : true,
"ASLUseVertexArrayBGRA" : true,
"ASLUsesRGB" : true,
"ASLVSMajor" : 3,
"ASLVSMinor" : 0,
"DisplayFullScreen" : false
}
Gringo Jun 12, 2014 @ 9:03pm 
I'm getting this same issue on my Arch x64 laptop. i7 with intel hd 4400
atarian88 Jun 12, 2014 @ 11:09pm 
I had this issue on my Gentoo laptop with a HD4000 "card". Simply change FSResID to 6 in ~/.local/share/Aspyr/Sid Meier's Civilization 5/GraphicsSettingsDX9.ini. Worked for a 1080p display.
Gringo Jun 13, 2014 @ 7:09am 
That worked! :) Thanks.
Gringo Jun 13, 2014 @ 7:11am 
Well now it crashes/freezes soon after I get to the menu but one step closer.
veikk0 Jun 13, 2014 @ 9:53am 
You could try turning off the Steam Overlay (on Steam: Civ V -> Properties -> General -> Enable the Steam Overlay while in-game). I've had some problems with the game on Radeon HD 4850 & open drivers, and turning the overlay off got rid of some of them.

If it doesn't help then it's at least one variable out of the equation.
Gringo Jun 13, 2014 @ 6:54pm 
Turning off overlay is the first thing I do for any game really so it is alreay done. There are a few topics for crashes so will go through them now.
Aleksejs Ivanovs Jun 24, 2014 @ 2:19am 
Have the same problem here. Steam overlay turned off. Can see intro video but when it should show menu, it shows blank screen. Any help?

Asus x550c with nVidia GeForce 720m.
Last edited by Aleksejs Ivanovs; Jun 24, 2014 @ 2:20am
veridiam Jul 9, 2014 @ 10:48pm 
Originally posted by atarian88:
I had this issue on my Gentoo laptop with a HD4000 "card". Simply change FSResID to 6 in ~/.local/share/Aspyr/Sid Meier's Civilization 5/GraphicsSettingsDX9.ini. Worked for a 1080p display.
Thanks man. Now I can conquer the world with Gentoo
Stormcrow Jul 25, 2014 @ 5:56am 
I have the same problem. Turning off the steam overlay allowed me to see the credits & intro, but i get a white screen (can hear the music). Tried changing FSResID from 0-6, nothing works. Any help on this would be appreciated!

My system: Ubuntu 12.04, Dell Latitude E7440, Intel Graphics 4400
ekimekim Aug 13, 2015 @ 10:16pm 
Originally posted by Nowaker:
~/.local/share/Aspyr/com.aspyr.civ5xp.json

{
"ASLAllowGLSoftwareFallback" : false,
"ASLCacheGLSLUniforms" : false,
"ASLDebugDasmInGLSL" : false,
"ASLDeferFBOClear" : false,
"ASLForcePSOff" : false,
"ASLForceVSOff" : false,
"ASLForceVSync" : false,
"ASLGLSLAvoidFacing" : false,
"ASLGLSLAvoidFogFragCoord" : false,
"ASLGLSLBindableUniforms" : false,
"ASLGLSLFacingFix" : false,
"ASLGLSLPreventDBZ" : false,
"ASLGLSLPreventRSqrtDBZ" : false,
"ASLGLSLZeroLengthVecFix" : false,
"ASLGenerateGLSL" : true,
"ASLIntelDeleteRBWorkaroundEnabled" : false,
"ASLPSMajor" : 3,
"ASLPSMinor" : 0,
"ASLPackedDepthStencilClearFix" : false,
"ASLRestrictNPOT" : false,
"ASLSupportClipPlanes" : true,
"ASLSupportMRT" : true,
"ASLUseARBFragmentProgShadow" : false,
"ASLUseARBFragmentPrograms" : true,
"ASLUseARBVertexPrograms" : true,
"ASLUseAnisotropic" : true,
"ASLUseBindableUniform" : true,
"ASLUseConditionalRender" : true,
"ASLUseCoreProfile" : true,
"ASLUseFBO" : true,
"ASLUseFloatTextures" : true,
"ASLUseFlushVBO" : true,
"ASLUseFramebufferBlit" : true,
"ASLUseFramebufferMultisample" : true,
"ASLUseGLSL" : true,
"ASLUseGPUProgParams" : true,
"ASLUseGPUShader4" : true,
"ASLUseGeometryShader4" : true,
"ASLUseHardwareShadowMapping" : true,
"ASLUseLODBias" : true,
"ASLUseNPOTTextures" : true,
"ASLUseNVFragmentProgram2" : true,
"ASLUseNVFragmentProgramOption" : true,
"ASLUseNVVertexProgram2Opt" : true,
"ASLUseNVVertexProgram3" : true,
"ASLUsePBO" : false,
"ASLUseTextureArray" : true,
"ASLUseTextureInteger" : true,
"ASLUseTransformFeedback" : true,
"ASLUseVertexArrayBGRA" : true,
"ASLUsesRGB" : true,
"ASLVSMajor" : 3,
"ASLVSMinor" : 0,
"DisplayFullScreen" : false
}

This file was exactly what I needed to force the game into windowed mode, thank you!
(fullscreen mode breaks badly in XMonad, arch linux x64)

Once the game was started I could go into settings and adjust resolution.
< >
Showing 1-12 of 12 comments
Per page: 15 30 50

Date Posted: Jun 11, 2014 @ 9:02am
Posts: 12