Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
Theory_77 Feb 17, 2013 @ 2:15pm
Civ V not working after steam update
Is anyone else having this problem?
< >
Showing 1-15 of 93 comments
Doctor Love Feb 17, 2013 @ 2:24pm 
yes. it will not start a game. it always crashes
Theory_77 Feb 17, 2013 @ 2:32pm 
Windows 7 64bit
16gb of ram
ATI Radeon HD 5700 (Latest drivers installed)

Yup, seems to have just popped today or yesterday. No way to play.
I have windows 8 64bit, what are your versions?
Theory_77 Feb 17, 2013 @ 2:36pm 
Theory_77 Feb 17, 2013 @ 3:08pm 
Did the old uninstall reinstall trick it worked. But it'll only let me play using Direct X 9
I tried uninstalling and reinstalling and it didn't work for me.
Simon Feb 17, 2013 @ 4:14pm 
When I try to launch it, it shows a black screen and an error message appears. I have read over a dozen forum post and have tried almost everything that was suggested without any success.This is the title of the latest crash report:

Amber Feb 17, 2013 @ 7:44pm 
I was having a lot of issues as well, and eventually just resigned to the idea that it would not be working for some time. However, I recalled that recently, both my laptop and desktop yelled at me that a beta was over, shifting me back to the normal client. So I checked to see if I had any betas I could opt into. There was one; Steam Client Beta. Installed it and restarted, and now I am able to play. (Or, at least, start the game without it crashing)

tl;dr: Try running with the Steam beta client.
Last edited by Amber; Feb 17, 2013 @ 8:04pm
reconinf Feb 17, 2013 @ 8:02pm 
i have had problems with it crashing..
Havck | 혼혈 | Feb 17, 2013 @ 8:14pm 
i don't know, its working seemingly fine for me, although it did crash at one point, and that is the first time it has happened to me.
The Wanderer Feb 17, 2013 @ 8:37pm 
Exit Steam -> Launch Civ 5 manually.
SixPackAbs Feb 18, 2013 @ 12:41am 
yup it crashes after the intro logos and junk
Brodie#2 Feb 18, 2013 @ 2:03am 
It wont do the updates for me, I've tried reloading Steam and uninstalling and reinstalling the games... nothing seems to work.
Brodie#2 Feb 18, 2013 @ 2:05am 
"content servers unreachable" does this mean the servers are under maintenance? if so, does anyone know for how long?
< >
Showing 1-15 of 93 comments
Per page: 15 30 50

Date Posted: Feb 17, 2013 @ 2:15pm
Posts: 93