Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
PrinceofPersia Jun 3, 2014 @ 11:21am
Civ 5 mods not showing up :/
So I downloaded some mods, and they did not show up. So I unsubscribed and deleted the files and tried subscribing again, but now it just says there is no mods :( Does anyone know how to make them download?
< >
Showing 1-15 of 26 comments
Willgriggs12 Jun 3, 2014 @ 12:47pm 
I had the same issue before. Two ways ive found of fixing this, either, from the homepage of Civ, click on mods, and if youve subscribed, after about 5/10 minutes they should begin to download, not too sure why it takes so long, but leave it on the screen and they should be there, or transferring.
Another method which ive found more suceesful, but takes longer, is from your steam homepage, where you have Library, Store etc, right click on Civ 5, and select properties. Then i believe it is under Local Files, select Verify Game Cache. Select this, and it may take a few minutes, but give you a percentage so you know how long it will take to do. After this launch the game, and all mods youve downloaded should have transferred to your mods page, where you can select which ones you use. I tend to do the second method first, then leave it for a few minutes, and this has worked for me evrytime :) hope this helps
Imperator Trump Jun 3, 2014 @ 1:56pm 
does it say it is compatible with the current version your are playing. E.G do you have all of the DLC's installed? Furthermore does it say that the mod is compatible with other mods? if you are not sure then go back to the page you got the mods and read the desc. to see if it says something that means it may be incompatible with other mods (I had a expanded tech tree mod once but with other mods like plant a forest i could not scroll down the tech tree). I hope you can solve this problem. i know how annoying it can be to have mods problems, good look. :)
PrinceofPersia Jun 3, 2014 @ 2:14pm 
willgriggs12- I did the second choice and still shows a blank screen and says "No mods installed" :(
Burnedsausage- I checked and am pretty sure they are all compatible. I had it working for a long time, then I found I couldn't download new mods, so I deleted everything and tried again. Now none of them will download :P.
Willgriggs12 Jun 4, 2014 @ 3:51am 
No idea then, sorry, worked for me :/
Ryika Jun 4, 2014 @ 6:26am 
Unsubscribe from all mods, then delete the Cache-Folder, start Civ5 again and subscribe to the mods from within the ingame-browser. The game should start downloading them then. However, the game doesn't show mods until they're done downloading, so if you're downloading big mods they will take a while to show up. Just give the game some time (1-2 Minutes if the mods are >1mb), don't un- and re-sub all the time, that might screw up your download.
lewispreston91 Jun 4, 2014 @ 8:50am 
I'm having the same issue. When I subscribe to a mod nothing downloads and nothing appears in the mod section when I launch the game. I've tried reinstalling the game, deleting the cache and the mod folder (which is empty?) and I also verified my game cache but it just reset the game script to hide the mod button in game. (I have a mac)
BenZoolander Jan 7, 2015 @ 12:41am 
has anyone solved this yet? Im having the samd issue
My mods suddenly disappeared. It's pretty annoying.
kurikinton Apr 13, 2015 @ 8:33pm 
Edit: scratch that, use ACEBUZZY's solution later in the thread, according to several commentors.

Just leaving this here for legacy:
--------------------------------------------------------------------
To anyone new finding this thread or who hasn't solved the issue:

You can manually copy the downloaded mods from the cache to the mods folder.

1. Close the game if running and open your Steam install directory
In my case this is C:\Program Files (x86)\Steam\

2. Look for the "userdata" folder, open it, and there should be a folder for which the name is a long number (probably your steam user id number or something). Open that. I suppose there could be more than one if you share your PC among multiple steam users, but I have no idea to check that. It is one folder for me. This folder will contain all cached/downloaded user content for all installed games.

3. Look for the "ugc" folder, and open it. There should be a "referenced" folder. Open that, and there will be a number of folders, with long numbers as names, equal to the number of mods you have subscribed to on Steam.

4. Open each of those folders in turn and copy the *.civ5mod files there to your mods folder one at a time, which is for me: Documents\My Games\Sid Meier's Civilization 5\MODS

5. Launch the game and click on Mods. At first it will show none installed, but after a second or so it will start showing progress bars filling and emptying for each mod you copied. After that (should take only a few seconds or a minute or so) you will have your list of mods back.

Why this happened or became necessary?

In my case, I installed and played the game on Linux for a while. On Linux, the above procedure is the *only* way to install mods (the folder locations are slightly different of course). Then, I switched to my Windows install and reinstalled the game there. My guess is that because I had already downloaded and used mods on Linux, the Windows installation got confused somehow. For instance, there might be some kind of config file, or server side setting, which prevents the auto-copying of downloaded mods from cache to mods folder. Or it could be something as simple as Steam thinking everything is already downloaded and installed and deciding to take no further action (not updating anything).
Last edited by kurikinton; May 29 @ 12:25am
analreker Apr 17, 2015 @ 12:11am 
Thx!
✪khalDROGO Apr 17, 2015 @ 2:21pm 
GG
ImperialFish Apr 18, 2015 @ 8:07pm 
Originally posted by kurikinton:
Some stuff.

Thanks for the help on that. It didn't wind up working for me until I extracted the mod files like you would a zip or a rar file. So if anyone is still having problems, use 7zip or Winrar to extract the .civ5mod files when they are in the ../MODS folder.
kurikinton Apr 18, 2015 @ 8:20pm 
Originally posted by ImperialFish:
7zip or Winrar to extract the .civ5mod files when they are in the ../MODS folder.

Ah, good point. That's what I do on Linux but for some reason the game did the extracting for me on Win7.
Warplock Engineer Apr 19, 2015 @ 2:48pm 
What if I cannot find the "mods" folder? Should I create one or is it named something wierd?
Ryika Apr 19, 2015 @ 5:28pm 
Mod folder will only be there if you downloaded mods before. Just create it.
< >
Showing 1-15 of 26 comments
Per page: 15 30 50

Date Posted: Jun 3, 2014 @ 11:21am
Posts: 26