Sid Meier's Civilization V

Sid Meier's Civilization V

View Stats:
Montoya Jan 7, 2018 @ 12:46am
New crash under Linux lack of steam_appid and segfault
I am reporting et another bug...

A couple of days ago I became unable to start the game, as it crashes as soon as I try to play it: If I try to start it from the terminal to see what is wrong, I can see that it lacks the steam_appid.txt file (yes, I tried to refresh cache, check integrity and even uninstall and install it again). I managed to find which one it is and created the file manually, but even if it seems to not complain about it anymore, I still get a segfault at start.

I am running it under the last stable Kernel at the moment (4.14.12), Mesa 17.3.1 and latest driver vesions. It happens under Nvidia (gtx 1060) and Intel (HD5500) grapics GPU. Just last month I was able to run the game no probs.
< >
Showing 1-9 of 9 comments
LordJason Jul 5, 2018 @ 2:22am 
Also getting a segfault on arch, up to date at the time I'm writing this.
dmesg shows messages like, Civ5XP[2234]: segfault at 0 ip 00000000ee587ecb sp 00000000f2e37734 error 6
Crazy0750 Jul 7, 2018 @ 2:20pm 

I had a similar issue on Manjaro, game worked fine but started to crash on startup after a system update. Apparently this was caused by pulse audio upgrading to version 12.0. Adding

LD_PRELOAD=/usr/lib32/libopenal.so.1 %command%

in the launch options fixed the problem for me.
LordJason Jul 8, 2018 @ 3:12am 
I tried your suggestion. Preloading libopenal.so.1 does not change anything for me. It still segfaults nearly the instant the game launches.
Hicks Jul 9, 2018 @ 12:33pm 
Doesn't launch for me either on Debian 9.

LD_PRELOAD does not resolve it for me.
Stupid Beard Jul 9, 2018 @ 1:07pm 
I'm also getting this problem, but only on the beta client. It seems to be an issue with all aspyr ports that I've tried. This is very annoying.
LordJason Jul 9, 2018 @ 4:50pm 
I just reverted to the default, instead of beta client and CivV still crashes.
Hicks Jul 12, 2018 @ 1:44pm 
Game is working again after the latest steam client update.
Stupid Beard Jul 12, 2018 @ 1:48pm 
Working for me now, too.
SAFR Jul 14, 2018 @ 9:13pm 
Uninstalled steam and reinstalled and it fixed, not entirely sure what the problem was but, while inconvenient at the time, is currently resolved.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Jan 7, 2018 @ 12:46am
Posts: 9