Freedom Force
Freedom Force > Общие обсуждения > Подробности темы
"Fist Glitch" fixes not working, nothing has...
This is a real issue, as this game was one of the ones I was truly looking forward to playing again.

I have the "fist" glitch, which is essentially a bug that causes the cursor to remain in a "combat" state. Also, and I'm not sure if this is part of it, but movement is completely broken. Whenever a location is clicked on the map, Minuteman runs off the screen and never looks back. I'm talking about into the black abyss of "invisible walls".

Searched for fixes, found absolutely nothing that helps. Tried pretty much everything suggested, including "compatibility settings", clicking specific places to start a new game, etc, etc.

Any help/confirmed fixes would be greatly appreciated. I'm running Win 8.1 with a GeForce 760.
< >
Сообщения 113 из 13
I have the same problem, I not find any solution, no one know what's the problem... u.u
I unloaded the game for a week and tryed again and it worked hope it keeps working.
I get the bug intermittently. Sometimes I start up the game and it's okay, sometimes it isn't. A reboot can sometimes help, but it seems random. There's obviously something going on...
Heres the fix, get yourself cracked 1.3 fforce.exe, and run it directly not through steam
First, my work-around, seems to have a 25% chance to work. Not great, but better than 0% when I don't do this.

Note: I've tried all the previous suggestions and then some (see below), and none of them are enabled in my config. This is "right out the box".

// WORK AROUND /////////////////////////////////
1. The moment you launch the game, mash the ESC key until the title screen appears.
2. Start or Load your game.
3. If you see the fist, quit, and try again.

That's it. Like I said, without doing this, I am never able to play without the fist. I've tried 20 - 30 times in a row without hitting ESC to no avail. After a few attempts while hitting ESC I can play.

First my setup:
AMD Athlon II X3 435 2.90 GHz
4.00 GB RAM
Windows 7 64-bit
NVIDIA GeForce GTX 570

I've spent an afternoon to come up with the awful "solution" above. Here's what I've tried:

1. I downloaded a cracked version as there are definite differences between the Steam version and the "boxed" version with the 1.3 patch. I still experienced the "fist bug" just the same.

2. Every combination of previous version of Windows with every combination of the checkboxes under Properties->Compatibility tab for fforce.exe .
a. Yes, literally every one, some just won't work at all as expected, none solved the problem without the ESC work around.

3. Enabling and disabling various options in the NVIDIA Control Panel.

4. Turning off and on various mouse settings.

5. Changing resolutions in and out of game with varying degrees of success, but ultimately I determined this option wasn't reliable enough in my experience.

After all of this, I've come to the conclusion that the "fist bug" is initialized as soon as the game starts. As I type this I realize it may still happen upon the resolution change and the ESC work around just might work when chaning resolutions. I'll test this some more.

Finally, I'm also curious if the bug is initialized when the logos appear before the main menu. I know some cracked/hacked games have had patches that removed these sorts of things in order to speed up the initial load time. I plan to do a bit more research into what it takes to do this and see if FF might benefit from it.

Hopefully this works for some of you who haven't been able to play at all. Perhaps this could even lead to a better understanding of the problem and a more permanent solution.
Автор сообщения: YardGnomeNinja
Finally, I'm also curious if the bug is initialized when the logos appear before the main menu. I know some cracked/hacked games have had patches that removed these sorts of things in order to speed up the initial load time. I plan to do a bit more research into what it takes to do this and see if FF might benefit from it.

It's not 100%, but I have far more success at not getting the glitch when I don't touch anything until it comes to the main menu.
i have tried everything, it was always a gamble, but since I use cracked exe and start the game directly from game folder (starting the game with steam or steam shortcut will bug the game), I had not seen this bug

using same res as on desktop, 1920x1200

size of cracked fforce.exe is 3 375 104 bytes

ps: i will try it on more computers

update: works fine on i5 with amd gpu and core2 with nvidia gpu, both win7 64bit

meaning 3 computers, 100% success rate, as for my testing

gnomeninja did you acctualy start the game with the cracked exe? dont use any kind of compatibility settings

Последний раз отредактировано Batchman; 16 ноя. 2014 в 5:21
Batchman, yes I used the cracked EXE without compatibility settings. The version I found on TPB was cracked by JAB with a cracked fforce.exe of 3,375,104 as well.

I just tried it once more to verify. When it loaded the first time it was fine. I exited the program and reentered and experienced the fist bug again.

In my experience "intermittent" is probably the best description of the bug. As starsrift's experience suggests, the ESC workaround I suggested may mean nothing, but in the very least it speeds you past the intro videos.

Based on the wildly differing experiences with this bug, I'm starting to wonder if it isn't related more to another application or process interferring with FF's initialization.

I was hopeful the cracked version would resolve the problems for me. I would recommend others give it a try. And I think if you honestly own a copy of the software, you shouldn't feel weird downloading a copy of it however you come by it.
Update: This is infuriating. I rebooted my machine and now can't get the Steam version to start at all again. However I was able to try a few times and would intermittently get the cracked version to work. I am not yet defeated, foul beast! I will overcome!
Some more interesting info:

Once I was able to get the cracked version to start without the bug, then the Steam version began intermittently succeeding as well.

I also noticed that if you right-click to display the action menu, then click Move, while your character is running off wherever the hell they decide to go, if you left click again, they'll run to the point you specified with your right-click. You can use this to get around on the ground easily by right-clicking, then double-click Move. Things get wacky though when flying and jumping enter the mix. You can make it work by experimenting, and I think every second left-click must be on the ground, but it's really a pain.
I posted in a different thread about this, but for me this is all still highly unreliable, and the bug keeps cropping up. What I did was virtualize Windows XP using Virtualbox which supports direct3d and acceleration. You can also still install Steam in Windows XP. Once all of this was set up and running, the game runs great and reliable. If you plan on doing any other retro gaming in the future this may be a better approach since you won't have to worry about compatibility.
i was albe to finish the game without problems, guess I am lucky, not to mention its pretty short for an old school game :/
Последний раз отредактировано Batchman; 18 ноя. 2014 в 9:09
I had this problem on my computer (running old Vista SP2). I solved it by exiting Steam in the notification area of the taskbar before starting the game.

Boom, it worked. Don't know why.
< >
Сообщения 113 из 13
Показывать на странице: 15 30 50

Freedom Force > Общие обсуждения > Подробности темы